aboutsummaryrefslogtreecommitdiff
path: root/math/wxmaxima/Makefile
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-30 12:24:12 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-30 12:24:12 +0000
commit39ecea83646e7e90b75ca85473d80140022ac6db (patch)
treee17709b45cee06b91919e42cbb509243ec0638c0 /math/wxmaxima/Makefile
parentb5988a489aad6633e318b430a55ac11cd27004ec (diff)
downloadports-39ecea83646e7e90b75ca85473d80140022ac6db.tar.gz
ports-39ecea83646e7e90b75ca85473d80140022ac6db.zip
Fix build
A C pre-processor conditional interpreted decimal numbers with a leading zero as octal number, which was rejected since it included the digig 8. Removal of the leading 0 from both condition arguments causes the correct interpretation of these numbers as decimal values.
Notes
Notes: svn path=/head/; revision=550692
Diffstat (limited to 'math/wxmaxima/Makefile')
-rw-r--r--math/wxmaxima/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/wxmaxima/Makefile b/math/wxmaxima/Makefile
index 25f8243850d6..b701ac5d71ba 100644
--- a/math/wxmaxima/Makefile
+++ b/math/wxmaxima/Makefile
@@ -3,8 +3,8 @@
PORTNAME= wxmaxima
PORTVERSION= 20.04.0
-PORTREVISION= 1
DISTVERSIONPREFIX= Version-
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= ports@FreeBSD.org
@@ -16,20 +16,20 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= maxima:math/maxima
USES= cmake compiler:c++11-lang desktop-file-utils shared-mime-info
-USE_WX= 3.0
USE_GITHUB= yes
GH_ACCOUNT= wxMaxima-Developers
-PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,}
+USE_WX= 3.0
WX_COMPS= wx
WX_CONF_ARGS= absolute
+PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,}
PORTDATA= COPYING README README.md
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-CMakeLists.txt
NLS_USES= gettext
+NLS_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-CMakeLists.txt
.include <bsd.port.mk>