aboutsummaryrefslogtreecommitdiff
path: root/math/xplot
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-03-06 01:23:08 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-03-06 01:23:08 +0000
commit039046aefda2a34a16471539ba072b841429c072 (patch)
tree5c116e292b83306cfeccd3c8fe0cd5421e4dc620 /math/xplot
parent34ca2fd6458030152504990301ea3c0a95a29b5f (diff)
downloadports-039046aefda2a34a16471539ba072b841429c072.tar.gz
ports-039046aefda2a34a16471539ba072b841429c072.zip
Another plotting utility. Commonly used to plot TCP traces.
Submitted by: fenner (he had to leave so I'm importing it)
Notes
Notes: svn path=/head/; revision=5861
Diffstat (limited to 'math/xplot')
-rw-r--r--math/xplot/Makefile32
-rw-r--r--math/xplot/distinfo1
-rw-r--r--math/xplot/files/patch-aa66
-rw-r--r--math/xplot/pkg-comment1
-rw-r--r--math/xplot/pkg-descr2
-rw-r--r--math/xplot/pkg-plist12
6 files changed, 114 insertions, 0 deletions
diff --git a/math/xplot/Makefile b/math/xplot/Makefile
new file mode 100644
index 000000000000..acb4731837a9
--- /dev/null
+++ b/math/xplot/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xplot
+# Version required: 0.89
+# Date created: 3 March 1997
+# Whom: fenner
+#
+# $Id$
+#
+
+DISTNAME= xplot-0.89
+CATEGORIES= math graphics net
+MASTER_SITES= ftp://mercury.lcs.mit.edu/pub/shep/
+
+MAINTAINER= fenner@FreeBSD.ORG
+
+USE_X11= yes
+GNU_CONFIGURE= yes
+
+XPLOT_DEMOS= demo.0 demo.1 demo.2 demo.3 demo.4 demo.5 demo.6 demo.7
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tcpdump2xplot.pl ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xplot
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xplot
+ ${INSTALL_DATA} ${WRKSRC}/README.tcp_plots ${PREFIX}/share/doc/xplot
+.endif
+ ${MKDIR} ${PREFIX}/share/examples/xplot
+.for i in ${XPLOT_DEMOS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/examples/xplot
+.endfor
+
+.include <bsd.port.mk>
diff --git a/math/xplot/distinfo b/math/xplot/distinfo
new file mode 100644
index 000000000000..bc08c23521ce
--- /dev/null
+++ b/math/xplot/distinfo
@@ -0,0 +1 @@
+MD5 (xplot-0.89.tar.gz) = 4aa3b5b1cf6689abd3cdb5e8f8cfb95d
diff --git a/math/xplot/files/patch-aa b/math/xplot/files/patch-aa
new file mode 100644
index 000000000000..b816568c25b3
--- /dev/null
+++ b/math/xplot/files/patch-aa
@@ -0,0 +1,66 @@
+--- double.c.orig Fri Dec 6 07:40:20 1996
++++ double.c Mon Mar 3 11:41:30 1997
+@@ -32,7 +32,7 @@
+ */
+ #include <X11/Xos.h>
+ #include <math.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdio.h>
+ #include "xplot.h"
+ #include "coord.h"
+--- dtime.c.orig Fri Dec 6 07:40:21 1996
++++ dtime.c Mon Mar 3 11:41:30 1997
+@@ -32,7 +32,7 @@
+ */
+ #include <X11/Xos.h>
+ #include <math.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdio.h>
+ #include "xplot.h"
+ #include "coord.h"
+--- signed.c.orig Thu Mar 23 18:17:51 1995
++++ signed.c Mon Mar 3 11:41:30 1997
+@@ -32,7 +32,7 @@
+ */
+ #include <X11/Xos.h>
+ #include <math.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdio.h>
+ #include "xplot.h"
+ #include "coord.h"
+--- timeval.c.orig Fri Jun 28 12:41:21 1996
++++ timeval.c Mon Mar 3 11:41:31 1997
+@@ -32,7 +32,7 @@
+ */
+ #include <X11/Xos.h>
+ #include <math.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdio.h>
+ #include <ctype.h>
+ #include "xplot.h"
+--- unsigned.c.orig Wed Dec 4 13:35:14 1996
++++ unsigned.c Mon Mar 3 11:41:31 1997
+@@ -32,7 +32,7 @@
+ */
+ #include <X11/Xos.h>
+ #include <math.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include "xplot.h"
+ #include "coord.h"
+ #include <stdio.h>
+--- xplot.c.orig Wed Jan 22 09:38:48 1997
++++ xplot.c Mon Mar 3 11:41:31 1997
+@@ -46,7 +46,7 @@
+ #include <X11/cursorfont.h>
+ #include <math.h>
+ #include <ctype.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include "xplot.h"
+ #include "coord.h"
+
diff --git a/math/xplot/pkg-comment b/math/xplot/pkg-comment
new file mode 100644
index 000000000000..001c93fe8467
--- /dev/null
+++ b/math/xplot/pkg-comment
@@ -0,0 +1 @@
+X-windows plotting package
diff --git a/math/xplot/pkg-descr b/math/xplot/pkg-descr
new file mode 100644
index 000000000000..71cf5c3ea978
--- /dev/null
+++ b/math/xplot/pkg-descr
@@ -0,0 +1,2 @@
+An X-Windows graphing utility. Commonly used to display TCP
+traces.
diff --git a/math/xplot/pkg-plist b/math/xplot/pkg-plist
new file mode 100644
index 000000000000..2c53b6230eb1
--- /dev/null
+++ b/math/xplot/pkg-plist
@@ -0,0 +1,12 @@
+bin/xplot
+bin/tcpdump2xplot.pl
+share/doc/xplot/README
+share/doc/xplot/README.tcp_plots
+share/examples/xplot/demo.0
+share/examples/xplot/demo.1
+share/examples/xplot/demo.2
+share/examples/xplot/demo.3
+share/examples/xplot/demo.4
+share/examples/xplot/demo.5
+share/examples/xplot/demo.6
+share/examples/xplot/demo.7