aboutsummaryrefslogtreecommitdiff
path: root/math/xspread/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-10 13:49:51 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-10 13:49:51 +0000
commitc7865dae4013a8d510a3cb863b9c77fa4e5d1116 (patch)
tree39ff453587ec7bab9d9674ddc347a2559a61c653 /math/xspread/Makefile
parent23cb8d98387903337e8d452c89b67a9b9994d309 (diff)
downloadports-c7865dae4013a8d510a3cb863b9c77fa4e5d1116.tar.gz
ports-c7865dae4013a8d510a3cb863b9c77fa4e5d1116.zip
- Update MASTER_SITES
- Add LICENSE - Add MAKE_JOBS_SAFE - Use PLIST_FILES instead of pkg-plist While I'm here: - Fix COMMENT - Fix build when X11=on - Make sure that configure script looks for x11 libs in right dir when LOCALBASE != /usr/local PR: ports/172033 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=307278
Diffstat (limited to 'math/xspread/Makefile')
-rw-r--r--math/xspread/Makefile43
1 files changed, 33 insertions, 10 deletions
diff --git a/math/xspread/Makefile b/math/xspread/Makefile
index cabcd1d5a1d2..fe2f923f8695 100644
--- a/math/xspread/Makefile
+++ b/math/xspread/Makefile
@@ -1,34 +1,57 @@
-# New ports collection makefile for: xspread
-# Date created: 28 June 1995
-# Whom: janek@gaja.ipan.lublin.pl
-#
+# Created by: janek@gaja.ipan.lublin.pl
# $FreeBSD$
-#
PORTNAME= xspread
PORTVERSION= 3.1.1c
PORTREVISION= 2
CATEGORIES= math
-MASTER_SITES= # disappeared
+MASTER_SITES= http://archive.debian.org/%SUBDIR%/ \
+ http://mirror.safehostnet.com/debian-archive/%SUBDIR%/ \
+ http://mirrors.xmission.com/debian-archive/%SUBDIR%/ \
+ http://vos-systems.net/ftp/%SUBDIR%/
+MASTER_SITE_SUBDIR= debian/dists/potato/main/source/math
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
-COMMENT= A spreadsheet program for X and terminals
+COMMENT= Spreadsheet program for X and terminals
+
+LICENSE= GPLv2 # (or later)
+
+OPTIONS_DEFINE= X11 DOCS
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CPPFLAGS+= -I${LOCALBASE}/include
+MAKE_JOBS_SAFE= yes
MAN1= xspread.1 pxspread.1
+PORTDOCS= *
+PLIST_FILES= bin/pxspread bin/xspread
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
+USE_XORG= x11 xau xdmcp xt
+LIB_DEPENDS+= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ xcb:${PORTSDIR}/x11/libxcb
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+.else
+CONFIGURE_ENV+= ac_cv_header_X11_X_h=no
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} 's|/usr/local/lib/libXt|${LOCALBASE}/lib/libXt|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|^void main|int main|' ${WRKSRC}/psc.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pxspread ${PREFIX}/bin/pxspread
${INSTALL_PROGRAM} ${WRKSRC}/xspread ${PREFIX}/bin/xspread
${INSTALL_MAN} ${WRKSRC}/pxspread.man ${MANPREFIX}/man/man1/pxspread.1
${INSTALL_MAN} ${WRKSRC}/xspread.man ${MANPREFIX}/man/man1/xspread.1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/x/notes ${DOCSDIR}