aboutsummaryrefslogtreecommitdiff
path: root/math/xtensor/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-12 08:56:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-12 08:56:30 +0000
commit8f733ea1be989de95acc98396f898e4a5f520d45 (patch)
treebdf72b6c91eb141fb060ad49702158add7c7ce21 /math/xtensor/Makefile
parent781ec3cca43f76744a41591206928f93171c88f9 (diff)
downloadports-8f733ea1be989de95acc98396f898e4a5f520d45.tar.gz
ports-8f733ea1be989de95acc98396f898e4a5f520d45.zip
New port: math/xtensor: Multi-dimensional arrays with broadcasting and lazy computing
Notes
Notes: svn path=/head/; revision=464237
Diffstat (limited to 'math/xtensor/Makefile')
-rw-r--r--math/xtensor/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/xtensor/Makefile b/math/xtensor/Makefile
new file mode 100644
index 000000000000..e0e00db06db1
--- /dev/null
+++ b/math/xtensor/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= xtensor
+DISTVERSION= 0.15.4
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Multi-dimensional arrays with broadcasting and lazy computing
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= googletest>0:devel/googletest
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= QuantStack
+GH_TUPLE= QuantStack:xtl:0.4.4:xtl/xtl
+NO_BUILD= yes
+NO_ARCH= yes
+
+post-install:
+ cd ${WRKSRC}/xtl/include && ${COPYTREE_SHARE} xtl ${STAGEDIR}${PREFIX}/include
+
+do-test: # 1 test is known to fail: https://github.com/QuantStack/xtensor/issues/674
+ @${RLN} ${STAGEDIR}${PREFIX}/include ${WRKSRC}/test/staged-include
+ @cd ${WRKSRC}/test && \
+ ${CMAKE_BIN} ${CMAKE_ARGS} . && \
+ ${MAKE_CMD} && \
+ ${MAKE_CMD} xtest
+
+.include <bsd.port.mk>