aboutsummaryrefslogtreecommitdiff
path: root/math/yacas
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-10 10:43:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-10 10:43:51 +0000
commit204477968748c985cb7715b9230de44ef757fcd1 (patch)
treeb5d83a5224b0c278ec1d696359f216bc61cc4352 /math/yacas
parent5cc4c102ee8454d657efb59e628ad52c05e15591 (diff)
downloadports-204477968748c985cb7715b9230de44ef757fcd1.tar.gz
ports-204477968748c985cb7715b9230de44ef757fcd1.zip
upgrade to 1.0.54
PR: 50016 Submitted by: Thomas E. Zander <riggs@rrr.de>
Notes
Notes: svn path=/head/; revision=78697
Diffstat (limited to 'math/yacas')
-rw-r--r--math/yacas/Makefile6
-rw-r--r--math/yacas/distinfo2
-rw-r--r--math/yacas/files/patch-configure59
-rw-r--r--math/yacas/files/patch-gmpnumbers.cpp15
-rw-r--r--math/yacas/pkg-plist74
5 files changed, 117 insertions, 39 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 0e5d97153db1..7c4a70542da1 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME= yacas
-PORTVERSION= 1.0.53r1
+PORTVERSION= 1.0.54
CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://yacas.sourceforge.net/backups/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/r/rev/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
diff --git a/math/yacas/distinfo b/math/yacas/distinfo
index c0a5fcfcae04..d7b623e17413 100644
--- a/math/yacas/distinfo
+++ b/math/yacas/distinfo
@@ -1 +1 @@
-MD5 (yacas-1.0.53rev1.tar.gz) = 2e938e2ec8f7552259439f2a5909803e
+MD5 (yacas-1.0.54.tar.gz) = 282e705b3a7466d31dc7ee6a76158d21
diff --git a/math/yacas/files/patch-configure b/math/yacas/files/patch-configure
index 90931a95f3c3..04aba66cf229 100644
--- a/math/yacas/files/patch-configure
+++ b/math/yacas/files/patch-configure
@@ -1,32 +1,41 @@
---- configure.orig Fri May 24 06:40:55 2002
-+++ configure Fri May 24 14:38:40 2002
-@@ -1966,9 +1966,9 @@
- fi
-
- if test "$enable_gmp" = "yes" ; then
-- echo $ac_n "checking for __gmpz_init in -lgmp""... $ac_c" 1>&6
--echo "configure:1971: checking for __gmpz_init in -lgmp" >&5
--ac_lib_var=`echo gmp'_'__gmpz_init | sed 'y%./+-%__p_%'`
-+ echo $ac_n "checking for mpz_init in -lgmp""... $ac_c" 1>&6
-+echo "configure:1971: checking for mpz_init in -lgmp" >&5
-+ac_lib_var=`echo gmp'_'mpz_init | sed 'y%./+-%__p_%'`
- if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
+--- configure.orig Sat Jan 18 22:23:21 2003
++++ configure Sat Mar 15 11:51:16 2003
+@@ -6932,9 +6932,9 @@
+ gmp)
+ echo "$as_me:$LINENO: result: gmp" >&5
+ echo "${ECHO_T}gmp" >&6
+- echo "$as_me:$LINENO: checking for __gmpz_init in -lgmp" >&5
+-echo $ECHO_N "checking for __gmpz_init in -lgmp... $ECHO_C" >&6
+-if test "${ac_cv_lib_gmp___gmpz_init+set}" = set; then
++ echo "$as_me:$LINENO: checking for mpz_init in -lgmp" >&5
++echo $ECHO_N "checking for mpz_init in -lgmp... $ECHO_C" >&6
++if test "${ac_cv_lib_gmp_mpz_init+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
else
-@@ -1977,13 +1977,14 @@
- cat > conftest.$ac_ext <<EOF
- #line 1979 "configure"
+ ac_check_lib_save_LIBS=$LIBS
+@@ -6942,6 +6942,7 @@
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
#include "confdefs.h"
+#include <gmp.h>
+
/* Override any gcc2 internal prototype to avoid an error. */
+ #ifdef __cplusplus
+@@ -6949,7 +6950,6 @@
+ #endif
/* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
--char __gmpz_init();
-
- int main() {
--__gmpz_init()
+ builtin and then its argument prototype would still apply. */
+-char __gmpz_init ();
+ #ifdef F77_DUMMY_MAIN
+ # ifdef __cplusplus
+ extern "C"
+@@ -6959,7 +6959,8 @@
+ int
+ main ()
+ {
+-__gmpz_init ();
+mpz_t integ;
+mpz_init(integ)
- ; return 0; }
- EOF
- if { (eval echo configure:1990: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ ;
+ return 0;
+ }
diff --git a/math/yacas/files/patch-gmpnumbers.cpp b/math/yacas/files/patch-gmpnumbers.cpp
index d78fa944dc2c..25243ed17c3e 100644
--- a/math/yacas/files/patch-gmpnumbers.cpp
+++ b/math/yacas/files/patch-gmpnumbers.cpp
@@ -1,6 +1,6 @@
---- src/gmpnumbers.cpp.orig Sat Jan 4 21:21:22 2003
-+++ src/gmpnumbers.cpp Sat Jan 4 22:22:56 2003
-@@ -70,25 +70,19 @@
+--- src/gmpnumbers.cpp.orig Tue Dec 10 01:30:35 2002
++++ src/gmpnumbers.cpp Sat Mar 15 12:02:41 2003
+@@ -81,25 +81,19 @@
void initGMPNumber(GMPNumber& x, GMPNumber& y)
{
@@ -11,8 +11,7 @@
x.exp = y.exp;
}
--void initGMPNumber(GMPNumber& x, long y=0)
-+void initGMPNumber(GMPNumber& x, long y)
+ void initGMPNumber(GMPNumber& x, long y)
{
- mpz_t man;
- mpz_init_set_ui(man,y);
@@ -30,7 +29,7 @@
x.exp = 0;
}
-@@ -137,11 +131,9 @@
+@@ -148,11 +142,9 @@
exp++;
}
if (!*man) {*man='0';*(man+1)='\0';neg=0;exp=0;}
@@ -44,7 +43,7 @@
x.exp=exp;
}
-@@ -158,7 +150,7 @@
+@@ -169,7 +161,7 @@
free(str);
}
@@ -53,7 +52,7 @@
{
long rawsize = mpz_sizeinbase(x.man,10);
size_t size;
-@@ -229,7 +221,7 @@
+@@ -240,7 +232,7 @@
}
static LispStringPtr GMPNumberToString(GMPNumber& x, LispHashTable& h,
diff --git a/math/yacas/pkg-plist b/math/yacas/pkg-plist
index f5f0aad6c11c..512a3e149a9c 100644
--- a/math/yacas/pkg-plist
+++ b/math/yacas/pkg-plist
@@ -1,7 +1,6 @@
bin/yacas
bin/yacas_client
bin/ytxt2tex
-share/yacas/addons/README
share/yacas/addons/editvi.ys
share/yacas/addons/editvi.ys.def
share/yacas/addons/unix.ys
@@ -12,6 +11,10 @@ share/yacas/assoc.rep/code.ys
share/yacas/assoc.rep/code.ys.def
share/yacas/c_form.rep/code.ys
share/yacas/c_form.rep/code.ys.def
+share/yacas/codecheck.rep/interface.ys
+share/yacas/codecheck.rep/interface.ys.def
+share/yacas/codecheck.rep/process.ys
+share/yacas/codecheck.rep/process.ys.def
share/yacas/complex.rep/code.ys
share/yacas/complex.rep/code.ys.def
share/yacas/complex.rep/om.ys
@@ -22,18 +25,23 @@ share/yacas/controlflow.rep/code.ys
share/yacas/controlflow.rep/code.ys.def
share/yacas/cstubgen.rep/code.ys
share/yacas/cstubgen.rep/code.ys.def
+share/yacas/debug.rep/code.ys
+share/yacas/debug.rep/code.ys.def
share/yacas/deffunc.rep/code.ys
share/yacas/deffunc.rep/code.ys.def
share/yacas/deriv.rep/code.ys
share/yacas/deriv.rep/code.ys.def
+share/yacas/documentation/Algo.html
share/yacas/documentation/Algochapter1.html
share/yacas/documentation/Algochapter2.html
share/yacas/documentation/Algochapter3.html
share/yacas/documentation/Algochapter4.html
share/yacas/documentation/Algochapter5.html
share/yacas/documentation/Algochapter6.html
+share/yacas/documentation/Algochapter7.html
share/yacas/documentation/Algochapters.html
share/yacas/documentation/Algomanual.html
+share/yacas/documentation/LispProgramming.html
share/yacas/documentation/LispProgrammingchapter1.html
share/yacas/documentation/LispProgrammingchapter2.html
share/yacas/documentation/LispProgrammingchapter3.html
@@ -41,7 +49,21 @@ share/yacas/documentation/LispProgrammingchapter4.html
share/yacas/documentation/LispProgrammingchapter5.html
share/yacas/documentation/LispProgrammingchapters.html
share/yacas/documentation/LispProgrammingmanual.html
+share/yacas/documentation/NewDesign.html
+share/yacas/documentation/NewDesignchapter1.html
+share/yacas/documentation/NewDesignchapter10.html
+share/yacas/documentation/NewDesignchapter2.html
+share/yacas/documentation/NewDesignchapter3.html
+share/yacas/documentation/NewDesignchapter4.html
+share/yacas/documentation/NewDesignchapter5.html
+share/yacas/documentation/NewDesignchapter6.html
+share/yacas/documentation/NewDesignchapter7.html
+share/yacas/documentation/NewDesignchapter8.html
+share/yacas/documentation/NewDesignchapter9.html
+share/yacas/documentation/NewDesignchapters.html
+share/yacas/documentation/NewDesignmanual.html
share/yacas/documentation/books.html
+share/yacas/documentation/coding.html
share/yacas/documentation/codingchapter1.html
share/yacas/documentation/codingchapter2.html
share/yacas/documentation/codingchapter3.html
@@ -50,8 +72,10 @@ share/yacas/documentation/codingchapter5.html
share/yacas/documentation/codingchapter6.html
share/yacas/documentation/codingchapter7.html
share/yacas/documentation/codingchapter8.html
+share/yacas/documentation/codingchapter9.html
share/yacas/documentation/codingchapters.html
share/yacas/documentation/codingmanual.html
+share/yacas/documentation/essays.html
share/yacas/documentation/essayschapter1.html
share/yacas/documentation/essayschapter2.html
share/yacas/documentation/essayschapter3.html
@@ -59,8 +83,10 @@ share/yacas/documentation/essayschapter4.html
share/yacas/documentation/essayschapter5.html
share/yacas/documentation/essayschapter6.html
share/yacas/documentation/essayschapter7.html
+share/yacas/documentation/essayschapter8.html
share/yacas/documentation/essayschapters.html
share/yacas/documentation/essaysmanual.html
+share/yacas/documentation/intro.html
share/yacas/documentation/introchapter1.html
share/yacas/documentation/introchapter2.html
share/yacas/documentation/introchapter3.html
@@ -79,6 +105,10 @@ share/yacas/documentation/refchapter15.html
share/yacas/documentation/refchapter16.html
share/yacas/documentation/refchapter17.html
share/yacas/documentation/refchapter18.html
+share/yacas/documentation/refchapter19.html
+share/yacas/documentation/refchapter20.html
+share/yacas/documentation/refchapter21.html
+share/yacas/documentation/refchapter22.html
share/yacas/documentation/refchapter2.html
share/yacas/documentation/refchapter3.html
share/yacas/documentation/refchapter4.html
@@ -89,7 +119,9 @@ share/yacas/documentation/refchapter8.html
share/yacas/documentation/refchapter9.html
share/yacas/documentation/refchapters.html
share/yacas/documentation/refmanual.html
+share/yacas/documentation/refprog.html
share/yacas/documentation/refprogchapter1.html
+share/yacas/documentation/refprogchapter10.html
share/yacas/documentation/refprogchapter2.html
share/yacas/documentation/refprogchapter3.html
share/yacas/documentation/refprogchapter4.html
@@ -97,6 +129,7 @@ share/yacas/documentation/refprogchapter5.html
share/yacas/documentation/refprogchapter6.html
share/yacas/documentation/refprogchapter7.html
share/yacas/documentation/refprogchapter8.html
+share/yacas/documentation/refprogchapter9.html
share/yacas/documentation/refprogchapters.html
share/yacas/documentation/refprogmanual.html
share/yacas/documentation/yacaslogo.gif
@@ -122,6 +155,7 @@ share/yacas/functional.rep/code.ys.def
share/yacas/glview.ys
share/yacas/html.rep/code.ys
share/yacas/html.rep/code.ys.def
+share/yacas/include/GPL_stuff.h
share/yacas/include/anumber.h
share/yacas/include/anumber.inl
share/yacas/include/archiver.h
@@ -130,11 +164,16 @@ share/yacas/include/arrayclass.h
share/yacas/include/arrayclass.inl
share/yacas/include/choices.h
share/yacas/include/commandline.h
+share/yacas/include/compressedfiles.h
share/yacas/include/ctokenizer.h
+share/yacas/include/cyacas.h
share/yacas/include/debugmem.h
share/yacas/include/deffile.h
share/yacas/include/deffile.inl
share/yacas/include/elfdll.h
+share/yacas/include/epoccli.h
+share/yacas/include/epocclsv.h
+share/yacas/include/epocserv.h
share/yacas/include/errors.h
share/yacas/include/evalfunc.h
share/yacas/include/genericobject.h
@@ -188,6 +227,9 @@ share/yacas/include/unipoly.h
share/yacas/include/unixcommandline.h
share/yacas/include/version.h
share/yacas/include/win32dll.h
+share/yacas/include/win32dllresource.h
+share/yacas/include/win32yacasdll.h
+share/yacas/include/win32yacasdllresource.h
share/yacas/include/xmltokenizer.h
share/yacas/include/yacas.h
share/yacas/include/yacasbase.h
@@ -214,7 +256,6 @@ share/yacas/localrules.rep/code.ys.def
share/yacas/logic.rep/code.ys
share/yacas/logic.rep/code.ys.def
share/yacas/logic.rep/om.ys
-share/yacas/maketest
share/yacas/manmake/book2TeX.sh
share/yacas/manmake/book2TeX.ys
share/yacas/manmake/txt2yacasdoc.pl
@@ -226,22 +267,37 @@ share/yacas/multivar.rep/sparsetree.ys
share/yacas/multivar.rep/sparsetree.ys.def
share/yacas/newly.rep/code.ys
share/yacas/newly.rep/code.ys.def
+share/yacas/numbers.rep/GaussianIntegers.ys
+share/yacas/numbers.rep/GaussianIntegers.ys.def
+share/yacas/numbers.rep/NumberTheory.ys
+share/yacas/numbers.rep/NumberTheory.ys.def
share/yacas/numbers.rep/code.ys
share/yacas/numbers.rep/code.ys.def
+share/yacas/numbers.rep/nthroot.ys
+share/yacas/numbers.rep/nthroot.ys.def
share/yacas/odesolver.rep/code.ys
share/yacas/odesolver.rep/code.ys.def
share/yacas/openmath.rep/code.ys
share/yacas/openmath.rep/code.ys.def
share/yacas/orthopoly.rep/code.ys
share/yacas/orthopoly.rep/code.ys.def
+share/yacas/osdep.rep/code.ys
+share/yacas/osdep.rep/code.ys.def
+share/yacas/osdep.rep/unix.ys
+share/yacas/osdep.rep/win32.ys
share/yacas/packages.ys
share/yacas/padic.rep/code.ys
share/yacas/padic.rep/code.ys.def
share/yacas/patterns.rep/code.ys
share/yacas/patterns.rep/code.ys.def
share/yacas/plots.rep/backends-2d.ys
+share/yacas/plots.rep/backends-3d.ys
share/yacas/plots.rep/code.ys
share/yacas/plots.rep/code.ys.def
+share/yacas/plots.rep/plot2d.ys
+share/yacas/plots.rep/plot2d.ys.def
+share/yacas/plots.rep/plot3d.ys
+share/yacas/plots.rep/plot3d.ys.def
share/yacas/predicates.rep/code.ys
share/yacas/predicates.rep/code.ys.def
share/yacas/probability.rep/code.ys
@@ -272,6 +328,8 @@ share/yacas/specfunc.rep/zeta.ys
share/yacas/specfunc.rep/zeta.ys.def
share/yacas/standard.ys
share/yacas/standard.ys.def
+share/yacas/statistics.rep/distributions.ys
+share/yacas/statistics.rep/distributions.ys.def
share/yacas/statistics.rep/hypothesystest.ys
share/yacas/statistics.rep/incompletegamma.ys.def
share/yacas/statistics.rep/regression.ys.def
@@ -285,6 +343,8 @@ share/yacas/stats.rep/code.ys
share/yacas/stats.rep/code.ys.def
share/yacas/stdfuncs.rep/code.ys
share/yacas/stdfuncs.rep/code.ys.def
+share/yacas/stdfuncs.rep/elemfuncs.ys
+share/yacas/stdfuncs.rep/elemfuncs.ys.def
share/yacas/stdfuncs.rep/numerical.ys
share/yacas/stdfuncs.rep/numerical.ys.def
share/yacas/stdfuncs.rep/nummethods.ys
@@ -304,8 +364,14 @@ share/yacas/testers.rep/code.ys
share/yacas/testers.rep/code.ys.def
share/yacas/texform.rep/code.ys
share/yacas/texform.rep/code.ys.def
+share/yacas/transforms.rep/code.ys
+share/yacas/transforms.rep/code.ys.def
share/yacas/trigsimp.rep/code.ys
share/yacas/trigsimp.rep/code.ys.def
+share/yacas/univar.rep/Cyclotomic.ys
+share/yacas/univar.rep/Cyclotomic.ys.def
+share/yacas/univar.rep/sparse.ys
+share/yacas/univar.rep/sparse.ys.def
share/yacas/univar.rep/code.ys
share/yacas/univar.rep/code.ys.def
share/yacas/univar.rep/sturm.ys
@@ -316,9 +382,11 @@ share/yacas/yacasinit.ys
@dirrm share/yacas/assoc.rep
@dirrm share/yacas/c_form.rep
@dirrm share/yacas/complex.rep
+@dirrm share/yacas/codecheck.rep
@dirrm share/yacas/constants.rep
@dirrm share/yacas/controlflow.rep
@dirrm share/yacas/cstubgen.rep
+@dirrm share/yacas/debug.rep
@dirrm share/yacas/deffunc.rep
@dirrm share/yacas/deriv.rep
@dirrm share/yacas/documentation
@@ -344,6 +412,7 @@ share/yacas/yacasinit.ys
@dirrm share/yacas/odesolver.rep
@dirrm share/yacas/openmath.rep
@dirrm share/yacas/orthopoly.rep
+@dirrm share/yacas/osdep.rep
@dirrm share/yacas/padic.rep
@dirrm share/yacas/patterns.rep
@dirrm share/yacas/plots.rep
@@ -364,6 +433,7 @@ share/yacas/yacasinit.ys
@dirrm share/yacas/tensor.rep
@dirrm share/yacas/testers.rep
@dirrm share/yacas/texform.rep
+@dirrm share/yacas/transforms.rep
@dirrm share/yacas/trigsimp.rep
@dirrm share/yacas/univar.rep
@dirrm share/yacas/probability.rep