aboutsummaryrefslogtreecommitdiff
path: root/math/yacas
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-03 15:04:21 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-03 15:04:21 +0000
commitc61156c3cbc233e0116d100f10ac9ad5ffec9f46 (patch)
treef5a28bfdf69d2947e14c2ac7609ab4c3f551e678 /math/yacas
parent1c6ee08b26c9face9888f48fa1860439674e6096 (diff)
downloadports-c61156c3cbc233e0116d100f10ac9ad5ffec9f46.tar.gz
ports-c61156c3cbc233e0116d100f10ac9ad5ffec9f46.zip
- Update to 1.3.4
Notes
Notes: svn path=/head/; revision=342453
Diffstat (limited to 'math/yacas')
-rw-r--r--math/yacas/Makefile32
-rw-r--r--math/yacas/distinfo4
-rw-r--r--math/yacas/files/patch-manmake_wester-1994.chapt.txt11
-rw-r--r--math/yacas/files/patch-scripts_Makefile.am11
-rw-r--r--math/yacas/files/patch-scripts_Makefile.in11
-rw-r--r--math/yacas/pkg-plist19
6 files changed, 44 insertions, 44 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 4de3ee2d9e97..2b6ca38ab4e9 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= yacas
-PORTVERSION= 1.3.3
+PORTVERSION= 1.3.4
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION:R}/
@@ -12,11 +12,9 @@ COMMENT= Yet Another Computer Algebra System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= TESTS DOCS
-OPTIONS_DEFAULT=TESTS
-TESTS_DESC= Run bundled self-tests after build
+OPTIONS_DEFINE= DOCS
-USES= gmake
+#USES= gmake
GNU_CONFIGURE= yes
.include <bsd.port.options.mk>
@@ -28,24 +26,22 @@ BROKEN= Does not compile with GCC 4.2
.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--enable-html-doc --with-html-dir=${DOCSDIR}
PORTDOCS= *
-USES+= perl5
-USE_PERL5= build
+USES+= perl5
+USE_PERL5= build
.else
CONFIGURE_ARGS+=--disable-html-doc
.endif
-.if ${PORT_OPTIONS:MTESTS}
-BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e \
- 's| /bin/bash| ${LOCALBASE}/bin/bash|' ${WRKSRC}/tests/test-yacas
-
-post-build:
-.if ${PORT_OPTIONS:MTESTS}
+# Can't use USES=shebangfix here, cause the path appears several
+# times in the file.
+ @${REINPLACE_CMD} -e 's| /bin/bash| ${LOCALBASE}/bin/bash|g' \
+ ${WRKSRC}/tests/test-yacas
+
+regression-test: build
+# This requires bash. I don't add it as a dependency to the port, as it's
+# not needed for the general use.
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- ${MAKEFILE} check ${MAKE_ARGS})
-.endif
+ ${MAKEFILE} check ${MAKE_ARGS})
.include <bsd.port.mk>
diff --git a/math/yacas/distinfo b/math/yacas/distinfo
index b1939a50706b..a5dafe6777ea 100644
--- a/math/yacas/distinfo
+++ b/math/yacas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (yacas-1.3.3.tar.gz) = 6c73c653c5e13567510888800a68c14d231b1ef4f2b33193a158b8caec142141
-SIZE (yacas-1.3.3.tar.gz) = 1296777
+SHA256 (yacas-1.3.4.tar.gz) = 18482f22d6a8336e9ebfda3bec045da70db2da68ae02f32987928a3c67284233
+SIZE (yacas-1.3.4.tar.gz) = 1360604
diff --git a/math/yacas/files/patch-manmake_wester-1994.chapt.txt b/math/yacas/files/patch-manmake_wester-1994.chapt.txt
deleted file mode 100644
index 9303d57c6156..000000000000
--- a/math/yacas/files/patch-manmake_wester-1994.chapt.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- manmake/wester-1994.chapt.txt.orig 2012-09-26 12:02:56.000000000 +0200
-+++ manmake/wester-1994.chapt.txt 2012-09-26 12:03:11.000000000 +0200
-@@ -96,7 +96,7 @@
- * 62. (OK) Invert a 2x2 symbolic matrix.
- Verify(Simplify(Inverse({{a,b},{1,a*b}})),
- {{a/(a^2-1), -1/(a^2-1)},
-- {-1/(b*(a^2-1)), a/(b*(a^2-1))}});
-+ {-1/((a^2-1)*b), a/((a^2-1)*b)}});
- * 63. (BUG) Compute the determinant of the 4x4 Vandermonde matrix.
- Factor(Determinant(VandermondeMatrix
- ({a,b,c,d})));
diff --git a/math/yacas/files/patch-scripts_Makefile.am b/math/yacas/files/patch-scripts_Makefile.am
new file mode 100644
index 000000000000..ef5bbba8f593
--- /dev/null
+++ b/math/yacas/files/patch-scripts_Makefile.am
@@ -0,0 +1,11 @@
+--- scripts/Makefile.am.orig 2014-02-03 10:39:12.000000000 +0100
++++ scripts/Makefile.am 2014-02-03 10:39:21.000000000 +0100
+@@ -164,7 +164,7 @@
+ @(diff scripts-listed-in-makefile.txt contents-of-tree.txt; \
+ rm -f scripts-listed-in-makefile.txt contents-of-tree.txt; \
+ RV=$$?; \
+- if [[ $$RV == 0 ]] ; \
++ if [ $$RV = 0 ] ; \
+ then echo " ... ok"; \
+ else \
+ false; \
diff --git a/math/yacas/files/patch-scripts_Makefile.in b/math/yacas/files/patch-scripts_Makefile.in
new file mode 100644
index 000000000000..247b34c06ad2
--- /dev/null
+++ b/math/yacas/files/patch-scripts_Makefile.in
@@ -0,0 +1,11 @@
+--- scripts/Makefile.in.orig 2014-02-03 10:37:08.000000000 +0100
++++ scripts/Makefile.in 2014-02-03 10:38:36.000000000 +0100
+@@ -562,7 +562,7 @@
+ @(diff scripts-listed-in-makefile.txt contents-of-tree.txt; \
+ rm -f scripts-listed-in-makefile.txt contents-of-tree.txt; \
+ RV=$$?; \
+- if [[ $$RV == 0 ]] ; \
++ if [ $$RV = 0 ] ; \
+ then echo " ... ok"; \
+ else \
+ false; \
diff --git a/math/yacas/pkg-plist b/math/yacas/pkg-plist
index ceb8ae31edbb..f57eb037beeb 100644
--- a/math/yacas/pkg-plist
+++ b/math/yacas/pkg-plist
@@ -26,7 +26,7 @@ bin/ytxt2tex
%%DATADIR%%/deriv.rep/code.ys
%%DATADIR%%/deriv.rep/code.ys.def
%%DATADIR%%/documentation/hints
-%%DATADIR%%/documentation/yacaslogo.gif
+%%DATADIR%%/documentation/yacaslogo.png
%%DATADIR%%/example.rep/code.ys
%%DATADIR%%/example.rep/code.ys.def
%%DATADIR%%/examples/ABIN.ys
@@ -47,18 +47,18 @@ bin/ytxt2tex
%%DATADIR%%/functional.rep/code.ys
%%DATADIR%%/functional.rep/code.ys.def
%%DATADIR%%/functional.rep/om.ys
+%%DATADIR%%/graph.rep/code.ys
+%%DATADIR%%/graph.rep/code.ys.def
%%DATADIR%%/html.rep/code.ys
%%DATADIR%%/html.rep/code.ys.def
%%DATADIR%%/include/GPL_stuff.h
%%DATADIR%%/include/anumber.h
%%DATADIR%%/include/anumber.inl
-%%DATADIR%%/include/archiver.h
%%DATADIR%%/include/arggetter.h
%%DATADIR%%/include/arrayclass.h
%%DATADIR%%/include/arrayclass.inl
%%DATADIR%%/include/choices.h
%%DATADIR%%/include/commandline.h
-%%DATADIR%%/include/compressedfiles.h
%%DATADIR%%/include/core_yacasmain.h
%%DATADIR%%/include/corefunctions.h
%%DATADIR%%/include/debugmem.h
@@ -66,7 +66,6 @@ bin/ytxt2tex
%%DATADIR%%/include/deffile.inl
%%DATADIR%%/include/errors.h
%%DATADIR%%/include/evalfunc.h
-%%DATADIR%%/include/filescanner.h
%%DATADIR%%/include/genericobject.h
%%DATADIR%%/include/genericstructs.h
%%DATADIR%%/include/grower.h
@@ -88,22 +87,17 @@ bin/ytxt2tex
%%DATADIR%%/include/lispparser.h
%%DATADIR%%/include/lispstring.h
%%DATADIR%%/include/lispstring.inl
+%%DATADIR%%/include/lisptype.h
%%DATADIR%%/include/lispuserfunc.h
-%%DATADIR%%/include/log.h
-%%DATADIR%%/include/lzoconf.h
-%%DATADIR%%/include/lzodefs.h
%%DATADIR%%/include/mathcommands.h
%%DATADIR%%/include/mathenvironment.h
%%DATADIR%%/include/mathuserfunc.h
%%DATADIR%%/include/mathutil.h
-%%DATADIR%%/include/minilzo.h
%%DATADIR%%/include/numbers.h
%%DATADIR%%/include/patcher.h
%%DATADIR%%/include/patternclass.h
%%DATADIR%%/include/patterns.h
-%%DATADIR%%/include/plat/linux32/lisptype.h
-%%DATADIR%%/include/plat/linux32/platfileio.h
-%%DATADIR%%/include/plat/linux32/stubs.inl
+%%DATADIR%%/include/platfileio.h
%%DATADIR%%/include/platmath.h
%%DATADIR%%/include/refcount.h
%%DATADIR%%/include/standard.h
@@ -310,10 +304,9 @@ bin/ytxt2tex
@dirrm %%DATADIR%%/limit.rep
@dirrm %%DATADIR%%/io.rep
@dirrm %%DATADIR%%/integrate.rep
-@dirrm %%DATADIR%%/include/plat/linux32
-@dirrm %%DATADIR%%/include/plat
@dirrm %%DATADIR%%/include
@dirrm %%DATADIR%%/html.rep
+@dirrm %%DATADIR%%/graph.rep
@dirrm %%DATADIR%%/functional.rep
@dirrm %%DATADIR%%/factors.rep
@dirrm %%DATADIR%%/examples