aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-06-21 01:46:10 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-06-21 01:46:10 +0000
commit3895d16357c5b27f246cfaaa1b5b6876139a10ca (patch)
treec22df829f1dc9423d76ef71fa206d5a990c395ec /math
parent0e9d2323d30eba26221a91443964dd7f3ff55375 (diff)
downloadports-3895d16357c5b27f246cfaaa1b5b6876139a10ca.tar.gz
ports-3895d16357c5b27f246cfaaa1b5b6876139a10ca.zip
- New port math/octave-forge-octclip
This is octclip. This package allows to do boolean operations with polygons using the Greiner-Hormann algorithm. The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. WWW: http://octave.sourceforge.net/ PR: ports/157969 Submitted by: stephen Approved by: maho (mentor)
Notes
Notes: svn path=/head/; revision=275949
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-octclip/Makefile25
-rw-r--r--math/octave-forge-octclip/distinfo2
-rw-r--r--math/octave-forge-octclip/pkg-descr11
-rw-r--r--math/octave-forge-octclip/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 6b008d49e79e..bd7f0bd30f8b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -259,6 +259,7 @@
SUBDIR += octave-forge-ocs
SUBDIR += octave-forge-oct2mat
SUBDIR += octave-forge-octcdf
+ SUBDIR += octave-forge-octclip
SUBDIR += octave-forge-octgpr
SUBDIR += octave-forge-octproj
SUBDIR += octave-forge-odebvp
diff --git a/math/octave-forge-octclip/Makefile b/math/octave-forge-octclip/Makefile
new file mode 100644
index 000000000000..bdd116d98a83
--- /dev/null
+++ b/math/octave-forge-octclip/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: octave-forge-octclip
+# Date created: 13 Janurary 2011
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-octclip
+PORTVERSION= 1.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+post-extract:
+ ${REINPLACE_CMD} s/CC/MKOCTFILE/ ${WRKSRC}/Makefile
+
+post-build:
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-octclip/distinfo b/math/octave-forge-octclip/distinfo
new file mode 100644
index 000000000000..aa8a3ab1cf0b
--- /dev/null
+++ b/math/octave-forge-octclip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/octclip-1.0.0.tar.gz) = f7b279a719ca03391e82fb0556d33f64b39eb3cfc3cfe1f2ba419ce4e9e813a1
+SIZE (octave-forge/octclip-1.0.0.tar.gz) = 276258
diff --git a/math/octave-forge-octclip/pkg-descr b/math/octave-forge-octclip/pkg-descr
new file mode 100644
index 000000000000..01ce40a87a74
--- /dev/null
+++ b/math/octave-forge-octclip/pkg-descr
@@ -0,0 +1,11 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is octclip.
+
+This package allows to do boolean operations with polygons using the
+Greiner-Hormann algorithm.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-octclip/pkg-plist b/math/octave-forge-octclip/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-octclip/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty