aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-01 16:46:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-01 17:22:09 +0000
commit423f7e59deed2cba591b8799b2183047326eafdd (patch)
tree23b20281c6b4df23119d37acb166fb4736d22323 /math
parent5652b672f77b87c35c371d57511248732a3a1d18 (diff)
downloadports-423f7e59deed2cba591b8799b2183047326eafdd.tar.gz
ports-423f7e59deed2cba591b8799b2183047326eafdd.zip
math/SCIP: Add the ZIMPL option
Diffstat (limited to 'math')
-rw-r--r--math/SCIP/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/math/SCIP/Makefile b/math/SCIP/Makefile
index 2b876a79b840..5170c45b1156 100644
--- a/math/SCIP/Makefile
+++ b/math/SCIP/Makefile
@@ -2,6 +2,7 @@
PORTNAME= SCIP
DISTVERSION= 7.0.3
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= https://www.scipopt.org/download/release/
DISTNAME= ${PORTNAME:tl}-${DISTVERSION}
@@ -22,19 +23,23 @@ USES= compiler:c11 cmake readline tar:tgz
EXTRACT_CMD= gtar
USE_LDCONFIG= yes
-CMAKE_OFF= PAPILO ZIMPL
+CMAKE_OFF= PAPILO
CXXFLAGS+= -I${LOCALBASE}/include/soplex
-OPTIONS_DEFINE= IPOPT
+OPTIONS_DEFINE= IPOPT ZIMPL
OPTIONS_DEFAULT= IPOPT
IPOPT_DESC= Non-linear optimization support via Ipopt
IPOPT_USES= fortran pkgconfig
+IPOPT_CMAKE_BOOL= IPOPT
IPOPT_LIB_DEPENDS= libblas.so:math/blas \
libipopt.so:math/ipopt \
liblapack.so:math/lapack
-IPOPT_CMAKE_BOOL= IPOPT
+ZIMPL_DESC= Build with Zimpl to translate LP models
+ZIMPL_CMAKE_BOOL= ZIMPL
+ZIMPL_LIB_DEPENDS= libzimpl.so:math/zimpl
+ZIMPL_BROKEN= see https://github.com/scipopt/scip/issues/4
.include <bsd.port.mk>