aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2019-11-14 20:56:04 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2019-11-14 20:56:04 +0000
commit45938639f0111f42e1b8210e3c1bbb9bae805671 (patch)
tree7c5d8d4cffd92ea811b2de3a05beb7a69c1db8c1 /math
parentbb08ef59f687a3f283236472392c6725f1940b3c (diff)
downloadports-45938639f0111f42e1b8210e3c1bbb9bae805671.tar.gz
ports-45938639f0111f42e1b8210e3c1bbb9bae805671.zip
- Resurrect math/octave-forge-linear algebra.
- Update math/octave-forge-linear-algebra to 2.2.3. - In math/octave-forge, option linear-algebra defaults to on. - Bump port revision of math/octave-forge.
Notes
Notes: svn path=/head/; revision=517613
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-linear-algebra/Makefile27
-rw-r--r--math/octave-forge-linear-algebra/distinfo3
-rw-r--r--math/octave-forge-linear-algebra/pkg-descr10
-rw-r--r--math/octave-forge/Makefile4
5 files changed, 43 insertions, 2 deletions
diff --git a/math/Makefile b/math/Makefile
index aaa9e98a793f..fe3fb9f158e1 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -429,6 +429,7 @@
SUBDIR += octave-forge-io
SUBDIR += octave-forge-irsa
SUBDIR += octave-forge-level-set
+ SUBDIR += octave-forge-linear-algebra
SUBDIR += octave-forge-lssa
SUBDIR += octave-forge-ltfat
SUBDIR += octave-forge-mapping
diff --git a/math/octave-forge-linear-algebra/Makefile b/math/octave-forge-linear-algebra/Makefile
new file mode 100644
index 000000000000..402114f897a2
--- /dev/null
+++ b/math/octave-forge-linear-algebra/Makefile
@@ -0,0 +1,27 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-linear-algebra
+PORTVERSION= 2.2.3
+PORTEPOCH= 1
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+do-build:
+ @${DO_NADA}
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-linear-algebra/distinfo b/math/octave-forge-linear-algebra/distinfo
new file mode 100644
index 000000000000..b9644f014bf2
--- /dev/null
+++ b/math/octave-forge-linear-algebra/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1573762522
+SHA256 (octave-forge/linear-algebra-2.2.3.tar.gz) = 53ee6a534e1327282339cbc0bd335af17e0f897f737c00bfa686c99d6ebf92f3
+SIZE (octave-forge/linear-algebra-2.2.3.tar.gz) = 47086
diff --git a/math/octave-forge-linear-algebra/pkg-descr b/math/octave-forge-linear-algebra/pkg-descr
new file mode 100644
index 000000000000..ed954a68c03d
--- /dev/null
+++ b/math/octave-forge-linear-algebra/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is linear-algebra.
+
+ Additional linear algebra code, including general SVD and matrix functions.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge/Makefile b/math/octave-forge/Makefile
index efc6ce771c28..fc848ec33800 100644
--- a/math/octave-forge/Makefile
+++ b/math/octave-forge/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave-forge
PORTVERSION= 20180409
-PORTREVISION= 22
+PORTREVISION= 23
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
@@ -28,7 +28,7 @@ OPTIONS_DEFINE= ACTUARIAL BENCHMARK BIM BIOINFO BSLTL CGI \
STRUCT SYMBAND SYMBOLIC TCL_OCTAVE TISEAN TSA VIDEO \
ZENITY ZEROMQ
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE:NDATA_SMOOTHING:NLINEAR_ALGEBRA:NMECHANICS:NPARALLEL:NSTRINGS:NTISEAN:NVIDEO}
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE:NDATA_SMOOTHING:NMECHANICS:NPARALLEL:NSTRINGS:NTISEAN:NVIDEO}
TARBALLS_DIR= ${LOCALBASE}/share/octave/tarballs