aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2021-08-24 07:05:33 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2021-08-24 07:09:29 +0000
commit4bd6f68f0b711e4113a4a067ee221e851405fdd7 (patch)
tree17f85c4a306ff77a433b4b1a40ed5e805a6af9f8 /math
parent42db3560ac768eab87b11e9e80c0041a07b02847 (diff)
downloadports-4bd6f68f0b711e4113a4a067ee221e851405fdd7.tar.gz
ports-4bd6f68f0b711e4113a4a067ee221e851405fdd7.zip
math/openfst: revive ports, also update to 1.8.1.
Reported by: kevlo@
Diffstat (limited to 'math')
-rw-r--r--math/openfst/Makefile31
-rw-r--r--math/openfst/distinfo3
-rw-r--r--math/openfst/pkg-descr20
-rw-r--r--math/openfst/pkg-plist345
4 files changed, 399 insertions, 0 deletions
diff --git a/math/openfst/Makefile b/math/openfst/Makefile
new file mode 100644
index 000000000000..a6fc61b6d0bf
--- /dev/null
+++ b/math/openfst/Makefile
@@ -0,0 +1,31 @@
+# Created by: Dmitry Sivachenko <mitya@yandex-team.ru>
+
+PORTNAME= openfst
+PORTVERSION= 1.8.1
+CATEGORIES= math
+MASTER_SITES= http://www.openfst.org/twiki/pub/FST/FstDownload/
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Library for working with weighted finite-state transducers
+
+LICENSE= APACHE20
+
+USES= compiler:c++17-lang libtool python:3.6+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+CONFIGURE_ARGS= --enable-bin \
+ --enable-compact-fsts \
+ --enable-compress \
+ --enable-const-fsts \
+ --enable-far \
+ --enable-fsts \
+ --enable-linear-fsts \
+ --enable-lookahead-fsts \
+ --enable-mpdt \
+ --enable-ngram-fsts \
+ --enable-pdt \
+ --enable-python \
+ --enable-special
+
+.include <bsd.port.mk>
diff --git a/math/openfst/distinfo b/math/openfst/distinfo
new file mode 100644
index 000000000000..c6047344dd34
--- /dev/null
+++ b/math/openfst/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629778485
+SHA256 (openfst-1.8.1.tar.gz) = 24fb53b72bb687e3fa8ee96c72a31ff2920d99b980a0a8f61dda426fca6713f0
+SIZE (openfst-1.8.1.tar.gz) = 1333532
diff --git a/math/openfst/pkg-descr b/math/openfst/pkg-descr
new file mode 100644
index 000000000000..ace996bb72e7
--- /dev/null
+++ b/math/openfst/pkg-descr
@@ -0,0 +1,20 @@
+OpenFst is a library for constructing, combining, optimizing, and searching
+weighted finite-state transducers (FSTs). Weighted finite-state transducers
+are automata where each transition has an input label, an output label, and
+a weight. The more familiar finite-state acceptor is represented as a
+transducer with each transition's input and output label equal.
+Finite-state acceptors are used to represent sets of strings (specifically,
+regular or rational sets); finite-state transducers are used to represent
+binary relations between pairs of strings (specifically, rational
+transductions). The weights can be used to represent the cost of taking
+a particular transition.
+FSTs have key applications in speech recognition and synthesis, machine
+translation, optical character recognition, pattern matching, string
+processing, machine learning, information extraction and retrieval
+among others. Often a weighted transducer is used to represent a
+probabilistic model (e.g., an n-gram model, pronunciation model). FSTs can
+be optimized by determinization and minimization, models can be applied to
+hypothesis sets (also represented as automata) or cascaded by finite-state
+composition, and the best results can be selected by shortest-path algorithms.
+
+WWW: http://www.openfst.org/
diff --git a/math/openfst/pkg-plist b/math/openfst/pkg-plist
new file mode 100644
index 000000000000..b86ce1a49591
--- /dev/null
+++ b/math/openfst/pkg-plist
@@ -0,0 +1,345 @@
+bin/farcompilestrings
+bin/farconvert
+bin/farcreate
+bin/farequal
+bin/farextract
+bin/farinfo
+bin/farisomorphic
+bin/farprintstrings
+bin/fstarcsort
+bin/fstclosure
+bin/fstcompile
+bin/fstcompose
+bin/fstcompress
+bin/fstconcat
+bin/fstconnect
+bin/fstconvert
+bin/fstdeterminize
+bin/fstdifference
+bin/fstdisambiguate
+bin/fstdraw
+bin/fstencode
+bin/fstepsnormalize
+bin/fstequal
+bin/fstequivalent
+bin/fstinfo
+bin/fstintersect
+bin/fstinvert
+bin/fstisomorphic
+bin/fstlinear
+bin/fstloglinearapply
+bin/fstmap
+bin/fstminimize
+bin/fstprint
+bin/fstproject
+bin/fstprune
+bin/fstpush
+bin/fstrandgen
+bin/fstrelabel
+bin/fstreplace
+bin/fstreverse
+bin/fstreweight
+bin/fstrmepsilon
+bin/fstshortestdistance
+bin/fstshortestpath
+bin/fstspecial
+bin/fstsymbols
+bin/fstsynchronize
+bin/fsttopsort
+bin/fstunion
+bin/mpdtcompose
+bin/mpdtexpand
+bin/mpdtinfo
+bin/mpdtreverse
+bin/pdtcompose
+bin/pdtexpand
+bin/pdtinfo
+bin/pdtreplace
+bin/pdtreverse
+bin/pdtshortestpath
+include/fst/accumulator.h
+include/fst/add-on.h
+include/fst/arc-arena.h
+include/fst/arc-map.h
+include/fst/arc.h
+include/fst/arcfilter.h
+include/fst/arcsort.h
+include/fst/bi-table.h
+include/fst/cache.h
+include/fst/closure.h
+include/fst/compact-fst.h
+include/fst/compat.h
+include/fst/complement.h
+include/fst/compose-filter.h
+include/fst/compose.h
+include/fst/concat.h
+include/fst/config.h
+include/fst/connect.h
+include/fst/const-fst.h
+include/fst/determinize.h
+include/fst/dfs-visit.h
+include/fst/difference.h
+include/fst/disambiguate.h
+include/fst/edit-fst.h
+include/fst/encode.h
+include/fst/epsnormalize.h
+include/fst/equal.h
+include/fst/equivalent.h
+include/fst/error-weight.h
+include/fst/expanded-fst.h
+include/fst/expander-cache.h
+include/fst/expectation-weight.h
+include/fst/extensions/compress/compress.h
+include/fst/extensions/compress/compressscript.h
+include/fst/extensions/compress/elias.h
+include/fst/extensions/far/compile-strings.h
+include/fst/extensions/far/convert.h
+include/fst/extensions/far/create.h
+include/fst/extensions/far/equal.h
+include/fst/extensions/far/extract.h
+include/fst/extensions/far/far-class.h
+include/fst/extensions/far/far.h
+include/fst/extensions/far/farlib.h
+include/fst/extensions/far/farscript.h
+include/fst/extensions/far/getters.h
+include/fst/extensions/far/info.h
+include/fst/extensions/far/isomorphic.h
+include/fst/extensions/far/print-strings.h
+include/fst/extensions/far/script-impl.h
+include/fst/extensions/far/stlist.h
+include/fst/extensions/far/sttable.h
+include/fst/extensions/linear/linear-fst-data-builder.h
+include/fst/extensions/linear/linear-fst-data.h
+include/fst/extensions/linear/linear-fst.h
+include/fst/extensions/linear/linearscript.h
+include/fst/extensions/linear/loglinear-apply.h
+include/fst/extensions/linear/trie.h
+include/fst/extensions/mpdt/compose.h
+include/fst/extensions/mpdt/expand.h
+include/fst/extensions/mpdt/info.h
+include/fst/extensions/mpdt/mpdt.h
+include/fst/extensions/mpdt/mpdtlib.h
+include/fst/extensions/mpdt/mpdtscript.h
+include/fst/extensions/mpdt/read_write_utils.h
+include/fst/extensions/mpdt/reverse.h
+include/fst/extensions/ngram/bitmap-index.h
+include/fst/extensions/ngram/ngram-fst.h
+include/fst/extensions/ngram/nthbit.h
+include/fst/extensions/pdt/collection.h
+include/fst/extensions/pdt/compose.h
+include/fst/extensions/pdt/expand.h
+include/fst/extensions/pdt/getters.h
+include/fst/extensions/pdt/info.h
+include/fst/extensions/pdt/paren.h
+include/fst/extensions/pdt/pdt.h
+include/fst/extensions/pdt/pdtlib.h
+include/fst/extensions/pdt/pdtscript.h
+include/fst/extensions/pdt/replace.h
+include/fst/extensions/pdt/reverse.h
+include/fst/extensions/pdt/shortest-path.h
+include/fst/extensions/special/phi-fst.h
+include/fst/extensions/special/rho-fst.h
+include/fst/extensions/special/sigma-fst.h
+include/fst/factor-weight.h
+include/fst/filter-state.h
+include/fst/flags.h
+include/fst/float-weight.h
+include/fst/fst-decl.h
+include/fst/fst.h
+include/fst/fstlib.h
+include/fst/generic-register.h
+include/fst/heap.h
+include/fst/icu.h
+include/fst/intersect.h
+include/fst/interval-set.h
+include/fst/invert.h
+include/fst/isomorphic.h
+include/fst/label-reachable.h
+include/fst/lexicographic-weight.h
+include/fst/lock.h
+include/fst/log.h
+include/fst/lookahead-filter.h
+include/fst/lookahead-matcher.h
+include/fst/map.h
+include/fst/mapped-file.h
+include/fst/matcher-fst.h
+include/fst/matcher.h
+include/fst/memory.h
+include/fst/minimize.h
+include/fst/mutable-fst.h
+include/fst/pair-weight.h
+include/fst/partition.h
+include/fst/power-weight-mappers.h
+include/fst/power-weight.h
+include/fst/product-weight.h
+include/fst/project.h
+include/fst/properties.h
+include/fst/prune.h
+include/fst/push.h
+include/fst/queue.h
+include/fst/randequivalent.h
+include/fst/randgen.h
+include/fst/rational.h
+include/fst/register.h
+include/fst/relabel.h
+include/fst/replace-util.h
+include/fst/replace.h
+include/fst/reverse.h
+include/fst/reweight.h
+include/fst/rmepsilon.h
+include/fst/rmfinalepsilon.h
+include/fst/script/arc-class.h
+include/fst/script/arciterator-class.h
+include/fst/script/arcsort.h
+include/fst/script/arg-packs.h
+include/fst/script/closure.h
+include/fst/script/compile-impl.h
+include/fst/script/compile.h
+include/fst/script/compose.h
+include/fst/script/concat.h
+include/fst/script/connect.h
+include/fst/script/convert.h
+include/fst/script/decode.h
+include/fst/script/determinize.h
+include/fst/script/difference.h
+include/fst/script/disambiguate.h
+include/fst/script/draw-impl.h
+include/fst/script/draw.h
+include/fst/script/encode.h
+include/fst/script/encodemapper-class.h
+include/fst/script/epsnormalize.h
+include/fst/script/equal.h
+include/fst/script/equivalent.h
+include/fst/script/fst-class.h
+include/fst/script/fstscript-decl.h
+include/fst/script/fstscript.h
+include/fst/script/getters.h
+include/fst/script/info-impl.h
+include/fst/script/info.h
+include/fst/script/intersect.h
+include/fst/script/invert.h
+include/fst/script/isomorphic.h
+include/fst/script/map.h
+include/fst/script/minimize.h
+include/fst/script/print-impl.h
+include/fst/script/print.h
+include/fst/script/project.h
+include/fst/script/prune.h
+include/fst/script/push.h
+include/fst/script/randequivalent.h
+include/fst/script/randgen.h
+include/fst/script/relabel.h
+include/fst/script/replace.h
+include/fst/script/reverse.h
+include/fst/script/reweight.h
+include/fst/script/rmepsilon.h
+include/fst/script/script-impl.h
+include/fst/script/shortest-distance.h
+include/fst/script/shortest-path.h
+include/fst/script/stateiterator-class.h
+include/fst/script/synchronize.h
+include/fst/script/text-io.h
+include/fst/script/topsort.h
+include/fst/script/union.h
+include/fst/script/verify.h
+include/fst/script/weight-class.h
+include/fst/set-weight.h
+include/fst/shortest-distance.h
+include/fst/shortest-path.h
+include/fst/signed-log-weight.h
+include/fst/sparse-power-weight.h
+include/fst/sparse-tuple-weight.h
+include/fst/state-map.h
+include/fst/state-reachable.h
+include/fst/state-table.h
+include/fst/statesort.h
+include/fst/string-weight.h
+include/fst/string.h
+include/fst/symbol-table-ops.h
+include/fst/symbol-table.h
+include/fst/synchronize.h
+include/fst/test-properties.h
+include/fst/test/algo_test.h
+include/fst/test/compactors.h
+include/fst/test/fst_test.h
+include/fst/test/rand-fst.h
+include/fst/test/weight-tester.h
+include/fst/topsort.h
+include/fst/tuple-weight.h
+include/fst/types.h
+include/fst/union-find.h
+include/fst/union-weight.h
+include/fst/union.h
+include/fst/util.h
+include/fst/vector-fst.h
+include/fst/verify.h
+include/fst/visit.h
+include/fst/weight.h
+include/fst/windows_defs.inc
+lib/fst/arc_lookahead-fst.so
+lib/fst/compact16_acceptor-fst.so
+lib/fst/compact16_string-fst.so
+lib/fst/compact16_unweighted-fst.so
+lib/fst/compact16_unweighted_acceptor-fst.so
+lib/fst/compact16_weighted_string-fst.so
+lib/fst/compact64_acceptor-fst.so
+lib/fst/compact64_string-fst.so
+lib/fst/compact64_unweighted-fst.so
+lib/fst/compact64_unweighted_acceptor-fst.so
+lib/fst/compact64_weighted_string-fst.so
+lib/fst/compact8_acceptor-fst.so
+lib/fst/compact8_string-fst.so
+lib/fst/compact8_unweighted-fst.so
+lib/fst/compact8_unweighted_acceptor-fst.so
+lib/fst/compact8_weighted_string-fst.so
+lib/fst/const16-fst.so
+lib/fst/const64-fst.so
+lib/fst/const8-fst.so
+lib/fst/ilabel_lookahead-fst.so
+lib/fst/linear_classifier-fst.so
+lib/fst/linear_tagger-fst.so
+lib/fst/ngram-fst.so
+lib/fst/olabel_lookahead-fst.so
+lib/fst/phi-fst.so
+lib/fst/rho-fst.so
+lib/fst/sigma-fst.so
+lib/libfst.so
+lib/libfst.so.24
+lib/libfst.so.24.0.0
+lib/libfstcompact.so
+lib/libfstcompact.so.24
+lib/libfstcompact.so.24.0.0
+lib/libfstcompressscript.so
+lib/libfstcompressscript.so.24
+lib/libfstcompressscript.so.24.0.0
+lib/libfstconst.so
+lib/libfstconst.so.24
+lib/libfstconst.so.24.0.0
+lib/libfstfar.so
+lib/libfstfar.so.24
+lib/libfstfar.so.24.0.0
+lib/libfstfarscript.so
+lib/libfstfarscript.so.24
+lib/libfstfarscript.so.24.0.0
+lib/libfstlinearscript.so
+lib/libfstlinearscript.so.24
+lib/libfstlinearscript.so.24.0.0
+lib/libfstlookahead.so
+lib/libfstlookahead.so.24
+lib/libfstlookahead.so.24.0.0
+lib/libfstmpdtscript.so
+lib/libfstmpdtscript.so.24
+lib/libfstmpdtscript.so.24.0.0
+lib/libfstngram.so
+lib/libfstngram.so.24
+lib/libfstngram.so.24.0.0
+lib/libfstpdtscript.so
+lib/libfstpdtscript.so.24
+lib/libfstpdtscript.so.24.0.0
+lib/libfstscript.so
+lib/libfstscript.so.24
+lib/libfstscript.so.24.0.0
+lib/libfstspecial.so
+lib/libfstspecial.so.24
+lib/libfstspecial.so.24.0.0
+%%PYTHON_SITELIBDIR%%/pywrapfst.so