aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-05-11 17:58:55 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-05-11 17:58:55 +0000
commit4e09def2d4cfcd05ede8b5671ca97a7f676654b2 (patch)
tree4e99b662e9edb02c504f73d22596ea702c0f3d31 /math
parentf88394af09ffce9250caa45347e357f79b0100ff (diff)
downloadports-4e09def2d4cfcd05ede8b5671ca97a7f676654b2.tar.gz
ports-4e09def2d4cfcd05ede8b5671ca97a7f676654b2.zip
Rectify USE_TEX to support both of teTeX and TeXLive.
TEX_DEFAULT: A knob to choose teTeX or TeXLive. One can specify in /etc/make.conf. USE_TEX: A knob for port developers. Valid keywords are listed in bsd.tex.mk.
Notes
Notes: svn path=/head/; revision=317899
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile2
-rw-r--r--math/asymptote/Makefile6
-rw-r--r--math/coq/Makefile2
-rw-r--r--math/eukleides/Makefile2
-rw-r--r--math/giacxcas/Makefile5
-rw-r--r--math/gnuplot/Makefile2
-rw-r--r--math/naturalmath/Makefile2
-rw-r--r--math/petsc/Makefile2
-rw-r--r--math/sage/Makefile2
9 files changed, 11 insertions, 14 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 517118169667..b64dea7c1dbb 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -244,7 +244,7 @@ INFO= R-FAQ R-admin R-data R-exts R-intro R-lang
.if ${PORT_OPTIONS:MPDF_MANUALS} && ${PORT_OPTIONS:MDOCS}
BROKEN = The PDF_MANUALS option cannot be used, because\
print/texinfo is incompatible with print/teTeX-base
-USE_TEX= tetex
+USE_TEX= tex:build
BUILD_DEPENDS += texi2dvi:${PORTSDIR}/print/texinfo
ALL_TARGET+= pdf
CONFIGURE_ENV += INSTALL_INFO="${LOCALBASE}/bin/install-info" \
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index e37895f25c59..a31b98e27552 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -25,7 +25,7 @@ ONLY_FOR_ARCHS= i386 amd64
CONFIGURE_ARGS= --disable-gc
USE_GHOSTSCRIPT=yes
-USE_TEX= tetex
+USE_TEX= latex
USE_GL= glut
USE_GMAKE= yes
USE_PERL5_BUILD= yes
@@ -80,11 +80,9 @@ INSTALL_TARGET+= install-man
#.if ${PORT_OPTIONS:MMANPAGES} || ${PORT_OPTIONS:MDOCS}
# teTeX is too old to compile the asymptote documentation
.if 0
+USE_TEX+= dvipsk:build
BUILD_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick \
- dvips:${PORTSDIR}/print/dvipsk-tetex \
- latex:${PORTSDIR}/print/teTeX-base \
makeinfo:${PORTSDIR}/textproc/texi2html \
- ${MKTEXLSR}:${PORTSDIR}/print/teTeX-base \
svn:${PORTSDIR}/devel/subversion \
texi2dvi:${PORTSDIR}/print/texinfo
.endif
diff --git a/math/coq/Makefile b/math/coq/Makefile
index a2191926c16c..8034e71fa3c7 100644
--- a/math/coq/Makefile
+++ b/math/coq/Makefile
@@ -36,7 +36,7 @@ MAN1= coq-tex.1 coq_makefile.1 coqc.1 coqchk.1 coqdep.1 coqdoc.1 \
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
-USE_TEX= tetex
+USE_TEX= latex:build
BUILD_DEPENDS+= hevea:${PORTSDIR}/textproc/hevea \
${LOCALBASE}/share/texmf/tex/latex/ucs/utf8x.def:${PORTSDIR}/print/latex-ucs
PORTDOCS= *
diff --git a/math/eukleides/Makefile b/math/eukleides/Makefile
index 5701d54e9d0f..2fbf03d706f6 100644
--- a/math/eukleides/Makefile
+++ b/math/eukleides/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
RUN_DEPENDS= pstoedit:${PORTSDIR}/graphics/pstoedit
USE_BZIP2= yes
-USE_TEX= tetex
+USE_TEX= latex
USES= bison gettext iconv
USE_GMAKE= yes
diff --git a/math/giacxcas/Makefile b/math/giacxcas/Makefile
index 3d372be0c960..de64e6d9d0ce 100644
--- a/math/giacxcas/Makefile
+++ b/math/giacxcas/Makefile
@@ -14,8 +14,7 @@ COMMENT= Computer algebra system by Bernard Parisse
LICENSE= GPLv3
-BUILD_DEPENDS= dvips:${PORTSDIR}/print/dvipsk-tetex \
- bash:${PORTSDIR}/shells/bash \
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/lib/libntl.a:${PORTSDIR}/math/ntl
LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
pari:${PORTSDIR}/math/pari \
@@ -29,7 +28,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GL= gl
USE_XORG= xcursor xft xi
-USE_TEX= tetex
+USE_TEX= latex:build dvipsk:build
USE_LDCONFIG= yes
USES= gettext
MAKE_JOBS_SAFE= yes
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 61e06c263b23..5a82812b92e3 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+= --without-plot
.endif
.if ${PORT_OPTIONS:MTETEX}
-USE_TEX= tetex
+USE_TEX= base texmf latex
CONFIGURE_ARGS+= --with-kpsexpand \
--with-texdir=${LOCALBASE}/share/texmf/tex/latex/gnuplot
PLIST_SUB+= TETEX=""
diff --git a/math/naturalmath/Makefile b/math/naturalmath/Makefile
index 471d5b23578e..28b6aee842df 100644
--- a/math/naturalmath/Makefile
+++ b/math/naturalmath/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= stephen@FreeBSD.org
COMMENT= Script to turn intuitively written math into latex
USE_PERL5= yes
-USE_TEX= tetex
+USE_TEX= latex:build
post-patch:
@${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/naturalmath
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 8e9fd552838a..1ff2de37803c 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -56,7 +56,7 @@ CONFIGURE_ARGS+= --with-umfpack-include="${LOCALBASE}/include/suitesparse" \
.if !defined(NOPORTDOCS)
PORTDOCS= *
-#USE_TEX= tetex
+#USE_TEX= latex:build
#BUILD_DEPENDS+= c2html:${PORTSDIR}/textproc/c2html \
# doc2lt:${PORTSDIR}/textproc/sowing
.endif
diff --git a/math/sage/Makefile b/math/sage/Makefile
index a3eadedaee0a..03d725d5dea4 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -32,7 +32,7 @@ USE_FORTRAN= yes
USE_GCC= 4.7+
USE_TK= yes
USE_GMAKE= yes
-USE_TEX= tetex
+USE_TEX= latex:build
USES= iconv
MAKE_JOBS_SAFE= yes
LDFLAGS:= -Wl,-rpath=${WRKSRC}/local/lib ${LDFLAGS}