aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2021-07-30 23:48:48 +0000
committerWen Heping <wen@FreeBSD.org>2021-07-30 23:48:48 +0000
commit53e162ef0d8bfc968ade9840980d2a573c8c879a (patch)
treea7213e5784a29709b6d516855a356880cd429005 /math
parent6068a9933c779ec4b039e5c2d1624c59ecf4977f (diff)
downloadports-53e162ef0d8bfc968ade9840980d2a573c8c879a.tar.gz
ports-53e162ef0d8bfc968ade9840980d2a573c8c879a.zip
math/mdal: Add new port
Mesh Data Abstraction Library (MDAL) is a C++ library for handling unstructured mesh data released with MIT license. It provides a single data model for multiple supported data formats. MDAL is used by QGIS for data access for mesh layers. WWW: http://www.mdal.xyz/
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/mdal/Makefile32
-rw-r--r--math/mdal/distinfo3
-rw-r--r--math/mdal/pkg-descr6
4 files changed, 42 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 372f33b523a2..a471c4a52c00 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -430,6 +430,7 @@
SUBDIR += maxima
SUBDIR += mbasecalc
SUBDIR += mcsim
+ SUBDIR += mdal
SUBDIR += metis
SUBDIR += mfem
SUBDIR += mingw32-libgmp
diff --git a/math/mdal/Makefile b/math/mdal/Makefile
new file mode 100644
index 000000000000..6e7cf15e0b1e
--- /dev/null
+++ b/math/mdal/Makefile
@@ -0,0 +1,32 @@
+# Created by: Wen Heping <wen@FreeBSD.org>
+
+PORTNAME= mdal
+DISTVERSION= 0.8.1
+CATEGORIES= math geography
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Mesh data abstration library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/gtest/gtest.h:devel/googletest
+LIB_DEPENDS= libpdal_base.so:math/pdal \
+ libnetcdf.so:science/netcdf \
+ libsqlite3.so:databases/sqlite3
+
+USES= cmake localbase
+USE_LDCONFIG= yes
+
+PLIST_FILES= bin/mdal_translate \
+ bin/mdalinfo \
+ include/mdal.h \
+ lib/libmdal.so \
+ lib/libmdal_a.a
+
+USE_GITHUB= yes
+GH_ACCOUNT= lutraconsulting
+GH_PROJECT= MDAL
+GH_TAGNAME= release-${DISTVERSION}
+
+.include <bsd.port.mk>
diff --git a/math/mdal/distinfo b/math/mdal/distinfo
new file mode 100644
index 000000000000..a6693c517136
--- /dev/null
+++ b/math/mdal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1627546478
+SHA256 (lutraconsulting-MDAL-0.8.1-release-0.8.1_GH0.tar.gz) = 0051495aff910b05d04efa792925cce377920ee02a03a89fa45529fd96cd2953
+SIZE (lutraconsulting-MDAL-0.8.1-release-0.8.1_GH0.tar.gz) = 52259830
diff --git a/math/mdal/pkg-descr b/math/mdal/pkg-descr
new file mode 100644
index 000000000000..cbe7859f607e
--- /dev/null
+++ b/math/mdal/pkg-descr
@@ -0,0 +1,6 @@
+Mesh Data Abstraction Library (MDAL) is a C++ library for handling unstructured
+mesh data released with MIT license. It provides a single data model for
+multiple supported data formats. MDAL is used by QGIS for data access for mesh
+layers.
+
+WWW: http://www.mdal.xyz/