aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-23 05:23:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-23 05:23:04 +0000
commit5a371113af9326cc2dee835b1aacc244515e8466 (patch)
tree707e0ee021634e16784d35939ebd2ed17aad78f8 /math
parentc0ddb908e847c6c6b3e11a0d68ea3161457e7f59 (diff)
downloadports-5a371113af9326cc2dee835b1aacc244515e8466.tar.gz
ports-5a371113af9326cc2dee835b1aacc244515e8466.zip
math/vtk8: Remove QT4 option
kde4 is set to be deprecated on 2018-12-31 with Qt4 soon to follow. Therefore, simplify the VTK8 port and remove QT4.
Notes
Notes: svn path=/head/; revision=485636
Diffstat (limited to 'math')
-rw-r--r--math/vtk8/Makefile21
1 files changed, 3 insertions, 18 deletions
diff --git a/math/vtk8/Makefile b/math/vtk8/Makefile
index f7817928c1fb..5ee5457b791b 100644
--- a/math/vtk8/Makefile
+++ b/math/vtk8/Makefile
@@ -2,7 +2,7 @@
PORTNAME= vtk
DISTVERSION= 8.1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math graphics
MASTER_SITES= http://www.vtk.org/files/release/${VTK_SHORT_VER}/
PKGNAMESUFFIX= 8
@@ -39,7 +39,7 @@ DOCSDIR= ${PREFIX}/share/doc/vtk-${VTK_SHORT_VER}
DATADIR= ${PREFIX}/share/vtk-${VTK_SHORT_VER}
# Options
-OPTIONS_DEFINE= DESIGNER DOCS OSMESA EXAMPLES
+OPTIONS_DEFINE= DESIGNER DOCS OSMESA QT5 EXAMPLES
OPTIONS_DEFAULT= MPI QT5
OSMESA_DESC= Use Mesa for off-screen rendering
DESIGNER_DESC= Build the Qt Designer plugin
@@ -59,18 +59,6 @@ $g_DESC= Build the $g group
$w_DESC= $w wrapping
.endfor
-# Qt radio
-OPTIONS_RADIO= Qt
-OPTIONS_RADIO_Qt= QT4 QT5
-Qt_DESC= Qt GUI support
-QT4_DESC= Qt 4 toolkit support
-QT5_DESC= Qt 5 toolkit support
-
-QT4_USES= qt:4
-QT4_USE= QT=corelib,designer,gui_build,gui_run,network_build,network_run,sql_build,sql_run,moc_build,uic_build,qmake_build,rcc_build,opengl,webkit_build,webkit_run
-QT4_CMAKE_ON= -DVTK_QT_VERSION:STRING="4" \
- -DVTK_Group_Qt:BOOL=ON
-
QT5_USES= qt:5
QT5_USE= QT=core,gui,sql,uiplugin,widgets,x11extras,qmake_build,buildtools_build
QT5_CMAKE_ON= -DVTK_QT_VERSION:STRING="5" \
@@ -79,6 +67,7 @@ QT5_CMAKE_ON= -DVTK_QT_VERSION:STRING="5" \
DESIGNER_CMAKE_BOOL= QT_DESIGNER_PLUGIN
DESIGNER_USE= QT=designer
+DESIGNER_IMPLIES= QT5
MPI_LIB_DEPENDS= libmpi.so:net/openmpi
MPI_CMAKE_ON= -DMPIEXEC=${LOCALBASE}/mpi/openmpi/bin/mpiexec
@@ -130,10 +119,6 @@ CMAKE_ARGS+= -DVTK_Group_${g}:BOOL=OFF
USE_GL= gl glu
.endif
-.if ${PORT_OPTIONS:MDESIGNER} && !${PORT_OPTIONS:MQT5} && !${PORT_OPTIONS:MQT4}
-IGNORE= designer requires either QT4 or QT5
-.endif
-
post-install: # autoplist: thousands of files, complex dependencies on options
@cd ${STAGEDIR}${PREFIX} && \
${FIND} * -type f -or -type l >> ${TMPPLIST}