aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-09-11 14:57:58 +0000
committerRene Ladan <rene@FreeBSD.org>2021-09-30 21:23:30 +0000
commit620968a43a5f9bb3fa98ab20f257a4c0d864caa7 (patch)
tree09bef799707f4b6e715b912429bd3b73c1addf4c /math
parentb9a93c0bf4778b9ec327c1be6f819eb1ff90ec19 (diff)
downloadports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.tar.gz
ports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.zip
cleanup: drop support for EOL FreeBSD 11.X
Search criteria used: - 11.4 - OSREL* - OSVER* - *_FreeBSD_11 Input from: - adridg: devel/qca-legacy - jbeich: _WITH_DPRINTF, _WITH_GETLINE, GNU bfd workarounds - sunpoet: security/p5-*OpenSSL* Reviewed by: doceng, kde, multimedia, perl, python, ruby, rust Differential Revision: https://reviews.freebsd.org/D32008 Test Plan: make index
Diffstat (limited to 'math')
-rw-r--r--math/clblas/Makefile1
-rw-r--r--math/flann/files/patch-src_cpp_CMakeLists.txt27
-rw-r--r--math/libflame/Makefile4
-rw-r--r--math/opensolaris-libm/Makefile15
-rw-r--r--math/openturns/Makefile2
-rw-r--r--math/py-ducc0/Makefile2
-rw-r--r--math/py-matplotlib/Makefile2
-rw-r--r--math/pynac/Makefile6
8 files changed, 1 insertions, 58 deletions
diff --git a/math/clblas/Makefile b/math/clblas/Makefile
index f0fc76392775..44d87d1bfe05 100644
--- a/math/clblas/Makefile
+++ b/math/clblas/Makefile
@@ -12,7 +12,6 @@ COMMENT= Software library containing BLAS functions written in OpenCL
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_11_powerpc64= src/library/tools/tune/tune.c:137: error: 'CLOCK_REALTIME' undeclared (first use in this function)
BROKEN_FreeBSD_12_powerpc64= src/library/tools/tune/tune.c:137: error: 'CLOCK_REALTIME' undeclared (first use in this function)
BUILD_DEPENDS= opencl>=0:devel/opencl
diff --git a/math/flann/files/patch-src_cpp_CMakeLists.txt b/math/flann/files/patch-src_cpp_CMakeLists.txt
index 64411160754e..ea453293ef9c 100644
--- a/math/flann/files/patch-src_cpp_CMakeLists.txt
+++ b/math/flann/files/patch-src_cpp_CMakeLists.txt
@@ -9,30 +9,3 @@
set_property(TARGET flann_cuda_s PROPERTY COMPILE_DEFINITIONS FLANN_STATIC)
endif()
-@@ -43,7 +43,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_COMPIL
- endif()
- else()
- add_library(flann_cpp SHARED ${CPP_SOURCES})
-- target_link_libraries(flann_cpp -Wl,--push-state,--no-as-needed ${LZ4_LIBRARIES} -Wl,--pop-state)
-+ target_link_libraries(flann_cpp -Wl,--no-as-needed ${LZ4_LIBRARIES}) # clang-8 in FreeBSD 11 doesn't know -Wl,--push-state / -Wl,--pop-state
- # export lz4 headers, so that MSVC to creates flann_cpp.lib
- set_target_properties(flann_cpp PROPERTIES WINDOWS_EXPORT_ALL_SYMBOLS YES)
- if (BUILD_CUDA_LIB)
-@@ -81,7 +81,7 @@ endif()
-
- if (BUILD_C_BINDINGS)
- add_library(flann_s STATIC ${C_SOURCES})
-- target_link_libraries(flann_s -Wl,--push-state,--no-as-needed ${LZ4_LIBRARIES} -Wl,--pop-state)
-+ target_link_libraries(flann_s -Wl,--no-as-needed ${LZ4_LIBRARIES})
- if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_CLANG)
- set_target_properties(flann_s PROPERTIES COMPILE_FLAGS -fPIC)
- endif()
-@@ -93,7 +93,7 @@ if (BUILD_C_BINDINGS)
- target_link_libraries(flann -Wl,-whole-archive flann_s -Wl,-no-whole-archive)
- else()
- add_library(flann SHARED ${C_SOURCES})
-- target_link_libraries(flann -Wl,--push-state,--no-as-needed ${LZ4_LIBRARIES} -Wl,--pop-state)
-+ target_link_libraries(flann -Wl,--no-as-needed ${LZ4_LIBRARIES})
-
- if(MINGW AND OPENMP_FOUND)
- target_link_libraries(flann gomp)
diff --git a/math/libflame/Makefile b/math/libflame/Makefile
index 28511da0fcce..b643f7aca486 100644
--- a/math/libflame/Makefile
+++ b/math/libflame/Makefile
@@ -63,10 +63,6 @@ CONFIGURE_ARGS+= --enable-multithreading=pthreads
CONFIGURE_ARGS+= --enable-multithreading=no
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200060
-IGNORE= requires a newer linker such as lld
-.endif
-
.if !(defined(USE_GCC) || !empty(CC:M*gcc4*))
CONFIGURE_ARGS+= --disable-autodetect-f77-ldflags \
--disable-autodetect-f77-name-mangling
diff --git a/math/opensolaris-libm/Makefile b/math/opensolaris-libm/Makefile
index ec571006c683..a2532a7e5947 100644
--- a/math/opensolaris-libm/Makefile
+++ b/math/opensolaris-libm/Makefile
@@ -12,7 +12,7 @@ COMMENT= C99 Math and vector libraries from OpenSolaris snv_33
LICENSE= CDDL
LICENSE_FILE= ${WRKSRC}/usr/src/OPENSOLARIS.LICENSE
-ONLY_FOR_ARCHS= amd64 # i386 and sparc possible with much work
+ONLY_FOR_ARCHS= amd64 # i386 possible with much work
PORTSCOUT= ignore:1
USE_GITHUB= yes
@@ -24,19 +24,6 @@ INSTALL_WRKSRC= ${WRKSRC}/usr/src/libm/wos64
MAKEFILE= Makefile.bsd
MAKE_ENV= ARCH=${ARCH} USE_ASSEMBLY_VERSIONS=yes
-# On FreeBSD 11+, libm will build on base clang.
-# On FreeBSD 10, the base clang (v3.4) cannot even build libm without emitting
-# Internal Compiler Errors, so GCC is required and does not appear as an
-# option. Similarly, the GCC option does not appear on DragonFly as the
-# base compiler is already GCC. Programs compiled with GCC that link to
-# these libraries require that the libraries are compiled with GCC for
-# proper functioning.
-
-OPTIONS_DEFINE= GCC
-OPTIONS_EXCLUDE_DragonFly= GCC
-
-GCC_USE= GCC=yes
-
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD
diff --git a/math/openturns/Makefile b/math/openturns/Makefile
index ed5e45cd76cc..205a13b534ee 100644
--- a/math/openturns/Makefile
+++ b/math/openturns/Makefile
@@ -10,8 +10,6 @@ COMMENT= Uncertainty treatment library
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
-BROKEN_FreeBSD_11= SymbolicParserExprTk.cxx.o: file not recognized: File format not recognized
-
BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
flex:textproc/flex \
spectra>0:math/spectra
diff --git a/math/py-ducc0/Makefile b/math/py-ducc0/Makefile
index 8287faa202af..a045d8313480 100644
--- a/math/py-ducc0/Makefile
+++ b/math/py-ducc0/Makefile
@@ -10,8 +10,6 @@ COMMENT= Distinctly Useful Code Collection (DUCC)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_11= ducc.o: file not recognized: File format not recognized
-
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY}
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 57809564b37f..35541f232899 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -34,8 +34,6 @@ RUN_DEPENDS= ${PYNUMPY} \
USES= compiler:c++11-lib gettext gnome localbase pkgconfig python:3.7+ shebangfix uniquefiles:dirs
USE_PYTHON= distutils
-LDFLAGS+= -fuse-ld=lld
-
PLIST_SUB= VER=${PORTVERSION}
PORTEXAMPLES= *
diff --git a/math/pynac/Makefile b/math/pynac/Makefile
index 260d9c2beaa8..dd92288adb58 100644
--- a/math/pynac/Makefile
+++ b/math/pynac/Makefile
@@ -33,10 +33,4 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${PORTVERSION}
USE_LDCONFIG= yes
TEST_TARGET= check
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGIAC}
-BROKEN_FreeBSD_11= libgiac is broken (undefined reference to `__divmodti4@GCC_7.0.0')
-.endif
-
.include <bsd.port.mk>