aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2021-10-26 00:50:47 +0000
committerWen Heping <wen@FreeBSD.org>2021-10-26 00:50:47 +0000
commit7e9bec828e31369d9b6bab30ac86218bf3def70d (patch)
tree369f43eb75b80bc3852a97c95b893b2321727a62 /math
parentebf5105f9a4deba9b4aa27ce2b842b022d0f1bc5 (diff)
downloadports-7e9bec828e31369d9b6bab30ac86218bf3def70d.tar.gz
ports-7e9bec828e31369d9b6bab30ac86218bf3def70d.zip
math/py-numpy: Update to 1.20.3
PR: 259063 Reported by: wen@ Exp-run by: antoine@
Diffstat (limited to 'math')
-rw-r--r--math/py-numpy/Makefile30
-rw-r--r--math/py-numpy/distinfo14
-rw-r--r--math/py-numpy/files/patch-numpy-distutils-exec_command.py4
-rw-r--r--math/py-numpy/files/patch-numpy-distutils-fcompiler-__init__.py4
-rw-r--r--math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py8
-rw-r--r--math/py-numpy/files/patch-numpy-distutils-system_info.py48
6 files changed, 33 insertions, 75 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index b2360830e97b..5a3130271612 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -1,16 +1,16 @@
# Created by: Tony Maher
PORTNAME= numpy
-PORTVERSION= 1.16.6
-PORTREVISION= 2
+PORTVERSION= 1.20.3
PORTEPOCH= 1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP \
- https://docs.scipy.org/doc/${PORTNAME}-${PORTVERSION}/:doc
+ https://numpy.org/doc/${PORTVERSION:R}/:doc
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-ref-${PORTVERSION:R}.1.pdf:doc \
- ${PORTNAME}-user-${PORTVERSION:R}.1.pdf:doc
+ ${PORTNAME}-ref.pdf:doc \
+ ${PORTNAME}-user.pdf:doc
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION:R}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= python@FreeBSD.org
@@ -19,13 +19,14 @@ COMMENT= The New Numeric Extension to Python
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hypothesis>=5.41.3:devel/py-hypothesis@${PY_FLAVOR}
-USES= compiler:c11 cpe fortran python:3.6-3.9 zip
+USES= compiler:c11 cpe fortran python:3.7-3.9 zip
USE_PYTHON= allflavors autoplist concurrent cython distutils
GCCLIBDIR_CMDS= ${FC} -print-file-name=libgfortran.so | ${SED} -e s/libgfortran.so//
-LDFLAGS+= -shared
+LDFLAGS+= -s
PYDISTUTILS_BUILDARGS= --fcompiler=gnu95
PYDISTUTILS_CONFIGUREARGS= --fcompiler=gnu95
@@ -48,15 +49,14 @@ SUITESPARSE_LIB_DEPENDS=libumfpack.so:math/suitesparse-umfpack
post-extract:
@${TOUCH} ${WRKSRC}/numpy/f2py/tests/src/temp
+ @${TOUCH} ${WRKSRC}/numpy/random/_examples/temp
-post-patch:
- @${REINPLACE_CMD} -e 's|%%FC%%|${FC}|' ${WRKSRC}/numpy/distutils/fcompiler/gnu.py
- @${CP} ${FILESDIR}/site.cfg ${WRKSRC}/site.cfg
-
-post-patch-SUITESPARSE-off:
+pre-configure-SUITESPARSE-off:
@${REINPLACE_CMD} -e 's|:%%LOCALBASE%%/include/suitesparse||' ${WRKSRC}/site.cfg
pre-configure:
+ @${REINPLACE_CMD} -e 's|%%FC%%|${FC}|' ${WRKSRC}/numpy/distutils/fcompiler/gnu.py
+ @${CP} ${FILESDIR}/site.cfg ${WRKSRC}/site.cfg
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%BLASLIBS%%|${BLASLIBS}|; s|%%BLASNAME%%|${BLASNAME}|' \
-e 's|%%LAPACKLIBS%%|${LAPACKLIBS}|; s|%%LIBRARIES%%|${LIBRARIES}|' \
@@ -68,8 +68,8 @@ post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}-ref-${PORTVERSION:R}.1.pdf ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}-user-${PORTVERSION:R}.1.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}-ref.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}-user.pdf ${STAGEDIR}${DOCSDIR}
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} runtests.py
diff --git a/math/py-numpy/distinfo b/math/py-numpy/distinfo
index 44663a5c50f5..7a8bcb26092b 100644
--- a/math/py-numpy/distinfo
+++ b/math/py-numpy/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1588013658
-SHA256 (numpy-1.16.6.zip) = e5cf3fdf13401885e8eea8170624ec96225e2174eb0c611c6f26dd33b489e3ff
-SIZE (numpy-1.16.6.zip) = 5143340
-SHA256 (numpy-ref-1.16.1.pdf) = 5296c4949c92d00ae2c94ce65b78369b8081995dc72447bb20b6518bfaed3552
-SIZE (numpy-ref-1.16.1.pdf) = 5175448
-SHA256 (numpy-user-1.16.1.pdf) = aa8c591eee4c537768854f19e3cf4b861280828c19eb9d2e6194ea230570ea75
-SIZE (numpy-user-1.16.1.pdf) = 592508
+TIMESTAMP = 1621965044
+SHA256 (numpy-1.20/numpy-1.20.3.zip) = e55185e51b18d788e49fe8305fd73ef4470596b33fc2c1ceb304566b99c71a69
+SIZE (numpy-1.20/numpy-1.20.3.zip) = 7761912
+SHA256 (numpy-1.20/numpy-ref.pdf) = 39514faf26f4fecb697d771ba83e9340e35d3afd22478ab7e641f9daed67e84a
+SIZE (numpy-1.20/numpy-ref.pdf) = 7362241
+SHA256 (numpy-1.20/numpy-user.pdf) = 20cc665d19cbb4a2dfe7505a06dc23ae978982fec27e3108ddb332110bc2a94c
+SIZE (numpy-1.20/numpy-user.pdf) = 4977046
diff --git a/math/py-numpy/files/patch-numpy-distutils-exec_command.py b/math/py-numpy/files/patch-numpy-distutils-exec_command.py
index ea297206195c..a99e5814811d 100644
--- a/math/py-numpy/files/patch-numpy-distutils-exec_command.py
+++ b/math/py-numpy/files/patch-numpy-distutils-exec_command.py
@@ -1,6 +1,6 @@
---- numpy/distutils/exec_command.py.orig 2017-09-29 20:10:10 UTC
+--- numpy/distutils/exec_command.py.orig 2021-05-08 18:35:28 UTC
+++ numpy/distutils/exec_command.py
-@@ -231,7 +231,7 @@ def _exec_command(command, use_shell=Non
+@@ -261,7 +261,7 @@ def _exec_command(command, use_shell=None, use_tee = N
if os.name == 'posix' and use_shell:
# On POSIX, subprocess always uses /bin/sh, override
diff --git a/math/py-numpy/files/patch-numpy-distutils-fcompiler-__init__.py b/math/py-numpy/files/patch-numpy-distutils-fcompiler-__init__.py
index 4c52b846e1b4..63c4d24b2f9b 100644
--- a/math/py-numpy/files/patch-numpy-distutils-fcompiler-__init__.py
+++ b/math/py-numpy/files/patch-numpy-distutils-fcompiler-__init__.py
@@ -1,6 +1,6 @@
---- numpy/distutils/fcompiler/__init__.py.orig 2019-01-31 02:31:08 UTC
+--- numpy/distutils/fcompiler/__init__.py.orig 2021-05-09 10:38:00 UTC
+++ numpy/distutils/fcompiler/__init__.py
-@@ -177,7 +177,7 @@ class FCompiler(CCompiler):
+@@ -171,7 +171,7 @@ class FCompiler(CCompiler):
# gnu95 compiler type when there are F90 sources.
suggested_f90_compiler = None
diff --git a/math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py b/math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py
index c34798b4f9a1..5efb5d0a3d37 100644
--- a/math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py
+++ b/math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py
@@ -1,6 +1,6 @@
---- numpy/distutils/fcompiler/gnu.py.orig 2015-09-13 16:21:27 UTC
+--- numpy/distutils/fcompiler/gnu.py.orig 2021-05-08 21:14:06 UTC
+++ numpy/distutils/fcompiler/gnu.py
-@@ -83,7 +83,7 @@ class GnuFCompiler(FCompiler):
+@@ -79,7 +79,7 @@ class GnuFCompiler(FCompiler):
return None
return v[1]
@@ -9,7 +9,7 @@
executables = {
'version_cmd' : [None, "-dumpversion"],
'compiler_f77' : [None, "-g", "-Wall", "-fno-second-underscore"],
-@@ -107,11 +107,13 @@ class GnuFCompiler(FCompiler):
+@@ -103,11 +103,13 @@ class GnuFCompiler(FCompiler):
for key in ['version_cmd', 'compiler_f77', 'linker_so', 'linker_exe']:
executables[key].append('-mno-cygwin')
@@ -24,7 +24,7 @@
if sys.platform == 'darwin':
target = os.environ.get('MACOSX_DEPLOYMENT_TARGET', None)
# If MACOSX_DEPLOYMENT_TARGET is set, we simply trust the value
-@@ -265,7 +267,7 @@ class Gnu95FCompiler(GnuFCompiler):
+@@ -287,7 +289,7 @@ class Gnu95FCompiler(GnuFCompiler):
self.executables[key].append('-mno-cygwin')
return v
diff --git a/math/py-numpy/files/patch-numpy-distutils-system_info.py b/math/py-numpy/files/patch-numpy-distutils-system_info.py
index 299f98311648..4ba9667e65c6 100644
--- a/math/py-numpy/files/patch-numpy-distutils-system_info.py
+++ b/math/py-numpy/files/patch-numpy-distutils-system_info.py
@@ -1,6 +1,6 @@
---- numpy/distutils/system_info.py.orig 2019-08-27 21:01:36 UTC
+--- numpy/distutils/system_info.py.orig 2021-05-09 10:38:00 UTC
+++ numpy/distutils/system_info.py
-@@ -172,6 +172,8 @@ def _c_string_literal(s):
+@@ -209,6 +209,8 @@ def _c_string_literal(s):
Convert a python string into a literal suitable for inclusion into C code
"""
# only these three characters are forbidden in C strings
@@ -9,7 +9,7 @@
s = s.replace('\\', r'\\')
s = s.replace('"', r'\"')
s = s.replace('\n', r'\n')
-@@ -1112,8 +1114,8 @@ class atlas_info(system_info):
+@@ -1322,8 +1324,8 @@ class atlas_info(system_info):
dir_env_var = 'ATLAS'
_lib_names = ['f77blas', 'cblas']
if sys.platform[:7] == 'freebsd':
@@ -20,45 +20,3 @@
else:
_lib_atlas = ['atlas']
_lib_lapack = ['lapack']
-@@ -1633,11 +1635,6 @@ class blas_opt_info(system_info):
- self.set_info(**blis_info)
- return
-
-- openblas_info = get_info('openblas')
-- if openblas_info:
-- self.set_info(**openblas_info)
-- return
--
- atlas_info = get_info('atlas_3_10_blas_threads')
- if not atlas_info:
- atlas_info = get_info('atlas_3_10_blas')
-@@ -1730,18 +1727,17 @@ class blas_info(system_info):
- # check we can link (find library)
- # some systems have separate cblas and blas libs. First
- # check for cblas lib, and if not present check for blas lib.
-- try:
-- c.link_executable(obj, os.path.join(tmpdir, "a.out"),
-- libraries=["cblas"],
-- library_dirs=info['library_dirs'],
-- extra_postargs=info.get('extra_link_args', []))
-- res = "cblas"
-- except distutils.ccompiler.LinkError:
-- c.link_executable(obj, os.path.join(tmpdir, "a.out"),
-- libraries=["blas"],
-- library_dirs=info['library_dirs'],
-- extra_postargs=info.get('extra_link_args', []))
-- res = "blas"
-+ res = None
-+ for libname in ['cblas', 'blas', 'openblas']:
-+ try:
-+ c.link_executable(obj, os.path.join(tmpdir, "a.out"),
-+ libraries=[libname],
-+ library_dirs=info['library_dirs'],
-+ extra_postargs=info.get('extra_link_args', []))
-+ res = libname
-+ break
-+ except distutils.ccompiler.LinkError:
-+ pass
- except distutils.ccompiler.CompileError:
- res = None
- finally: