aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-27 22:32:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-27 22:33:14 +0000
commit80469139f77f357b974af84e65c59f428dc130ea (patch)
tree130b69776d83217e99b614115efc08f66caf4f40 /math
parent921e007cc543520bac1adf9e96de9483cb3e725e (diff)
downloadports-80469139f77f357b974af84e65c59f428dc130ea.tar.gz
ports-80469139f77f357b974af84e65c59f428dc130ea.zip
math/octave: Update 3.1.2 -> 5.7.0
Diffstat (limited to 'math')
-rw-r--r--math/deal.ii/Makefile2
-rw-r--r--math/mcsim/Makefile1
-rw-r--r--math/octave/Makefile2
-rw-r--r--math/sundials/Makefile45
-rw-r--r--math/sundials/distinfo6
-rw-r--r--math/sundials/files/patch-config_SundialsBlas.cmake10
-rw-r--r--math/sundials/files/patch-config_SundialsFortran.cmake15
-rw-r--r--math/sundials/files/patch-config_SundialsFortran90.cmake15
-rw-r--r--math/sundials/files/patch-config_SundialsLapack.cmake10
-rw-r--r--math/sundials/files/patch-config_SundialsSuperLUMT.cmake11
-rw-r--r--math/sundials/files/patch-src_arkode_CMakeLists.txt22
-rw-r--r--math/sundials/files/patch-src_cvode_CMakeLists.txt21
-rw-r--r--math/sundials/files/patch-src_cvodes_CMakeLists.txt21
-rw-r--r--math/sundials/files/patch-src_ida_CMakeLists.txt21
-rw-r--r--math/sundials/files/patch-src_idas_CMakeLists.txt21
-rw-r--r--math/sundials/files/patch-src_kinsol_CMakeLists.txt21
-rw-r--r--math/sundials/pkg-plist134
17 files changed, 107 insertions, 271 deletions
diff --git a/math/deal.ii/Makefile b/math/deal.ii/Makefile
index 1cb851e07328..deec17783b2d 100644
--- a/math/deal.ii/Makefile
+++ b/math/deal.ii/Makefile
@@ -1,7 +1,7 @@
PORTNAME= deal.II
DISTVERSIONPREFIX= v
DISTVERSION= 9.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/mcsim/Makefile b/math/mcsim/Makefile
index 094795dc76dd..117486f6ce4f 100644
--- a/math/mcsim/Makefile
+++ b/math/mcsim/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mcsim
PORTVERSION= 6.2.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= GNU
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 7d7f49233761..da7c7d7f65a9 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -2,7 +2,7 @@
PORTNAME= octave
PORTVERSION= ${OCTAVE_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= GNU
diff --git a/math/sundials/Makefile b/math/sundials/Makefile
index 65b66fabcd47..94f9d2135dc4 100644
--- a/math/sundials/Makefile
+++ b/math/sundials/Makefile
@@ -1,8 +1,7 @@
PORTNAME= sundials
-DISTVERSION= 3.1.2
-PORTREVISION= 11
+DISTVERSION= 5.7.0
CATEGORIES= math
-MASTER_SITES= https://computation.llnl.gov/projects/sundials/download/
+MASTER_SITES= https://github.com/LLNL/sundials/releases/download/v${DISTVERSION}/
MAINTAINER= yuri@FreeBSD.org
COMMENT= SUite of Nonlinear and DIfferential/ALgebraic Equation Solvers
@@ -10,59 +9,61 @@ COMMENT= SUite of Nonlinear and DIfferential/ALgebraic Equation Solvers
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:noninja python:build # ninja doesn't support fortran
+USES= cmake:noninja fortran localbase:ldflags python:build # ninja doesn't support fortran
USE_LDCONFIG= yes
-CMAKE_ARGS= -DPTHREAD_ENABLE:BOOL=ON \
+CMAKE_ARGS= -DENABLE_PTHREAD:BOOL=ON \
-DBUILD_STATIC_LIBS:BOOL=OFF
-PLIST_SUB= SHL3=${DISTVERSION} SHL1=${DISTVERSION:R:R} SHLX3=1.1.2 SHLX1=1
+FCFLAGS:= ${FFLAGS} # project checks that these flags are equal
+
+TEST_TARGET= test
OPTIONS_DEFINE= BLAS EXAMPLES LAPACK MPI # OPENMP detection is broken in cmake: https://gitlab.kitware.com/cmake/cmake/issues/17474
-OPTIONS_DEFAULT= LAPACK
+#OPTIONS_DEFAULT= LAPACK # LAPACK is broken
OPTIONS_GROUP= VECTORS
OPTIONS_GROUP_VECTORS= HYPRE PETSC
VECTORS_DESC= Alternative vector libraries
-BLAS_DESC= Enable BLAS support
-HYPRE_DESC= HYPRE vectors support (also enables MPI)
-LAPACK_DESC= Use Lapack linear algebra (sets SUNDIALS_INDEX_TYPE=int32)
-PETSC_DESC= PETSc vectors support (also enables MPI)
OPTIONS_SUB= yes
+BLAS_DESC= Enable BLAS support
BLAS_CMAKE_BOOL= BLAS_ENABLE
-BLAS_USES= blaslapack:openblas fortran
+BLAS_USES= blaslapack:openblas
BLAS_CMAKE_ON= -DFREEBSD_GCC_DIR:STRING=${LOCALBASE}/lib/gcc${GCC_DEFAULT:S/.//} # assumes that fortran:gcc is used
EXAMPLES_CMAKE_BOOL= EXAMPLES_ENABLE_C EXAMPLES_ENABLE_CXX EXAMPLES_ENABLE_F77 EXAMPLES_ENABLE_F90
EXAMPLES_CMAKE_ON= -DEXAMPLES_INSTALL_PATH=${EXAMPLESDIR}
-HYPRE_CMAKE_BOOL= HYPRE_ENABLE
+HYPRE_DESC= HYPRE vectors support (also enables MPI)
+HYPRE_CMAKE_BOOL= ENABLE_HYPRE
HYPRE_CMAKE_ON= -DHYPRE_INCLUDE_DIR=${LOCALBASE}/include \
-DHYPRE_LIBRARY_DIR=${LOCALBASE}/lib
-HYPRE_LIB_DEPENDS= libHYPRE.so:science/hypre
+HYPRE_LIB_DEPENDS= libHYPRE.so:science/hypre # maybe is broken due to https://github.com/hypre-space/hypre/issues/464
HYPRE_IMPLIES= MPI
HYPRE_PREVENTS= LAPACK # error: Incompatible sunindextype for LAPACK; disable LAPACK and rebuild
-LAPACK_USES= blaslapack:openblas fortran
-LAPACK_CMAKE_BOOL= LAPACK_ENABLE
-LAPACK_CMAKE_ON= -DSUNDIALS_INDEX_TYPE:STRING=int32_t \
+LAPACK_DESC= Use Lapack linear algebra (sets SUNDIALS_INDEX_TYPE=int32)
+LAPACK_USES= blaslapack:openblas
+LAPACK_CMAKE_BOOL= ENABLE_LAPACK
+LAPACK_CMAKE_ON= -DSUNDIALS_INDEX_TYPE:STRING=int64_t \
-DFREEBSD_GCC_DIR:STRING=${LOCALBASE}/lib/gcc${GCC_DEFAULT:S/.//} # assumes that fortran:gcc is used
+LAPACK_BROKEN= Ignores LDFLAGS and fails to find lapack: https://github.com/LLNL/sundials/issues/74
MPI_CMAKE_ON= -DMPI_ENABLE:BOOL=ON
MPI_LIB_DEPENDS= libmpich.so:net/mpich
-PETSC_CMAKE_BOOL= PETSC_ENABLE
-PETSC_CMAKE_ON= -DPETSC_INCLUDE_DIR=${LOCALBASE}/include \
+PETSC_DESC= PETSc vectors support (also enables MPI)
+PETSC_CMAKE_BOOL= ENABLE_PETSC
+PETSC_CMAKE_ON= -DPETSC_DIR=${LOCALBASE} \
+ -DPETSC_INCLUDE_DIR=${LOCALBASE}/include \
-DPETSC_LIBRARY_DIR=${LOCALBASE}/lib
PETSC_LIB_DEPENDS= libpetsc.so:science/PETSc
PETSC_IMPLIES= MPI
PETSC_PREVENTS= LAPACK # error: Incompatible sunindextype for LAPACK; disable LAPACK and rebuild
+PERSC_BROKEN= ERROR: PETSc not functional due to index size mismatch: SUNDIALS_INDEX_SIZE=64, but PETSc was built with 32-bit indices
PORTEXAMPLES= *
-post-patch:
- @${FIND} ${WRKSRC}/examples -name "*.c" -o -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -E 's/"(ESYM|FSYM)"/" \1 "/g'
-
post-install:
@${RM} ${STAGEDIR}${PREFIX}/include/sundials/LICENSE
diff --git a/math/sundials/distinfo b/math/sundials/distinfo
index c64cf3e65774..a10e2e95c308 100644
--- a/math/sundials/distinfo
+++ b/math/sundials/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1533629106
-SHA256 (sundials-3.1.2.tar.gz) = a8985bb1e851d90e24260450667b134bc13d71f5c6effc9e1d7183bd874fe116
-SIZE (sundials-3.1.2.tar.gz) = 18212893
+TIMESTAMP = 1630044758
+SHA256 (sundials-5.7.0.tar.gz) = 48da7baa8152ddb22aed1b02d82d1dbb4fbfea22acf67634011aa0303a100a43
+SIZE (sundials-5.7.0.tar.gz) = 22612286
diff --git a/math/sundials/files/patch-config_SundialsBlas.cmake b/math/sundials/files/patch-config_SundialsBlas.cmake
deleted file mode 100644
index 74a9406d0ff4..000000000000
--- a/math/sundials/files/patch-config_SundialsBlas.cmake
+++ /dev/null
@@ -1,10 +0,0 @@
---- config/SundialsBlas.cmake.orig 2017-11-07 23:47:45 UTC
-+++ config/SundialsBlas.cmake
-@@ -74,6 +74,7 @@ if(BLAS_LIBRARIES)
-
- # Attempt to link the "ltest" executable
- try_compile(LTEST_OK ${BlasTest_DIR} ${BlasTest_DIR}
-+ LINK_DIRECTORIES ${FREEBSD_GCC_DIR}
- ltest OUTPUT_VARIABLE MY_OUTPUT)
-
- # To ensure we do not use stuff from the previous attempts,
diff --git a/math/sundials/files/patch-config_SundialsFortran.cmake b/math/sundials/files/patch-config_SundialsFortran.cmake
deleted file mode 100644
index 561332abb4ba..000000000000
--- a/math/sundials/files/patch-config_SundialsFortran.cmake
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/SundialsFortran.cmake.orig 2017-11-07 23:47:45 UTC
-+++ config/SundialsFortran.cmake
-@@ -51,9 +51,9 @@ if(CMAKE_Fortran_COMPILER)
- (NOT "${ENV_FCFLAGS}" STREQUAL "") AND
- ("${CMAKE_Fortran_FLAGS}" STREQUAL ""))
- # check if environment variables are equal
-- IF (NOT "${ENV_FFLAGS}" STREQUAL "${ENV_FCFLAGS}")
-- PRINT_ERROR("FFLAGS='${ENV_FFLAGS}' and FCFLAGS='${ENV_FCFLAGS}' are both set but are not equal.")
-- ENDIF()
-+ #IF (NOT "${ENV_FFLAGS}" STREQUAL "${ENV_FCFLAGS}")
-+ # PRINT_ERROR("FFLAGS='${ENV_FFLAGS}' and FCFLAGS='${ENV_FCFLAGS}' are both set but are not equal.")
-+ #ENDIF()
- ENDIF()
-
- # Enable the language for next steps
diff --git a/math/sundials/files/patch-config_SundialsFortran90.cmake b/math/sundials/files/patch-config_SundialsFortran90.cmake
deleted file mode 100644
index 081d9cbc4dc5..000000000000
--- a/math/sundials/files/patch-config_SundialsFortran90.cmake
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/SundialsFortran90.cmake.orig 2017-11-07 23:47:45 UTC
-+++ config/SundialsFortran90.cmake
-@@ -35,9 +35,9 @@ if(CMAKE_Fortran_COMPILER)
- (NOT "${ENV_FCFLAGS}" STREQUAL "") AND
- ("${CMAKE_Fortran_FLAGS}" STREQUAL ""))
- # check if environment variables are equal
-- IF (NOT "${ENV_FFLAGS}" STREQUAL "${ENV_FCFLAGS}")
-- PRINT_ERROR("FFLAGS='${ENV_FFLAGS}' and FCFLAGS='${ENV_FCFLAGS}' are both set but are not equal.")
-- ENDIF()
-+ #IF (NOT "${ENV_FFLAGS}" STREQUAL "${ENV_FCFLAGS}")
-+ # PRINT_ERROR("FFLAGS='${ENV_FFLAGS}' and FCFLAGS='${ENV_FCFLAGS}' are both set but are not equal.")
-+ #ENDIF()
- ENDIF()
-
- # Enable the language for next steps
diff --git a/math/sundials/files/patch-config_SundialsLapack.cmake b/math/sundials/files/patch-config_SundialsLapack.cmake
deleted file mode 100644
index 248f4d07f0cf..000000000000
--- a/math/sundials/files/patch-config_SundialsLapack.cmake
+++ /dev/null
@@ -1,10 +0,0 @@
---- config/SundialsLapack.cmake.orig 2017-11-07 23:47:45 UTC
-+++ config/SundialsLapack.cmake
-@@ -75,6 +75,7 @@ if(LAPACK_LIBRARIES)
-
- # Attempt to link the "ltest" executable
- try_compile(LTEST_OK ${LapackTest_DIR} ${LapackTest_DIR}
-+ LINK_DIRECTORIES ${FREEBSD_GCC_DIR}
- ltest OUTPUT_VARIABLE MY_OUTPUT)
-
- # To ensure we do not use stuff from the previous attempts,
diff --git a/math/sundials/files/patch-config_SundialsSuperLUMT.cmake b/math/sundials/files/patch-config_SundialsSuperLUMT.cmake
deleted file mode 100644
index 2b0a1670ab19..000000000000
--- a/math/sundials/files/patch-config_SundialsSuperLUMT.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- config/SundialsSuperLUMT.cmake.orig 2017-12-28 04:44:39 UTC
-+++ config/SundialsSuperLUMT.cmake
-@@ -61,7 +61,7 @@ if(SUPERLUMT_LIBRARY AND SUPERLUMT_LIBRA
- "}\n")
-
- # Attempt to link the "ltest" executable
-- try_compile(LTEST_OK ${SUPERLUMT_TEST_DIR} ${SUPERLUMT_TEST_DIR} ltest OUTPUT_VARIABLE MY_OUTPUT)
-+ try_compile(LTEST_OK ${SUPERLUMT_TEST_DIR} ${SUPERLUMT_TEST_DIR} LINK_DIRECTORIES ${FREEBSD_GCC_DIR} ltest OUTPUT_VARIABLE MY_OUTPUT)
-
- # To ensure we do not use stuff from the previous attempts,
- # we must remove the CMakeFiles directory.
diff --git a/math/sundials/files/patch-src_arkode_CMakeLists.txt b/math/sundials/files/patch-src_arkode_CMakeLists.txt
deleted file mode 100644
index 93a9caa23adf..000000000000
--- a/math/sundials/files/patch-src_arkode_CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/arkode/CMakeLists.txt.orig 2017-11-07 23:47:45 UTC
-+++ src/arkode/CMakeLists.txt
-@@ -112,6 +112,19 @@ IF(BUILD_SHARED_LIBS)
- TARGET_LINK_LIBRARIES(sundials_arkode_shared m)
- ENDIF()
-
-+
-+ IF(UNIX)
-+ TARGET_LINK_LIBRARIES(sundials_arkode_shared m)
-+ ENDIF()
-+
-+ IF(LAPACK_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_arkode_shared ${LAPACK_LIBRARIES})
-+ ENDIF()
-+
-+ IF(KLU_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_arkode_shared ${KLU_LIBRARIES})
-+ ENDIF ()
-+
- # Set the library name and make sure it is not deleted
- SET_TARGET_PROPERTIES(sundials_arkode_shared
- PROPERTIES OUTPUT_NAME sundials_arkode CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_cvode_CMakeLists.txt b/math/sundials/files/patch-src_cvode_CMakeLists.txt
deleted file mode 100644
index 03b9411207cf..000000000000
--- a/math/sundials/files/patch-src_cvode_CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/cvode/CMakeLists.txt.orig 2017-11-07 23:47:57 UTC
-+++ src/cvode/CMakeLists.txt
-@@ -114,6 +114,18 @@ IF(BUILD_SHARED_LIBS)
- TARGET_LINK_LIBRARIES(sundials_cvode_shared m)
- ENDIF()
-
-+ IF(UNIX)
-+ TARGET_LINK_LIBRARIES(sundials_cvode_shared m)
-+ ENDIF()
-+
-+ IF(LAPACK_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_cvode_shared ${LAPACK_LIBRARIES})
-+ ENDIF()
-+
-+ IF(KLU_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_cvode_shared ${KLU_LIBRARIES})
-+ ENDIF ()
-+
- # Set the library name and make sure it is not deleted
- SET_TARGET_PROPERTIES(sundials_cvode_shared
- PROPERTIES OUTPUT_NAME sundials_cvode CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_cvodes_CMakeLists.txt b/math/sundials/files/patch-src_cvodes_CMakeLists.txt
deleted file mode 100644
index 9cc862d4f65d..000000000000
--- a/math/sundials/files/patch-src_cvodes_CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/cvodes/CMakeLists.txt.orig 2017-11-07 23:48:01 UTC
-+++ src/cvodes/CMakeLists.txt
-@@ -116,6 +116,18 @@ IF(BUILD_SHARED_LIBS)
- TARGET_LINK_LIBRARIES(sundials_cvodes_shared m)
- ENDIF()
-
-+ IF(UNIX)
-+ TARGET_LINK_LIBRARIES(sundials_cvodes_shared m)
-+ ENDIF()
-+
-+ IF(LAPACK_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_cvodes_shared ${LAPACK_LIBRARIES})
-+ ENDIF()
-+
-+ IF(KLU_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_cvodes_shared ${KLU_LIBRARIES})
-+ ENDIF()
-+
- # Set the library name and make sure it is not deleted
- SET_TARGET_PROPERTIES(sundials_cvodes_shared
- PROPERTIES OUTPUT_NAME sundials_cvodes CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_ida_CMakeLists.txt b/math/sundials/files/patch-src_ida_CMakeLists.txt
deleted file mode 100644
index b44f0c2b63a6..000000000000
--- a/math/sundials/files/patch-src_ida_CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/ida/CMakeLists.txt.orig 2017-11-07 23:48:06 UTC
-+++ src/ida/CMakeLists.txt
-@@ -117,6 +117,18 @@ IF(BUILD_SHARED_LIBS)
- TARGET_LINK_LIBRARIES(sundials_ida_shared m)
- ENDIF()
-
-+ IF(UNIX)
-+ TARGET_LINK_LIBRARIES(sundials_ida_shared m)
-+ ENDIF()
-+
-+ IF(LAPACK_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_ida_shared ${LAPACK_LIBRARIES})
-+ ENDIF()
-+
-+ IF(KLU_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_ida_shared ${KLU_LIBRARIES})
-+ ENDIF()
-+
- # Set the library name and make sure it is not deleted
- SET_TARGET_PROPERTIES(sundials_ida_shared
- PROPERTIES OUTPUT_NAME sundials_ida CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_idas_CMakeLists.txt b/math/sundials/files/patch-src_idas_CMakeLists.txt
deleted file mode 100644
index 473abaef7f15..000000000000
--- a/math/sundials/files/patch-src_idas_CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/idas/CMakeLists.txt.orig 2017-11-07 23:48:10 UTC
-+++ src/idas/CMakeLists.txt
-@@ -113,6 +113,18 @@ IF(BUILD_SHARED_LIBS)
- TARGET_LINK_LIBRARIES(sundials_idas_shared m)
- ENDIF()
-
-+ IF(UNIX)
-+ TARGET_LINK_LIBRARIES(sundials_idas_shared m)
-+ ENDIF()
-+
-+ IF(LAPACK_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_idas_shared ${LAPACK_LIBRARIES})
-+ ENDIF()
-+
-+ IF(KLU_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_idas_shared ${KLU_LIBRARIES})
-+ ENDIF()
-+
- # Set the library name and make sure it is not deleted
- SET_TARGET_PROPERTIES(sundials_idas_shared
- PROPERTIES OUTPUT_NAME sundials_idas CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/files/patch-src_kinsol_CMakeLists.txt b/math/sundials/files/patch-src_kinsol_CMakeLists.txt
deleted file mode 100644
index 18ee03deee25..000000000000
--- a/math/sundials/files/patch-src_kinsol_CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/kinsol/CMakeLists.txt.orig 2017-11-07 23:48:14 UTC
-+++ src/kinsol/CMakeLists.txt
-@@ -110,6 +110,18 @@ IF(BUILD_SHARED_LIBS)
- TARGET_LINK_LIBRARIES(sundials_kinsol_shared m)
- ENDIF()
-
-+ IF(UNIX)
-+ TARGET_LINK_LIBRARIES(sundials_kinsol_shared m)
-+ ENDIF()
-+
-+ IF(LAPACK_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_kinsol_shared ${LAPACK_LIBRARIES})
-+ ENDIF()
-+
-+ IF(KLU_FOUND)
-+ TARGET_LINK_LIBRARIES(sundials_kinsol_shared ${KLU_LIBRARIES})
-+ ENDIF()
-+
- # Set the library name and make sure it is not deleted
- SET_TARGET_PROPERTIES(sundials_kinsol_shared
- PROPERTIES OUTPUT_NAME sundials_kinsol CLEAN_DIRECT_OUTPUT 1)
diff --git a/math/sundials/pkg-plist b/math/sundials/pkg-plist
index 0321eeacf1f5..0b3cc85473cc 100644
--- a/math/sundials/pkg-plist
+++ b/math/sundials/pkg-plist
@@ -1,62 +1,69 @@
include/arkode/arkode.h
+include/arkode/arkode_arkstep.h
include/arkode/arkode_bandpre.h
include/arkode/arkode_bbdpre.h
-include/arkode/arkode_direct.h
-include/arkode/arkode_impl.h
-include/arkode/arkode_spils.h
+include/arkode/arkode_butcher.h
+include/arkode/arkode_butcher_dirk.h
+include/arkode/arkode_butcher_erk.h
+include/arkode/arkode_erkstep.h
+include/arkode/arkode_ls.h
+include/arkode/arkode_mristep.h
include/cvode/cvode.h
include/cvode/cvode_bandpre.h
include/cvode/cvode_bbdpre.h
include/cvode/cvode_diag.h
include/cvode/cvode_direct.h
-include/cvode/cvode_impl.h
+include/cvode/cvode_ls.h
+include/cvode/cvode_proj.h
include/cvode/cvode_spils.h
include/cvodes/cvodes.h
include/cvodes/cvodes_bandpre.h
include/cvodes/cvodes_bbdpre.h
include/cvodes/cvodes_diag.h
include/cvodes/cvodes_direct.h
-include/cvodes/cvodes_impl.h
+include/cvodes/cvodes_ls.h
include/cvodes/cvodes_spils.h
include/ida/ida.h
include/ida/ida_bbdpre.h
include/ida/ida_direct.h
-include/ida/ida_impl.h
+include/ida/ida_ls.h
include/ida/ida_spils.h
include/idas/idas.h
include/idas/idas_bbdpre.h
include/idas/idas_direct.h
-include/idas/idas_impl.h
+include/idas/idas_ls.h
include/idas/idas_spils.h
include/kinsol/kinsol.h
include/kinsol/kinsol_bbdpre.h
include/kinsol/kinsol_direct.h
-include/kinsol/kinsol_impl.h
+include/kinsol/kinsol_ls.h
include/kinsol/kinsol_spils.h
+include/nvector/nvector_manyvector.h
+%%MPI%%include/nvector/nvector_mpimanyvector.h
+%%MPI%%include/nvector/nvector_mpiplusx.h
%%MPI%%include/nvector/nvector_parallel.h
%%HYPRE%%include/nvector/nvector_parhyp.h
%%PETSC%%include/nvector/nvector_petsc.h
include/nvector/nvector_pthreads.h
include/nvector/nvector_serial.h
+include/sundials/NOTICE
include/sundials/sundials_band.h
include/sundials/sundials_config.h
include/sundials/sundials_dense.h
include/sundials/sundials_direct.h
+include/sundials/sundials_export.h
include/sundials/sundials_fconfig.h
include/sundials/sundials_fnvector.h
+include/sundials/sundials_futils.h
include/sundials/sundials_iterative.h
%%LAPACK%%include/sundials/sundials_lapack.h
include/sundials/sundials_linearsolver.h
include/sundials/sundials_math.h
include/sundials/sundials_matrix.h
+include/sundials/sundials_memory.h
%%MPI%%include/sundials/sundials_mpi_types.h
+include/sundials/sundials_nonlinearsolver.h
include/sundials/sundials_nvector.h
-include/sundials/sundials_pcg.h
-include/sundials/sundials_sparse.h
-include/sundials/sundials_spbcgs.h
-include/sundials/sundials_spfgmr.h
-include/sundials/sundials_spgmr.h
-include/sundials/sundials_sptfqmr.h
include/sundials/sundials_types.h
include/sundials/sundials_version.h
include/sunlinsol/sunlinsol_band.h
@@ -71,45 +78,61 @@ include/sunlinsol/sunlinsol_sptfqmr.h
include/sunmatrix/sunmatrix_band.h
include/sunmatrix/sunmatrix_dense.h
include/sunmatrix/sunmatrix_sparse.h
+include/sunnonlinsol/sunnonlinsol_fixedpoint.h
+include/sunnonlinsol/sunnonlinsol_newton.h
+lib/cmake/sundials/SUNDIALSConfig.cmake
+lib/cmake/sundials/SUNDIALSConfigVersion.cmake
+lib/cmake/sundials/SUNDIALSTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/sundials/SUNDIALSTargets.cmake
lib/libsundials_arkode.so
-lib/libsundials_arkode.so.2
-lib/libsundials_arkode.so.2.1.2
+lib/libsundials_arkode.so.4
+lib/libsundials_arkode.so.4.7.0
lib/libsundials_cvode.so
-lib/libsundials_cvode.so.%%SHL1%%
-lib/libsundials_cvode.so.%%SHL3%%
+lib/libsundials_cvode.so.5
+lib/libsundials_cvode.so.5.7.0
lib/libsundials_cvodes.so
-lib/libsundials_cvodes.so.%%SHL1%%
-lib/libsundials_cvodes.so.%%SHL3%%
+lib/libsundials_cvodes.so.5
+lib/libsundials_cvodes.so.5.7.0
+lib/libsundials_generic.so
+lib/libsundials_generic.so.5
+lib/libsundials_generic.so.5.7.0
lib/libsundials_ida.so
-lib/libsundials_ida.so.%%SHL1%%
-lib/libsundials_ida.so.%%SHL3%%
+lib/libsundials_ida.so.5
+lib/libsundials_ida.so.5.7.0
lib/libsundials_idas.so
-lib/libsundials_idas.so.2
-lib/libsundials_idas.so.2.1.2
+lib/libsundials_idas.so.4
+lib/libsundials_idas.so.4.7.0
lib/libsundials_kinsol.so
-lib/libsundials_kinsol.so.%%SHL1%%
-lib/libsundials_kinsol.so.%%SHL3%%
+lib/libsundials_kinsol.so.5
+lib/libsundials_kinsol.so.5.7.0
+lib/libsundials_nvecmanyvector.so
+lib/libsundials_nvecmanyvector.so.5
+lib/libsundials_nvecmanyvector.so.5.7.0
+%%MPI%%lib/libsundials_nvecmpimanyvector.so
+%%MPI%%lib/libsundials_nvecmpimanyvector.so.5
+%%MPI%%lib/libsundials_nvecmpimanyvector.so.5.7.0
+%%MPI%%lib/libsundials_nvecmpiplusx.so
+%%MPI%%lib/libsundials_nvecmpiplusx.so.5
+%%MPI%%lib/libsundials_nvecmpiplusx.so.5.7.0
%%MPI%%lib/libsundials_nvecparallel.so
-%%MPI%%lib/libsundials_nvecparallel.so.%%SHL1%%
-%%MPI%%lib/libsundials_nvecparallel.so.%%SHL3%%
+%%MPI%%lib/libsundials_nvecparallel.so.5
+%%MPI%%lib/libsundials_nvecparallel.so.5.7.0
%%HYPRE%%lib/libsundials_nvecparhyp.so
-%%HYPRE%%lib/libsundials_nvecparhyp.so.%%SHL1%%
-%%HYPRE%%lib/libsundials_nvecparhyp.so.%%SHL3%%
+%%HYPRE%%lib/libsundials_nvecparhyp.so.5
+%%HYPRE%%lib/libsundials_nvecparhyp.so.5.7.0
%%PETSC%%lib/libsundials_nvecpetsc.so
-%%PETSC%%lib/libsundials_nvecpetsc.so.%%SHL1%%
-%%PETSC%%lib/libsundials_nvecpetsc.so.%%SHL3%%
+%%PETSC%%lib/libsundials_nvecpetsc.so.3
+%%PETSC%%lib/libsundials_nvecpetsc.so.3.1.2
lib/libsundials_nvecpthreads.so
-lib/libsundials_nvecpthreads.so.%%SHL1%%
-lib/libsundials_nvecpthreads.so.%%SHL3%%
+lib/libsundials_nvecpthreads.so.5
+lib/libsundials_nvecpthreads.so.5.7.0
lib/libsundials_nvecserial.so
-lib/libsundials_nvecserial.so.%%SHL1%%
-lib/libsundials_nvecserial.so.%%SHL3%%
+lib/libsundials_nvecserial.so.5
+lib/libsundials_nvecserial.so.5.7.0
lib/libsundials_sunlinsolband.so
-lib/libsundials_sunlinsolband.so.%%SHLX1%%
-lib/libsundials_sunlinsolband.so.%%SHLX3%%
+lib/libsundials_sunlinsolband.so.3.7.0
lib/libsundials_sunlinsoldense.so
-lib/libsundials_sunlinsoldense.so.%%SHLX1%%
-lib/libsundials_sunlinsoldense.so.%%SHLX3%%
+lib/libsundials_sunlinsoldense.so.3.7.0
%%LAPACK%%lib/libsundials_sunlinsollapackband.so
%%LAPACK%%lib/libsundials_sunlinsollapackband.so.%%SHLX1%%
%%LAPACK%%lib/libsundials_sunlinsollapackband.so.%%SHLX3%%
@@ -117,26 +140,25 @@ lib/libsundials_sunlinsoldense.so.%%SHLX3%%
%%LAPACK%%lib/libsundials_sunlinsollapackdense.so.%%SHLX1%%
%%LAPACK%%lib/libsundials_sunlinsollapackdense.so.%%SHLX3%%
lib/libsundials_sunlinsolpcg.so
-lib/libsundials_sunlinsolpcg.so.%%SHLX1%%
-lib/libsundials_sunlinsolpcg.so.%%SHLX3%%
+lib/libsundials_sunlinsolpcg.so.3.7.0
lib/libsundials_sunlinsolspbcgs.so
-lib/libsundials_sunlinsolspbcgs.so.%%SHLX1%%
-lib/libsundials_sunlinsolspbcgs.so.%%SHLX3%%
+lib/libsundials_sunlinsolspbcgs.so.3.7.0
lib/libsundials_sunlinsolspfgmr.so
-lib/libsundials_sunlinsolspfgmr.so.%%SHLX1%%
-lib/libsundials_sunlinsolspfgmr.so.%%SHLX3%%
+lib/libsundials_sunlinsolspfgmr.so.3.7.0
lib/libsundials_sunlinsolspgmr.so
-lib/libsundials_sunlinsolspgmr.so.%%SHLX1%%
-lib/libsundials_sunlinsolspgmr.so.%%SHLX3%%
+lib/libsundials_sunlinsolspgmr.so.3.7.0
lib/libsundials_sunlinsolsptfqmr.so
-lib/libsundials_sunlinsolsptfqmr.so.%%SHLX1%%
-lib/libsundials_sunlinsolsptfqmr.so.%%SHLX3%%
+lib/libsundials_sunlinsolsptfqmr.so.3.7.0
lib/libsundials_sunmatrixband.so
-lib/libsundials_sunmatrixband.so.%%SHLX1%%
-lib/libsundials_sunmatrixband.so.%%SHLX3%%
+lib/libsundials_sunmatrixband.so.3
+lib/libsundials_sunmatrixband.so.3.7.0
lib/libsundials_sunmatrixdense.so
-lib/libsundials_sunmatrixdense.so.%%SHLX1%%
-lib/libsundials_sunmatrixdense.so.%%SHLX3%%
+lib/libsundials_sunmatrixdense.so.3
+lib/libsundials_sunmatrixdense.so.3.7.0
lib/libsundials_sunmatrixsparse.so
-lib/libsundials_sunmatrixsparse.so.%%SHLX1%%
-lib/libsundials_sunmatrixsparse.so.%%SHLX3%%
+lib/libsundials_sunmatrixsparse.so.3
+lib/libsundials_sunmatrixsparse.so.3.7.0
+lib/libsundials_sunnonlinsolfixedpoint.so
+lib/libsundials_sunnonlinsolfixedpoint.so.2.7.0
+lib/libsundials_sunnonlinsolnewton.so
+lib/libsundials_sunnonlinsolnewton.so.2.7.0