aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:10:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:10:33 +0000
commit853523a04d21b463f682209777e22465194eaeb2 (patch)
tree0fac8e664b3a45872ed66896ad49e5b355c94e59 /math
parent079a9de859216383231de486fe8005a45d6b7b9b (diff)
downloadports-853523a04d21b463f682209777e22465194eaeb2.tar.gz
ports-853523a04d21b463f682209777e22465194eaeb2.zip
math/py-scikit-fem: Add py-scikit-fem 8.1.0
scikit-fem is a pure Python library for performing finite element assembly. Its main purpose is the transformation of bilinear forms into sparse matrices and linear forms into vectors. The library - has minimal dependencies - contains no compiled code - supports one-dimensional, triangular, quadrilateral, tetrahedral and hexahedral finite elements - includes special elements such as Raviart-Thomas, Nedelec, MINI, Crouzeix-Raviart, Argyris, ...
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-scikit-fem/Makefile24
-rw-r--r--math/py-scikit-fem/distinfo3
-rw-r--r--math/py-scikit-fem/pkg-descr11
4 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index f69d5b82a5b5..55af21bdbc42 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -1042,6 +1042,7 @@
SUBDIR += py-rpy2
SUBDIR += py-rustworkx
SUBDIR += py-rvlib
+ SUBDIR += py-scikit-fem
SUBDIR += py-scikit-umfpack
SUBDIR += py-scs
SUBDIR += py-seaborn
diff --git a/math/py-scikit-fem/Makefile b/math/py-scikit-fem/Makefile
new file mode 100644
index 000000000000..481c288c58e5
--- /dev/null
+++ b/math/py-scikit-fem/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= scikit-fem
+PORTVERSION= 8.1.0
+CATEGORIES= math python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple finite element assemblers
+WWW= https://github.com/kinnala/scikit-fem
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=42:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-scikit-fem/distinfo b/math/py-scikit-fem/distinfo
new file mode 100644
index 000000000000..cc19e530506d
--- /dev/null
+++ b/math/py-scikit-fem/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688166026
+SHA256 (scikit-fem-8.1.0.tar.gz) = 6dbc2656f358e37180e92265b9ae8fac358ccd906a2be83337c178cc7a0c6972
+SIZE (scikit-fem-8.1.0.tar.gz) = 143833
diff --git a/math/py-scikit-fem/pkg-descr b/math/py-scikit-fem/pkg-descr
new file mode 100644
index 000000000000..8bf143ab09a6
--- /dev/null
+++ b/math/py-scikit-fem/pkg-descr
@@ -0,0 +1,11 @@
+scikit-fem is a pure Python library for performing finite element assembly. Its
+main purpose is the transformation of bilinear forms into sparse matrices and
+linear forms into vectors.
+
+The library
+- has minimal dependencies
+- contains no compiled code
+- supports one-dimensional, triangular, quadrilateral, tetrahedral and
+ hexahedral finite elements
+- includes special elements such as Raviart-Thomas, Nedelec, MINI,
+ Crouzeix-Raviart, Argyris, ...