aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-06 21:43:48 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-06 21:43:48 +0000
commit94416bcf15318bdcbce0cb52d37e44f61167ed25 (patch)
treeaec178d7e7a85f35ed2de7b3c0da79c3944d66be /math
parent61adc0389b9c587fc2ddbc4114f912914d535073 (diff)
downloadports-94416bcf15318bdcbce0cb52d37e44f61167ed25.tar.gz
ports-94416bcf15318bdcbce0cb52d37e44f61167ed25.zip
- Update from v0.25 to v0.26
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=164654
Diffstat (limited to 'math')
-rw-r--r--math/p5-CAD-Calc/Makefile7
-rw-r--r--math/p5-CAD-Calc/distinfo6
-rw-r--r--math/p5-CAD-Calc/files/patch-lib-Calc.pm11
3 files changed, 7 insertions, 17 deletions
diff --git a/math/p5-CAD-Calc/Makefile b/math/p5-CAD-Calc/Makefile
index e733a5b1cab9..08244a7c7d6a 100644
--- a/math/p5-CAD-Calc/Makefile
+++ b/math/p5-CAD-Calc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= CAD-Calc
-PORTVERSION= 0.25
+PORTVERSION= 0.26
CATEGORIES= math graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CAD
@@ -17,7 +17,8 @@ COMMENT= Generic cad-related geometry calculations
BUILD_DEPENDS= ${SITE_PERL}/Math/Vec.pm:${PORTSDIR}/math/p5-Math-Vec \
${SITE_PERL}/Math/Round/Var.pm:${PORTSDIR}/math/p5-Math-Round-Var \
- ${SITE_PERL}/Math/BigFloat.pm:${PORTSDIR}/math/p5-Math-BigInt
+ ${SITE_PERL}/Math/BigFloat.pm:${PORTSDIR}/math/p5-Math-BigInt \
+ ${SITE_PERL}/Math/Geometry/Planar/Offset.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-Offset
RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3= CAD::Calc.3
@@ -26,7 +27,7 @@ PERL_MODBUILD= yes
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
+.if ${PERL_LEVEL} < 500600 # inherited from math/p5-Math-Vec
IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
.endif
diff --git a/math/p5-CAD-Calc/distinfo b/math/p5-CAD-Calc/distinfo
index 70d17ec33c41..6a22682a22d2 100644
--- a/math/p5-CAD-Calc/distinfo
+++ b/math/p5-CAD-Calc/distinfo
@@ -1,3 +1,3 @@
-MD5 (CAD-Calc-0.25.tar.gz) = 8c6d7c470d403fc6d1e683002a418bcd
-SHA256 (CAD-Calc-0.25.tar.gz) = 09dd6205895f8d476e65d38c2c6b61ab143a5d7d59cdf9b9d3ac8e40dae566c7
-SIZE (CAD-Calc-0.25.tar.gz) = 12725
+MD5 (CAD-Calc-0.26.tar.gz) = d261fcfd17f2886dd88b4a28b3743e9e
+SHA256 (CAD-Calc-0.26.tar.gz) = 3d467d344077fc63768cff1b3c453ea4a989c355f340dab62b275d21462374e9
+SIZE (CAD-Calc-0.26.tar.gz) = 13207
diff --git a/math/p5-CAD-Calc/files/patch-lib-Calc.pm b/math/p5-CAD-Calc/files/patch-lib-Calc.pm
deleted file mode 100644
index 0c5df25c8902..000000000000
--- a/math/p5-CAD-Calc/files/patch-lib-Calc.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/CAD/Calc.pm Fri Jan 6 22:25:54 2006
-+++ lib/CAD/Calc.pm Sun May 21 16:15:57 2006
-@@ -1,7 +1,7 @@
- package CAD::Calc;
- our $VERSION = '0.25';
-
--use Math::Vec qw(NewVec :terse);
-+use Math::Vec qw(:terse NewVec);
- use Math::Complex qw(acos);
- use Math::Round::Var;
- use Math::BigFloat;