aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-02-24 17:53:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-02-24 17:54:19 +0000
commita25970a7d37960273cf707c7f8b749848a28f18d (patch)
tree03b3bb19bde8edc7736ba47055299d4f0924502b /math
parent99cb092febcfa7ff125dc2ebcb4416fb9b771a7f (diff)
downloadports-a25970a7d37960273cf707c7f8b749848a28f18d.tar.gz
ports-a25970a7d37960273cf707c7f8b749848a28f18d.zip
math/py-ipyopt: New port: Python interface to Ipopt
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-ipyopt/Makefile31
-rw-r--r--math/py-ipyopt/distinfo3
-rw-r--r--math/py-ipyopt/pkg-descr3
4 files changed, 38 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 72a5e31e9b18..70451d05c518 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -850,6 +850,7 @@
SUBDIR += py-iminuit
SUBDIR += py-intspan
SUBDIR += py-iohexperimenter
+ SUBDIR += py-ipyopt
SUBDIR += py-jax
SUBDIR += py-keras
SUBDIR += py-keras-applications
diff --git a/math/py-ipyopt/Makefile b/math/py-ipyopt/Makefile
new file mode 100644
index 000000000000..ee8a247a3a91
--- /dev/null
+++ b/math/py-ipyopt/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= ipyopt
+DISTVERSION= 0.12.2
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python interface to Ipopt
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+LIB_DEPENDS= libipopt.so:math/ipopt
+RUN_DEPENDS= ${PY_DEPENDS}
+TEST_DEPENDS= py.test:devel/py-pytest@${PY_FLAVOR}
+
+USES= compiler:c++17-lang pkgconfig python:3.6+
+USE_PYTHON= distutils autoplist
+
+CXXFLAGS+= $(pkg-config --cflags ipopt)
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/${PORTNAME}.cpython-*.so
+
+do-test: # tests fail: https://gitlab.com/g-braeunlich/ipyopt/-/issues/6
+ @cd ${WRKSRC} && pytest
+
+.include <bsd.port.mk>
diff --git a/math/py-ipyopt/distinfo b/math/py-ipyopt/distinfo
new file mode 100644
index 000000000000..beb76c6a4113
--- /dev/null
+++ b/math/py-ipyopt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1645723676
+SHA256 (ipyopt-0.12.2.tar.gz) = bc92d0c83713fb81374aef6425db8af182c088eeae12233a274e56ee0bd2305c
+SIZE (ipyopt-0.12.2.tar.gz) = 35177
diff --git a/math/py-ipyopt/pkg-descr b/math/py-ipyopt/pkg-descr
new file mode 100644
index 000000000000..0aaaad22f440
--- /dev/null
+++ b/math/py-ipyopt/pkg-descr
@@ -0,0 +1,3 @@
+Python interface for the interior point optimizer COIN-OR IPOpt.
+
+WWW: https://gitlab.com/g-braeunlich/ipyopt