aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-07-21 20:38:05 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-07-25 16:01:48 +0000
commita36e5a3440e59bd0e2a42f16d0ca5b820be234d9 (patch)
tree981e484144d1492fdab5e785e1d1a0242d9ef5ce /math
parent0e16088e4a731a766a3609d9efb0de6d741d8266 (diff)
math/lapack: fix post-patch target for math/atlas
When upgrading this port, I previously merged the post-patch with the pre-configure target, and it was a mistake. The patch target is used from math/atlas, and make.inc is needed. PR: 257122 Reported by: alt2600 (at) icloud.com MFH: 2021Q3 (cherry picked from commit b7eec409d5664a73725c392b83e4f2741c5ad33f)
Diffstat (limited to 'math')
-rw-r--r--math/lapack/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/lapack/Makefile b/math/lapack/Makefile
index 128c6f2eb4da..5b6cf934e9a5 100644
--- a/math/lapack/Makefile
+++ b/math/lapack/Makefile
@@ -80,7 +80,7 @@ PLIST_SUB+= BLAS="@comment " CBLAS="@comment " LAPACK="" XLAPACK="@comment " LA
.include <bsd.port.pre.mk>
-pre-configure:
+post-patch:
${SED} -Ee '\
s@^(FORTRAN|LOADER)([[:blank:]]*=)(.*)@\1\2 $${FC}@; \
s@^(OPTS[[:blank:]]*=)(.*)@\1 $${FFLAGS} $${EXTRAFLAGS}@; \
@@ -93,6 +93,8 @@ pre-configure:
s@^(LDFLAGS[[:blank:]]*=)(.*)@@; \
\@(BLAS|LAPACKE|RAN)LIB[[:blank:]]*=@d;' \
${WRKSRC}/make.inc.example > ${WRKSRC}/make.inc
+
+pre-configure:
${REINPLACE_CMD} -e 's@\./lapack_testing\.py@${S} &@' \
${WRKSRC}/Makefile
${FIND} ${WRKSRC} -name Makefile | ${XARGS} \