aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2016-10-25 18:18:56 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2016-10-25 18:18:56 +0000
commitafe74630902e1c60c54d0949855eebca4a1de58c (patch)
tree0453df5217131dc902611c4018dcf088805c92de /math
parent1ca5cffd50ed5b3d5fbc15ba2dfa2f2545235067 (diff)
downloadports-afe74630902e1c60c54d0949855eebca4a1de58c.tar.gz
ports-afe74630902e1c60c54d0949855eebca4a1de58c.zip
math/libRmath: make standalone (free from math/R) and unmark as
BROKEN Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D8289
Notes
Notes: svn path=/head/; revision=424642
Diffstat (limited to 'math')
-rw-r--r--math/libRmath/Makefile45
-rw-r--r--math/libRmath/distinfo3
2 files changed, 39 insertions, 9 deletions
diff --git a/math/libRmath/Makefile b/math/libRmath/Makefile
index e12cf2cae589..c67aae6f3c7b 100644
--- a/math/libRmath/Makefile
+++ b/math/libRmath/Makefile
@@ -1,17 +1,44 @@
# Created by: Eric van Gyzen <vangyzen@stat.duke.edu>
# $FreeBSD$
-PORTNAME= libRmath
+PORTNAME= libRmath
+PORTVERSION= 3.3.1
+CATEGORIES= math lang
+MASTER_SITES= CRAN/src/base/R-${PORTVERSION:C|\..*||}
+DISTNAME= R-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
-COMMENT= The standalone math library from R
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Standalone math library from R
-BROKEN= fails to configure
+LICENSE= GPLv2
-DESCR= ${.CURDIR}/pkg-descr
-LIBRMATH_SLAVEPORT= yes
-MASTERDIR= ${.CURDIR}/../R
-PLIST= ${.CURDIR}/pkg-plist
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libpcre.so:devel/pcre
-BROKEN_powerpc64= Does not build
+BUILD_WRKSRC= ${WRKSRC}/src/nmath/standalone
+CONFIGURE_ARGS= --disable-nls --with-ICU=no --with-cairo=no \
+ --with-jpeglib=no --with-libpng=no --with-libtiff=no \
+ --with-readline=no --with-tcltk=no --with-x=no \
+ --without-libintl-prefix
+CONFIGURE_ENV+= ac_cv_header_iconv_h=no
+GNU_CONFIGURE= yes
+RMATH_SOVERSION= 1
+USES= fortran localbase
+USE_LDCONFIG= yes
-.include "${MASTERDIR}/Makefile"
+PLIST_SUB= RMATH_SOVERSION="${RMATH_SOVERSION}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g'\
+ ${WRKSRC}/src/nmath/standalone/Makefile.in \
+ ${WRKSRC}/src/unix/Makefile.in
+ @${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|g" \
+ ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/include/Rmath.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/libRmath.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${BUILD_WRKSRC}/libRmath.so ${STAGEDIR}${PREFIX}/lib/libRmath.so
+ (cd ${STAGEDIR}${PREFIX}/lib; ${LN} -sf libRmath.so libRmath.so.${RMATH_SOVERSION})
+
+.include <bsd.port.mk>
diff --git a/math/libRmath/distinfo b/math/libRmath/distinfo
new file mode 100644
index 000000000000..4248960125f5
--- /dev/null
+++ b/math/libRmath/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476901394
+SHA256 (R-3.3.1.tar.gz) = 3dc59ae5831f5380f83c169bac2103ad052efe0ecec4ffa74bde4d85a0fda9e2
+SIZE (R-3.3.1.tar.gz) = 29848329