aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2023-05-02 13:40:24 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2023-05-02 14:25:21 +0000
commitb94d1e58ddfa03e1162339e81a8465899249d0c5 (patch)
tree96fd9bedb0bd683ad376048955d6f74f936ca4d6 /math
parentbe2c810a32b7630fe91b61e25755707e7683938f (diff)
downloadports-b94d1e58ddfa03e1162339e81a8465899249d0c5.tar.gz
ports-b94d1e58ddfa03e1162339e81a8465899249d0c5.zip
math/readstat: fix build with clang15
.. continuing story of missing prototypes.
Diffstat (limited to 'math')
-rw-r--r--math/readstat/Makefile2
-rw-r--r--math/readstat/files/patch-src_readstat__writer.c11
-rw-r--r--math/readstat/files/patch-src_sas_readstat__sas.c11
-rw-r--r--math/readstat/files/patch-src_sas_readstat__xport__read.c11
4 files changed, 34 insertions, 1 deletions
diff --git a/math/readstat/Makefile b/math/readstat/Makefile
index ed5a13ebbe3d..6d2174c3f1b6 100644
--- a/math/readstat/Makefile
+++ b/math/readstat/Makefile
@@ -1,6 +1,6 @@
PORTNAME= readstat
DISTVERSION= 1.1.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math kde
MASTER_SITES= https://github.com/WizardMac/ReadStat/releases/download/v${DISTVERSION}/
diff --git a/math/readstat/files/patch-src_readstat__writer.c b/math/readstat/files/patch-src_readstat__writer.c
new file mode 100644
index 000000000000..cc5db2096209
--- /dev/null
+++ b/math/readstat/files/patch-src_readstat__writer.c
@@ -0,0 +1,11 @@
+--- src/readstat_writer.c.orig 2023-05-02 13:36:19 UTC
++++ src/readstat_writer.c
+@@ -35,7 +35,7 @@ readstat_string_ref_t *readstat_string_ref_init(const
+ return ref;
+ }
+
+-readstat_writer_t *readstat_writer_init() {
++readstat_writer_t *readstat_writer_init(void) {
+ readstat_writer_t *writer = calloc(1, sizeof(readstat_writer_t));
+
+ writer->variables = calloc(VARIABLES_INITIAL_CAPACITY, sizeof(readstat_variable_t *));
diff --git a/math/readstat/files/patch-src_sas_readstat__sas.c b/math/readstat/files/patch-src_sas_readstat__sas.c
new file mode 100644
index 000000000000..b25b7075d0a0
--- /dev/null
+++ b/math/readstat/files/patch-src_sas_readstat__sas.c
@@ -0,0 +1,11 @@
+--- src/sas/readstat_sas.c.orig 2023-05-02 13:35:12 UTC
++++ src/sas/readstat_sas.c
+@@ -120,7 +120,7 @@ static readstat_charset_entry_t _charset_table[] = {
+ { .code = 248, .name = "SHIFT_JISX0213" },
+ };
+
+-static time_t sas_epoch() {
++static time_t sas_epoch(void) {
+ return - 3653 * 86400; // seconds between 01-01-1960 and 01-01-1970
+ }
+
diff --git a/math/readstat/files/patch-src_sas_readstat__xport__read.c b/math/readstat/files/patch-src_sas_readstat__xport__read.c
new file mode 100644
index 000000000000..0a27d30ebcca
--- /dev/null
+++ b/math/readstat/files/patch-src_sas_readstat__xport__read.c
@@ -0,0 +1,11 @@
+--- src/sas/readstat_xport_read.c.orig 2023-05-02 13:35:52 UTC
++++ src/sas/readstat_xport_read.c
+@@ -45,7 +45,7 @@ static readstat_error_t xport_update_progress(xport_ct
+ return io->update(ctx->file_size, ctx->handle.progress, ctx->user_ctx, io->io_ctx);
+ }
+
+-static xport_ctx_t *xport_ctx_init() {
++static xport_ctx_t *xport_ctx_init(void) {
+ xport_ctx_t *ctx = calloc(1, sizeof(xport_ctx_t));
+ return ctx;
+ }