aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-03 05:30:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-03 06:10:45 +0000
commitc36ae8bd1f78d93bb9e6813256386de67f1a37bf (patch)
tree4b939ab6a3fa6646855bd1810961589141d6e8fb /math
parent3397fa37713793f0795833aef4b91c639763c5c4 (diff)
downloadports-c36ae8bd1f78d93bb9e6813256386de67f1a37bf.tar.gz
ports-c36ae8bd1f78d93bb9e6813256386de67f1a37bf.zip
math/py-yt: Update 3.6.1 -> 4.0.1
Reported by: portscout
Diffstat (limited to 'math')
-rw-r--r--math/py-yt/Makefile16
-rw-r--r--math/py-yt/distinfo6
-rw-r--r--math/py-yt/files/patch-yt_extern_tqdm___utils.py11
-rw-r--r--math/py-yt/files/patch-yt_utilities_lib_platform__dep.h11
-rw-r--r--math/py-yt/files/patch-yt_utilities_lib_platform__dep__math.hpp16
5 files changed, 38 insertions, 22 deletions
diff --git a/math/py-yt/Makefile b/math/py-yt/Makefile
index c03573b61aa9..3c4b0afafbd9 100644
--- a/math/py-yt/Makefile
+++ b/math/py-yt/Makefile
@@ -1,7 +1,7 @@
# Created by: Yuri Victorovich <yuri@rawbw.com>
PORTNAME= yt
-DISTVERSION= 3.6.1
+DISTVERSION= 4.0.1
CATEGORIES= math astro python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,11 +12,19 @@ COMMENT= Analysis and visualization toolkit for volumetric data
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING.txt
+# dependencies are in setup.cfg
BUILD_DEPENDS= ${PYNUMPY}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sympy>=1.0:math/py-sympy@${PY_FLAVOR} \
+RUN_DEPENDS= \
${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.5.3:math/py-matplotlib@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}ipython5>=1.0:devel/ipython5@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}ipython5>=1.0:devel/ipython5@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=2.0.2:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}more-itertools>=8.4:devel/py-more-itertools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=20.9:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sympy>=1.2:math/py-sympy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toml>=0.10.2:textproc/py-toml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=3.4.0:misc/py-tqdm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}unyt>=2.8.0:math/py-unyt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=4.2b1:devel/py-yaml@${PY_FLAVOR}
USES= dos2unix localbase python:3.7+
USE_PYTHON= distutils cython autoplist concurrent
diff --git a/math/py-yt/distinfo b/math/py-yt/distinfo
index 39612d87f051..9f1d0ff22c97 100644
--- a/math/py-yt/distinfo
+++ b/math/py-yt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1605290212
-SHA256 (yt-3.6.1.tar.gz) = be454f9d05dcbe0623328b4df43a1bfd1f0925e516be97399710452931a19bb0
-SIZE (yt-3.6.1.tar.gz) = 11810361
+TIMESTAMP = 1627935642
+SHA256 (yt-4.0.1.tar.gz) = 6219cbf971871320a13679a57722c0363e50db5e6d4d64ea9d197461b2a7f70f
+SIZE (yt-4.0.1.tar.gz) = 12588963
diff --git a/math/py-yt/files/patch-yt_extern_tqdm___utils.py b/math/py-yt/files/patch-yt_extern_tqdm___utils.py
deleted file mode 100644
index 42900ea89072..000000000000
--- a/math/py-yt/files/patch-yt_extern_tqdm___utils.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- yt/extern/tqdm/_utils.py.orig 2017-01-01 20:57:19 UTC
-+++ yt/extern/tqdm/_utils.py
-@@ -40,7 +40,7 @@ def _environ_cols_wrapper(): # pragma:
- _environ_cols = _environ_cols_windows
- if _environ_cols is None:
- _environ_cols = _environ_cols_tput
-- if current_os in ['Linux', 'Darwin'] or current_os.startswith('CYGWIN'):
-+ if current_os in ['FreeBSD', 'Linux', 'Darwin'] or current_os.startswith('CYGWIN'):
- _environ_cols = _environ_cols_linux
- return _environ_cols
-
diff --git a/math/py-yt/files/patch-yt_utilities_lib_platform__dep.h b/math/py-yt/files/patch-yt_utilities_lib_platform__dep.h
index 4bf2fcc821d3..286fb4d5ffc7 100644
--- a/math/py-yt/files/patch-yt_utilities_lib_platform__dep.h
+++ b/math/py-yt/files/patch-yt_utilities_lib_platform__dep.h
@@ -1,11 +1,14 @@
---- yt/utilities/lib/platform_dep.h.orig 2017-01-01 20:57:35 UTC
+--- yt/utilities/lib/platform_dep.h.orig 2021-08-02 20:27:17 UTC
+++ yt/utilities/lib/platform_dep.h
-@@ -57,7 +57,7 @@ double erf(double x)
+@@ -59,6 +59,10 @@ double erf(double x)
#else
#include <stdint.h>
-#include "alloca.h"
-+#include <stdlib.h>
++#if !defined(__FreeBSD__)
++# include "alloca.h"
++#else
++# include <stdlib.h>
++#endif
#include <math.h>
#endif
-
diff --git a/math/py-yt/files/patch-yt_utilities_lib_platform__dep__math.hpp b/math/py-yt/files/patch-yt_utilities_lib_platform__dep__math.hpp
new file mode 100644
index 000000000000..ddc45bddb8ec
--- /dev/null
+++ b/math/py-yt/files/patch-yt_utilities_lib_platform__dep__math.hpp
@@ -0,0 +1,16 @@
+--- yt/utilities/lib/platform_dep_math.hpp.orig 2021-08-02 20:38:53 UTC
++++ yt/utilities/lib/platform_dep_math.hpp
+@@ -5,6 +5,7 @@ MSVC does not define isnormal in the std:: namespace,
+ However with GCC-5, there is a clash between the definition of isnormal in <math.h> and using C++14, so we need to import from cmath instead.
+ */
+
++#if !defined(__FreeBSD__) // see https://github.com/yt-project/yt/issues/3459
+ #if _MSC_VER
+ #include <math.h>
+ inline bool __isnormal(double x) {
+@@ -15,4 +16,5 @@ inline bool __isnormal(double x) {
+ inline bool __isnormal(double x) {
+ return std::isnormal(x);
+ }
++#endif
+ #endif