aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-05 22:10:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-05 22:10:16 +0000
commitd1503e798349f648ed4d60fdbc48bda4401e3031 (patch)
treef9c38155976a3a1fe4ea8ea4fc5d965279a9cb26 /math
parent3e0e18d3f46a65a7e24d78c41bddc4744d55a0d0 (diff)
downloadports-d1503e798349f648ed4d60fdbc48bda4401e3031.tar.gz
ports-d1503e798349f648ed4d60fdbc48bda4401e3031.zip
New port: math/cm: Library for ring class fields of imaginary quadratic number fields
Notes
Notes: svn path=/head/; revision=560438
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/cm/Makefile29
-rw-r--r--math/cm/distinfo3
-rw-r--r--math/cm/pkg-descr7
-rw-r--r--math/cm/pkg-plist31
5 files changed, 71 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index dbd81cb7f93b..988928b81dc9 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -192,6 +192,7 @@
SUBDIR += cloog
SUBDIR += clp
SUBDIR += clrng
+ SUBDIR += cm
SUBDIR += cminpack
SUBDIR += cmlib
SUBDIR += cocoalib
diff --git a/math/cm/Makefile b/math/cm/Makefile
new file mode 100644
index 000000000000..d9a319f73303
--- /dev/null
+++ b/math/cm/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= cm
+DISTVERSION= 0.3.1
+CATEGORIES= math
+MASTER_SITES= http://www.multiprecision.org/downloads/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for ring class fields of imaginary quadratic number fields
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpc.so:math/mpc \
+ libmpfr.so:math/mpfr \
+ libmpfrcx.so:math/mpfrcx \
+ libpari.so:math/pari
+
+USES= gmake libtool localbase
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+INFO= cm
+
+.include <bsd.port.mk>
diff --git a/math/cm/distinfo b/math/cm/distinfo
new file mode 100644
index 000000000000..de69efb98cc7
--- /dev/null
+++ b/math/cm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609882958
+SHA256 (cm-0.3.1.tar.gz) = 82d4f4dc194738466888f70c2046bd934680b92aca8fa139927e85c567580663
+SIZE (cm-0.3.1.tar.gz) = 2471723
diff --git a/math/cm/pkg-descr b/math/cm/pkg-descr
new file mode 100644
index 000000000000..5abff8a8e76d
--- /dev/null
+++ b/math/cm/pkg-descr
@@ -0,0 +1,7 @@
+The CM software implements the construction of ring class fields of imaginary
+quadratic number fields and of elliptic curves with complex multiplication via
+floating point approximations. It consists of libraries that can be called from
+within a C program and of executable command line applications. For the
+implemented algorithms.
+
+WWW: http://www.multiprecision.org/cm/home.html
diff --git a/math/cm/pkg-plist b/math/cm/pkg-plist
new file mode 100644
index 000000000000..09ac5eb09318
--- /dev/null
+++ b/math/cm/pkg-plist
@@ -0,0 +1,31 @@
+bin/classpol
+bin/cm
+include/cm_arith.h
+include/cm_class.h
+include/cm_common.h
+include/mpfpx.h
+lib/libcm_class.a
+lib/libcm_class.so
+lib/libcm_class.so.1
+lib/libcm_class.so.1.0.0
+lib/libcm_common.a
+lib/libcm_common.so
+lib/libcm_common.so.1
+lib/libcm_common.so.1.0.0
+lib/libmpfpx.a
+lib/libmpfpx.so
+lib/libmpfpx.so.0
+lib/libmpfpx.so.0.0.0
+%%DATADIR%%/af/af_0047.dat.gz
+%%DATADIR%%/af/af_0059.dat.gz
+%%DATADIR%%/af/af_0071.dat.gz
+%%DATADIR%%/af/af_0131.dat.gz
+%%DATADIR%%/df/df_0035.dat.gz
+%%DATADIR%%/df/df_0039.dat.gz
+%%DATADIR%%/df/df_0145.dat.gz
+%%DATADIR%%/df/df_0146.dat.gz
+%%DATADIR%%/df/df_0194.dat.gz
+%%DATADIR%%/df/df_0327.dat.gz
+%%DATADIR%%/df/df_0386.dat.gz
+%%DATADIR%%/df/df_0482.dat.gz
+%%DATADIR%%/mf/mf_0105.dat.gz