aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-05-24 16:39:21 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-05-25 10:00:04 +0000
commitd1a753db1981f5dc9da0ffa3d8d5996901d7e758 (patch)
treeff43438c925774bd1bab260498d64128ba0ae3fd /math
parent3c093f64b5dd1e2a804bca049749b2bcd7063841 (diff)
downloadports-d1a753db1981f5dc9da0ffa3d8d5996901d7e758.tar.gz
ports-d1a753db1981f5dc9da0ffa3d8d5996901d7e758.zip
suitesparse-ccolamd: new port for the module CCOLAMD of SuiteSparse
Diffstat (limited to 'math')
-rw-r--r--math/suitesparse-ccolamd/Makefile18
-rw-r--r--math/suitesparse-ccolamd/files/patch-CCOLAMD_Demo_Makefile10
-rw-r--r--math/suitesparse-ccolamd/pkg-descr11
-rw-r--r--math/suitesparse-ccolamd/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/math/suitesparse-ccolamd/Makefile b/math/suitesparse-ccolamd/Makefile
new file mode 100644
index 000000000000..252880b3bded
--- /dev/null
+++ b/math/suitesparse-ccolamd/Makefile
@@ -0,0 +1,18 @@
+# Created by: Thierry Thomas (<thierry@pompo.net>)
+
+PORTNAME= CCOLAMD
+PORTVERSION= 2.9.6
+CATEGORIES= math
+
+COMMENT= Constrained column approximate minimum degree ordering
+
+LICENSE= BSD3CLAUSE
+
+USES= localbase:ldflags
+OMP_NEEDED= yes
+
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+USE_LDCONFIG= yes
+
+.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
+.include <bsd.port.post.mk>
diff --git a/math/suitesparse-ccolamd/files/patch-CCOLAMD_Demo_Makefile b/math/suitesparse-ccolamd/files/patch-CCOLAMD_Demo_Makefile
new file mode 100644
index 000000000000..98112a33e069
--- /dev/null
+++ b/math/suitesparse-ccolamd/files/patch-CCOLAMD_Demo_Makefile
@@ -0,0 +1,10 @@
+--- CCOLAMD/Demo/Makefile.orig 2021-05-17 01:04:52 UTC
++++ CCOLAMD/Demo/Makefile
+@@ -15,7 +15,6 @@ LIB2 = $(LDFLAGS) -L../../lib -lccolamd -lsuitesparsec
+ all: library ccolamd_example ccolamd_l_example
+
+ library:
+- ( cd ../../SuiteSparse_config ; $(MAKE) )
+ ( cd ../Lib ; $(MAKE) )
+
+ #------------------------------------------------------------------------------
diff --git a/math/suitesparse-ccolamd/pkg-descr b/math/suitesparse-ccolamd/pkg-descr
new file mode 100644
index 000000000000..f6acb20ea1d7
--- /dev/null
+++ b/math/suitesparse-ccolamd/pkg-descr
@@ -0,0 +1,11 @@
+This port installs the module CCOLAMD of SuiteSparse.
+
+The CCOLAMD column approximate minimum degree ordering algorithm computes a
+permutation vector P such that the LU factorization of A (:,P) tends to be
+sparser than that of A. The Cholesky factorization of (A (:,P))'*(A (:,P)) will
+also tend to be sparser than that of A'*A. CSYMAMD is a symmetric minimum
+degree ordering method based on CCOLAMD, also available as a MATLAB-callable
+function. It constructs a matrix M such that M'*M has the same pattern as A, and
+then uses CCOLAMD to compute a column ordering of M.
+
+WWW: http://faculty.cse.tamu.edu/davis/suitesparse.html
diff --git a/math/suitesparse-ccolamd/pkg-plist b/math/suitesparse-ccolamd/pkg-plist
new file mode 100644
index 000000000000..7330d08927fc
--- /dev/null
+++ b/math/suitesparse-ccolamd/pkg-plist
@@ -0,0 +1,5 @@
+include/suitesparse/ccolamd.h
+lib/libccolamd.so
+lib/libccolamd.so.2
+lib/libccolamd.so.2.9.6
+%%PORTDOCS%%%%DOCSDIR%%/CCOLAMD_README.txt