aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2013-09-18 13:28:06 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2013-09-18 13:28:06 +0000
commite03359c0aac5d86660e0818719b7abaea7c6415b (patch)
treef896fc873ac4b47289838019aa8b15812b602b4f /math
parentf91c2df1fb086ef2f27a4ec7189f29865523df80 (diff)
downloadports-e03359c0aac5d86660e0818719b7abaea7c6415b.tar.gz
ports-e03359c0aac5d86660e0818719b7abaea7c6415b.zip
Add minisat port - a lightweight SAT solver.
Notes
Notes: svn path=/head/; revision=327544
Diffstat (limited to 'math')
-rw-r--r--math/minisat/Makefile16
-rw-r--r--math/minisat/distinfo2
-rw-r--r--math/minisat/pkg-descr20
-rw-r--r--math/minisat/pkg-plist30
4 files changed, 68 insertions, 0 deletions
diff --git a/math/minisat/Makefile b/math/minisat/Makefile
new file mode 100644
index 000000000000..b4a66132ea74
--- /dev/null
+++ b/math/minisat/Makefile
@@ -0,0 +1,16 @@
+# Created by: Vsevolod Stakhov <vsevolod@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= minisat
+PORTVERSION= 2.2.1
+CATEGORIES= math devel
+MASTER_SITES= http://highsecure.ru/distfiles/
+
+MAINTAINER= vsevolod@FreeBSD.org
+COMMENT= A minimalistic, open-source SAT solver
+
+USES= gmake
+USE_LDCONFIG= yes
+MAKE_ENV= prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/math/minisat/distinfo b/math/minisat/distinfo
new file mode 100644
index 000000000000..96ab870034b4
--- /dev/null
+++ b/math/minisat/distinfo
@@ -0,0 +1,2 @@
+SHA256 (minisat-2.2.1.tar.gz) = d39de26ad3c56a0fbc30a92c23004a5fb2802e8aebd34febc107dc43781e9a19
+SIZE (minisat-2.2.1.tar.gz) = 49892
diff --git a/math/minisat/pkg-descr b/math/minisat/pkg-descr
new file mode 100644
index 000000000000..1195f6c9cd87
--- /dev/null
+++ b/math/minisat/pkg-descr
@@ -0,0 +1,20 @@
+MiniSat is a minimalistic, open-source SAT solver, developed to help
+researchers and developers alike to get started on SAT. It is released under
+the MIT licence, and is currently used in a number of projects.
+
+Some key features of MiniSat:
+
+- Easy to modify. MiniSat is small and well-documented, and possibly also
+well-designed, making it an ideal starting point for adapting SAT based
+techniques to domain specific problems.
+
+- Highly efficient. Winning all the industrial categories of the SAT 2005
+competition, MiniSat is a good starting point both for future research in SAT,
+and for applications using SAT.
+
+- Designed for integration. MiniSat supports incremental SAT and has
+mechanisms for adding non-clausal constraints. By virtue of being easy to
+modify, it is a good choice for integrating as a backend to another tool, such
+as a model checker or a more generic constraint solver.
+
+WWW: http://minisat.se/
diff --git a/math/minisat/pkg-plist b/math/minisat/pkg-plist
new file mode 100644
index 000000000000..5bf7e3727f3a
--- /dev/null
+++ b/math/minisat/pkg-plist
@@ -0,0 +1,30 @@
+@comment $FreeBSD$
+
+bin/minisat
+include/minisat/mtl/XAlloc.h
+include/minisat/mtl/Heap.h
+include/minisat/mtl/IntTypes.h
+include/minisat/mtl/IntMap.h
+include/minisat/mtl/Sort.h
+include/minisat/mtl/Rnd.h
+include/minisat/mtl/Alg.h
+include/minisat/mtl/Vec.h
+include/minisat/mtl/Alloc.h
+include/minisat/mtl/Map.h
+include/minisat/mtl/Queue.h
+include/minisat/utils/Options.h
+include/minisat/utils/ParseUtils.h
+include/minisat/utils/System.h
+include/minisat/core/Solver.h
+include/minisat/core/Dimacs.h
+include/minisat/core/SolverTypes.h
+include/minisat/simp/SimpSolver.h
+lib/libminisat.so.2.1.0
+lib/libminisat.so.2
+lib/libminisat.so
+lib/libminisat.a
+@dirrmtry include/minisat/utils
+@dirrmtry include/minisat/simp
+@dirrmtry include/minisat/mtl
+@dirrmtry include/minisat/core
+@dirrmtry include/minisat