aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-20 16:09:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-20 19:49:17 +0000
commite905d57f398296e6c3a96037e9bb4d2bc859626d (patch)
tree3f8767cfbbab48dad172d38084fbfc13641794bb /math
parentc480370a3006c020c3d7a7cb79108ac0284f8c15 (diff)
downloadports-e905d57f398296e6c3a96037e9bb4d2bc859626d.tar.gz
ports-e905d57f398296e6c3a96037e9bb4d2bc859626d.zip
math/py-mapbox-earcut: New port: Bindings for Pango for use with Manim
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-mapbox-earcut/Makefile28
-rw-r--r--math/py-mapbox-earcut/distinfo3
-rw-r--r--math/py-mapbox-earcut/pkg-descr2
4 files changed, 34 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 902b5e115691..236381a7fdf9 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -937,6 +937,7 @@
SUBDIR += py-linearmodels
SUBDIR += py-lmfit
SUBDIR += py-luminol
+ SUBDIR += py-mapbox-earcut
SUBDIR += py-mathics
SUBDIR += py-mathics-scanner
SUBDIR += py-matplotlib
diff --git a/math/py-mapbox-earcut/Makefile b/math/py-mapbox-earcut/Makefile
new file mode 100644
index 000000000000..dc0bd92d7388
--- /dev/null
+++ b/math/py-mapbox-earcut/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= mapbox-earcut
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.1
+CATEGORIES= math
+#MASTER_SITES= PYPI # no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Bindings for Pango for use with Manim
+WWW= https://manimpango.manim.community/en/latest/
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR}
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= skogler
+GH_PROJECT= mapbox_earcut_python
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+TEST_WRKSRC= ${WRKSRC}/tests
+
+.include <bsd.port.mk>
diff --git a/math/py-mapbox-earcut/distinfo b/math/py-mapbox-earcut/distinfo
new file mode 100644
index 000000000000..206f5a0c6eea
--- /dev/null
+++ b/math/py-mapbox-earcut/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674241658
+SHA256 (skogler-mapbox_earcut_python-v1.0.1_GH0.tar.gz) = 88b439b7623c8dc81eec33281254b0b508bb2a0e0e8b82cb68f4c7c0c4208b0e
+SIZE (skogler-mapbox_earcut_python-v1.0.1_GH0.tar.gz) = 11794
diff --git a/math/py-mapbox-earcut/pkg-descr b/math/py-mapbox-earcut/pkg-descr
new file mode 100644
index 000000000000..1cfd12e8596d
--- /dev/null
+++ b/math/py-mapbox-earcut/pkg-descr
@@ -0,0 +1,2 @@
+mapbox-earcut is python bindings for the C++ implementation of the Mapbox Earcut
+library, which provides very fast and quite robust triangulation of 2D polygons.