aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-01 04:20:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-01 04:31:33 +0000
commite91e4db558d523bdff60711d5084d9c5c6bf32fd (patch)
treecfa68acf8deb2735a8ddee9f6c015394e44703a8 /math
parent6960eba7ccf2cd7b3dd310f9182b9c4f96867879 (diff)
downloadports-e91e4db558d523bdff60711d5084d9c5c6bf32fd.tar.gz
ports-e91e4db558d523bdff60711d5084d9c5c6bf32fd.zip
math/SCIP: Update 7.0.2 -> 7.0.3
Also add the IPOPT option. IPOPT options submitted by: Philipp Ost <bsd@philippost.de>
Diffstat (limited to 'math')
-rw-r--r--math/SCIP/Makefile16
-rw-r--r--math/SCIP/distinfo6
-rw-r--r--math/SCIP/pkg-plist2
3 files changed, 17 insertions, 7 deletions
diff --git a/math/SCIP/Makefile b/math/SCIP/Makefile
index 991cb2ead0ad..2b876a79b840 100644
--- a/math/SCIP/Makefile
+++ b/math/SCIP/Makefile
@@ -1,8 +1,7 @@
# Created by: Yuri Victorovich <yuri@FreeBSD.org>
PORTNAME= SCIP
-DISTVERSION= 7.0.2
-PORTREVISION= 1
+DISTVERSION= 7.0.3
CATEGORIES= math science
MASTER_SITES= https://www.scipopt.org/download/release/
DISTNAME= ${PORTNAME:tl}-${DISTVERSION}
@@ -23,8 +22,19 @@ USES= compiler:c11 cmake readline tar:tgz
EXTRACT_CMD= gtar
USE_LDCONFIG= yes
+CMAKE_OFF= PAPILO ZIMPL
+
CXXFLAGS+= -I${LOCALBASE}/include/soplex
-CONFLICTS_BUILD= Ipopt
+OPTIONS_DEFINE= IPOPT
+OPTIONS_DEFAULT= IPOPT
+
+IPOPT_DESC= Non-linear optimization support via Ipopt
+IPOPT_USES= fortran pkgconfig
+IPOPT_LIB_DEPENDS= libblas.so:math/blas \
+ libipopt.so:math/ipopt \
+ liblapack.so:math/lapack
+
+IPOPT_CMAKE_BOOL= IPOPT
.include <bsd.port.mk>
diff --git a/math/SCIP/distinfo b/math/SCIP/distinfo
index 773a70691216..3de1f2ab70dd 100644
--- a/math/SCIP/distinfo
+++ b/math/SCIP/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608539374
-SHA256 (scip-7.0.2.tgz) = 6eb44f6f2afa1cbbb9714251eb31889ab2afcbe68267773c11e689dc4c5e4427
-SIZE (scip-7.0.2.tgz) = 10271583
+TIMESTAMP = 1627789406
+SHA256 (scip-7.0.3.tgz) = 9cb008271497b8f7587f404f968d1ca9d0126d6192b3946f47bb73d19ac8ed0a
+SIZE (scip-7.0.3.tgz) = 10240528
diff --git a/math/SCIP/pkg-plist b/math/SCIP/pkg-plist
index 9e8056e408f7..3ec11b039dc2 100644
--- a/math/SCIP/pkg-plist
+++ b/math/SCIP/pkg-plist
@@ -519,4 +519,4 @@ lib/cmake/scip/scip-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/scip/scip-targets.cmake
lib/libscip.so
lib/libscip.so.7.0
-lib/libscip.so.7.0.2.0
+lib/libscip.so.7.0.3.0