aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-06-04 08:26:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-06-04 08:26:46 +0000
commitee00973678b95324d58dc0572802e7169c1345de (patch)
treed424397cd07ed9351a86f92422a2a9ed96cb0d5f /math
parent0ed7cc3196146ce2c8fc7b7b9e59760135cd88ec (diff)
downloadports-ee00973678b95324d58dc0572802e7169c1345de.tar.gz
ports-ee00973678b95324d58dc0572802e7169c1345de.zip
- Update to 3.52.23
PR: 179216 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=319835
Diffstat (limited to 'math')
-rw-r--r--math/xlispstat/Makefile27
-rw-r--r--math/xlispstat/distinfo4
-rw-r--r--math/xlispstat/files/patch-ac11
-rw-r--r--math/xlispstat/files/patch-aj41
-rw-r--r--math/xlispstat/pkg-descr10
5 files changed, 31 insertions, 62 deletions
diff --git a/math/xlispstat/Makefile b/math/xlispstat/Makefile
index 48845653b0f9..e1d583ecfc43 100644
--- a/math/xlispstat/Makefile
+++ b/math/xlispstat/Makefile
@@ -1,29 +1,22 @@
-# New ports collection makefile for: xlisp-stat
-# Date created: Tue Aug 15 17:57:48 CDT 1995
-# Whom: Eric L. Hernes <erich@rrnet.com>
-#
+# Created by: Eric L. Hernes <erich@rrnet.com>
# $FreeBSD$
-#
PORTNAME= xlispstat
-PORTVERSION= 3.52.20
-PORTREVISION= 2
+PORTVERSION= 3.52.23
CATEGORIES= math lang lisp
-MASTER_SITES= ftp://ftp.stat.umn.edu/pub/xlispstat/current/ \
- http://lib.stat.cmu.edu/xlispstat/Src/current/ \
- ftp://ftp.stat.unipg.it/pub/stat/xlispstat/current/ \
- ftp://srsuna.shlrc.mq.edu.au/pub/xlispstat/current/ \
- ftp://statlab.uni-heidelberg.de/pub/mirrors/umn/xlispstat/current/
+MASTER_SITES= http://homepage.stat.uiowa.edu/~luke/xls/xlispstat/3-52/%SUBDIR%/
+MASTER_SITE_SUBDIR= . old
DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A statistics/X11 based lisp interpreter
+COMMENT= Statistics/X11 based lisp interpreter
+LICENSE= BSD
+
+USE_XORG= x11
GNU_CONFIGURE= yes
+CONFIGURE_ENV= UCFLAGS="${CFLAGS}"
ALL_TARGET= ${PORTNAME}
-USE_XORG= x11
-
-post-patch:
- @${REINPLACE_CMD} '/^static double fmax/d' ${WRKSRC}/lowess.c
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.mk>
diff --git a/math/xlispstat/distinfo b/math/xlispstat/distinfo
index e9a811e6bd26..0b11a3166349 100644
--- a/math/xlispstat/distinfo
+++ b/math/xlispstat/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xlispstat-3-52-20.tar.gz) = 977d3e984cbe881244b0f15d1b8a78f4660ac2b7cbc53cc857606d75ecd0b71a
-SIZE (xlispstat-3-52-20.tar.gz) = 1527951
+SHA256 (xlispstat-3-52-23.tar.gz) = 9bf165eb3f92384373dab34f9a56ec8455ff9e2bf7dff6485e807767e6ce6cf4
+SIZE (xlispstat-3-52-23.tar.gz) = 1570981
diff --git a/math/xlispstat/files/patch-ac b/math/xlispstat/files/patch-ac
index 5d2b5e32e9c9..e69de29bb2d1 100644
--- a/math/xlispstat/files/patch-ac
+++ b/math/xlispstat/files/patch-ac
@@ -1,11 +0,0 @@
---- configure.orig Fri Mar 24 01:03:59 2000
-+++ configure Wed May 3 09:00:00 2000
-@@ -580,7 +580,7 @@
- # Set some default values
- #
- LIBS=-lm
--UCFLAGS=-O
-+UCFLAGS=$CFLAGS
- ULDFLAGS=
- X11INCDIR_FLAG=
- X11LIBDIR_FLAG=
diff --git a/math/xlispstat/files/patch-aj b/math/xlispstat/files/patch-aj
index 125891637795..37050a6d69e6 100644
--- a/math/xlispstat/files/patch-aj
+++ b/math/xlispstat/files/patch-aj
@@ -1,16 +1,13 @@
--- Makefile.in.orig Wed Feb 2 08:22:53 2000
+++ Makefile.in Wed May 3 09:00:00 2000
-@@ -6,7 +6,8 @@
- ##############################################################################
+@@ -7,13 +7,15 @@
##############################################################################
#
--# XLSLIB -- directory for xlisp executable, startup, example, and help files
-+# XLSLIB -- directory for xlisp example and help files
+ # XLSLIB -- directory for xlisp executable, startup, example, and help files
+# XLSLIBEXEC -- directory for xlisp executable and startup
# BINDIR -- directory for xlispstat shell script
#
- # For the remaining parameters, if your machine has a subdirectory in the
-@@ -34,7 +35,8 @@
+
prefix = @prefix@
exec_prefix = @exec_prefix@
@@ -19,31 +16,23 @@
+XLSLIBEXEC=${prefix}/libexec/xlispstat
BINDIR=${exec_prefix}/bin
- GRAPHSYS = @GRAPHSYS@
-@@ -67,11 +69,11 @@
- .lsp.fsl:
- echo "(compile-file \"$<\") (exit)" | ./xlisp
-
--CFLAGS = -D${GRAPHSYS} ${UCFLAGS} ${X11INCDIR_FLAG}
-+CFLAGS = -D${GRAPHSYS} ${UCFLAGS} ${X11INCDIR_FLAG} -Dunix
-
+ SHELL = /bin/sh
+@@ -33,7 +35,7 @@
LIBS = ${EXTRALIBS} -lm
--LDFLAGS = ${ULDFLAGS}
-+LDFLAGS+= ${ULDFLAGS}
-
- OSOBJS = xsdynload.o xssystem.o unixprim.o
-
-@@ -118,7 +120,7 @@
- compiler/assemble.fsl compiler/cmpfront.fsl
-
xlispstat: setup.shell xlisp.wks
- ./setup.shell xlispstat ${XLSLIB}
+ ./setup.shell xlispstat ${XLSLIB} ${XLSLIBEXEC}
chmod a+x xlispstat
- xlisp.wks: xlisp ${CMPFSLFILES} ${FSLFILES} ${AUTOFSLFILES}
-@@ -141,20 +143,21 @@
+ xlisp.wks: xlisp ${LSPDIR}/xlisp.wks
+@@ -46,24 +48,25 @@
+ rm -f xlisp
+ cp ${CDIR}/xlisp ./xlisp
+ ${CDIR}/xlisp:
+- (cd ${CDIR}; make xlisp)
++ (cd ${CDIR}; ${MAKE} xlisp)
+
install: installexecs installlsp
installexecs: xlispstat xlisp installdirs
@@ -52,19 +41,17 @@
+ ${BSD_INSTALL_SCRIPT} xlispstat ${BINDIR}/xlispstat
+ ${BSD_INSTALL_PROGRAM} xlisp ${XLSLIBEXEC}
- installlsp: xlisp.wks xlisp.hlp ${AUTOFSLFILES} ${CMPFSLFILES} installdirs
+ installlsp: xlisp.wks xlisp.hlp installdirs
- -cp xlisp.wks ${XLSLIB}
- -cp xlisp.hlp ${XLSLIB}
- -cp Autoload/_autoidx.lsp Autoload/*.fsl ${XLSLIB}/Autoload
- -cp Data/*.lsp ${XLSLIB}/Data
- -cp Examples/*.lsp ${XLSLIB}/Examples
--# -cp ${CMPFSLFILES} ${XLSLIB}/compiler
+ ${BSD_INSTALL_SCRIPT} xlisp.wks ${XLSLIBEXEC}
+ ${BSD_INSTALL_DATA} xlisp.hlp ${XLSLIB}
+ ${BSD_INSTALL_DATA} Autoload/_autoidx.lsp Autoload/*.fsl ${XLSLIB}/Autoload
+ ${BSD_INSTALL_DATA} Data/*.lsp ${XLSLIB}/Data
+ ${BSD_INSTALL_DATA} Examples/*.lsp ${XLSLIB}/Examples
-+# ${BSD_INSTALL_DATA} ${CMPFSLFILES} ${XLSLIB}/compiler
installdirs:
-mkdir -p ${BINDIR}
diff --git a/math/xlispstat/pkg-descr b/math/xlispstat/pkg-descr
index 77abbdfdb91a..16ae95402485 100644
--- a/math/xlispstat/pkg-descr
+++ b/math/xlispstat/pkg-descr
@@ -1,7 +1,7 @@
XLISP-STAT is a statistical environment based on a dialect of the Lisp
-language called XLISP. To facilitate statistical computations, standard Lisp
-functions for addition, logarithms, etc., have been modified to operate on
-lists and arrays of numbers, and a number of basic statistical functions have
-been added.
+language called XLISP. To facilitate statistical computations, standard
+Lisp functions for addition, logarithms, etc., have been modified to
+operate on lists and arrays of numbers, and a number of basic
+statistical functions have been added.
-WWW: http://www.stat.uiowa.edu/~luke/xls/xlsinfo/xlsinfo.html
+WWW: http://homepage.stat.uiowa.edu/~luke/xls/xlsinfo/xlsinfo.html