aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-03-21 09:35:38 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-03-21 09:35:38 +0000
commitfb351125c5a2103bd6beffa23c4e38eb294182de (patch)
tree382c9fa0eb2546dba53db61d8934bf425ac72f38 /math
parentc81eeb529067a73560e4d7e201560527b8032c86 (diff)
downloadports-fb351125c5a2103bd6beffa23c4e38eb294182de.tar.gz
ports-fb351125c5a2103bd6beffa23c4e38eb294182de.zip
- Update to 1.23
- Remove files/patch-doc-Makefile - Unbreak on amd64
Notes
Notes: svn path=/head/; revision=187853
Diffstat (limited to 'math')
-rw-r--r--math/asymptote/Makefile31
-rw-r--r--math/asymptote/distinfo6
-rw-r--r--math/asymptote/files/patch-doc-Makefile14
-rw-r--r--math/asymptote/pkg-plist14
4 files changed, 35 insertions, 30 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index cd74d0aaae7b..56b0934be1a7 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asymptote
-PORTVERSION= 1.20
+PORTVERSION= 1.23
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,8 +15,7 @@ MAINTAINER= nivit@FreeBSD.org
COMMENT= A powerful script-based vector graphics language
LIB_DEPENDS= fftw3.4:${PORTSDIR}/math/fftw3
-BUILD_DEPENDS= ${NOEXISTENT}:${PORTSDIR}/devel/boehm-gc:fetch \
- convert:${PORTSDIR}/graphics/ImageMagick \
+BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
latex:${PORTSDIR}/print/teTeX \
makeinfo:${PORTSDIR}/textproc/texi2html \
${MKTEXLSR}:${PORTSDIR}/print/teTeX \
@@ -26,7 +25,7 @@ RUN_DEPENDS= ggv:${PORTSDIR}/print/ggv \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
# devel/boehm-gc
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
USE_GCC= 3.3+
USE_GHOSTSCRIPT=yes
@@ -34,8 +33,7 @@ USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-gc=${GCVERSION} \
- --with-latex=${LOCALBASE}/share/texmf-local/tex/latex
+CONFIGURE_ARGS= --with-latex=${LOCALBASE}/share/texmf-local/tex/latex --enable-gc=system
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include $${CPPFLAGS}" LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}" CFLAGS="-I${LOCALBASE}/include $${CFLAGS}" LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS}"
MAKE_ENV+= ${CONFIGURE_ENV}
@@ -55,23 +53,30 @@ MAN1= asy.1 xasy.1x
INFO= ${PORTNAME} asy-faq
ALL_TARGET+= doc
+CONFIGURE_ARGS+= --with-docdir=${DOCSDIR}
INSTALL_TARGET+= install-doc
.endif
-LN_OPTS= -sf
-
-GCVERSION= 6.8
-GC_DISTNAME= gc${GCVERSION}.tar.gz
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= depends on net/avahi
.endif
+.if ( ${ARCH} == "amd64" )
+BUILD_DEPENDS+= boehm-gc=6.8:${PORTSDIR}/devel/boehm-gc
+CONFIGURE_ARGS+= --enable-gc=system
+.else
+BUILD_DEPENDS+= ${NOEXISTENT}:${PORTSDIR}/devel/boehm-gc:fetch
+CONFIGURE_ARGS+= --enable-gc=${GCVERSION}
+GCVERSION= 6.8
+GC_DISTNAME= gc${GCVERSION}.tar.gz
+LN_OPTS= -sf
+
pre-configure:
- @cd ${WRKSRC}; \
- ${LN} ${LN_OPTS} ${DISTDIR}/${GC_DISTNAME} ${GC_DISTNAME}
+ cd ${WRKSRC}; \
+ ${LN} ${LN_OPTS} ${DISTDIR}/${GC_DISTNAME} ${GC_DISTNAME};
+.endif
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/math/asymptote/distinfo b/math/asymptote/distinfo
index 7755618516b2..56860f597a62 100644
--- a/math/asymptote/distinfo
+++ b/math/asymptote/distinfo
@@ -1,3 +1,3 @@
-MD5 (asymptote-1.20.tar.gz) = 7e705a3418395d26318509aaa8191076
-SHA256 (asymptote-1.20.tar.gz) = 860e7b28c3bace3786e7dace9b458437eddb78382fc13e943bf6ff42c06ca2ca
-SIZE (asymptote-1.20.tar.gz) = 937426
+MD5 (asymptote-1.23.tar.gz) = 64d1c0ec4458dfe93f31aedb6180505a
+SHA256 (asymptote-1.23.tar.gz) = 672e80af25ec599bfaba3a5840598de0cbd2a7b7e5b65f9ca76ae6f9df26de43
+SIZE (asymptote-1.23.tar.gz) = 896895
diff --git a/math/asymptote/files/patch-doc-Makefile b/math/asymptote/files/patch-doc-Makefile
deleted file mode 100644
index 59b85caf373b..000000000000
--- a/math/asymptote/files/patch-doc-Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- doc/Makefile Wed Dec 13 03:06:11 2006
-+++ doc/Makefile.port Wed Dec 13 13:44:57 2006
-@@ -72,9 +72,10 @@
- rm -rf asymptote
-
- install: man faq
-+ mkdir $(prefix)/share/doc/asymptote
- cd FAQ; $(MAKE) install
- ${INSTALL} -d -m 755 $(docdir) $(mandir)/man1
-- ${INSTALL} -p -m 644 $(DOCFILES) $(docdir)
-+ ${INSTALL} -p -m 644 $(DOCFILES) $(prefix)/share/doc/asymptote
- ${INSTALL} -p -m 644 $(MANFILES) $(mandir)/man1
-
- install-all: doc install
diff --git a/math/asymptote/pkg-plist b/math/asymptote/pkg-plist
index 4dcc15fd41dc..8b97e23705ef 100644
--- a/math/asymptote/pkg-plist
+++ b/math/asymptote/pkg-plist
@@ -10,6 +10,7 @@ bin/xasy
%%DATADIR%%/asy.vim
%%DATADIR%%/asymptote.py
%%DATADIR%%/babel.asy
+%%DATADIR%%/binarytree.asy
%%DATADIR%%/contour.asy
%%DATADIR%%/drawtree.asy
%%DATADIR%%/embed.asy
@@ -22,8 +23,11 @@ bin/xasy
%%DATADIR%%/graph.asy
%%DATADIR%%/graph3.asy
%%DATADIR%%/graph_settings.asy
+%%DATADIR%%/grid3.asy
+%%DATADIR%%/labelpath.asy
%%DATADIR%%/latin1.asy
%%DATADIR%%/light.asy
+%%DATADIR%%/markers.asy
%%DATADIR%%/math.asy
%%DATADIR%%/metapost.asy
%%DATADIR%%/palette.asy
@@ -72,6 +76,7 @@ bin/xasy
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section8.html
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section9.html
%%PORTDOCS%%%%DOCSDIR%%/asymptote.pdf
+%%PORTDOCS%%%%DOCSDIR%%/intro.pdf
%%EXAMPLESDIR%%/BezierSurface.asy
%%EXAMPLESDIR%%/Bode.asy
%%EXAMPLESDIR%%/CAD1.asy
@@ -95,7 +100,9 @@ bin/xasy
%%EXAMPLESDIR%%/axis3.asy
%%EXAMPLESDIR%%/bezier.asy
%%EXAMPLESDIR%%/bezier2.asy
+%%EXAMPLESDIR%%/beziercurve.asy
%%EXAMPLESDIR%%/bigsquare.asy
+%%EXAMPLESDIR%%/binarytreetest.asy
%%EXAMPLESDIR%%/brokenaxis.asy
%%EXAMPLESDIR%%/buildcycle.asy
%%EXAMPLESDIR%%/cardiod.asy
@@ -112,6 +119,7 @@ bin/xasy
%%EXAMPLESDIR%%/cos2theta.asy
%%EXAMPLESDIR%%/cosaddition.asy
%%EXAMPLESDIR%%/cube.asy
+%%EXAMPLESDIR%%/curvedlabel.asy
%%EXAMPLESDIR%%/cylinder.asy
%%EXAMPLESDIR%%/cylinderskeleton.asy
%%EXAMPLESDIR%%/datagraph.asy
@@ -131,6 +139,8 @@ bin/xasy
%%EXAMPLESDIR%%/exp.asy
%%EXAMPLESDIR%%/fano.asy
%%EXAMPLESDIR%%/fermi.asy
+%%EXAMPLESDIR%%/filegraph.asy
+%%EXAMPLESDIR%%/filegraph.dat
%%EXAMPLESDIR%%/fillcontour.asy
%%EXAMPLESDIR%%/fjortoft.asy
%%EXAMPLESDIR%%/flow.asy
@@ -139,6 +149,7 @@ bin/xasy
%%EXAMPLESDIR%%/generalaxis.asy
%%EXAMPLESDIR%%/generalaxis3.asy
%%EXAMPLESDIR%%/grid.asy
+%%EXAMPLESDIR%%/grid3xyz.asy
%%EXAMPLESDIR%%/hatch.asy
%%EXAMPLESDIR%%/helix.asy
%%EXAMPLESDIR%%/hierarchy.asy
@@ -149,6 +160,7 @@ bin/xasy
%%EXAMPLESDIR%%/imagecontour.asy
%%EXAMPLESDIR%%/imagehistogram.asy
%%EXAMPLESDIR%%/integraltest.asy
+%%EXAMPLESDIR%%/intro.asy
%%EXAMPLESDIR%%/join.asy
%%EXAMPLESDIR%%/join3.asy
%%EXAMPLESDIR%%/labelbox.asy
@@ -175,6 +187,8 @@ bin/xasy
%%EXAMPLESDIR%%/lowint.asy
%%EXAMPLESDIR%%/lowupint.asy
%%EXAMPLESDIR%%/makepen.asy
+%%EXAMPLESDIR%%/markers1.asy
+%%EXAMPLESDIR%%/markers2.asy
%%EXAMPLESDIR%%/mexicanhat.asy
%%EXAMPLESDIR%%/monthaxis.asy
%%EXAMPLESDIR%%/mosaic.asy