aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-27 01:24:44 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-28 11:42:43 +0000
commitff82663b674567c432167b1d3c78c1a4da1d20ed (patch)
tree799bf925ab82847abbb14d3ee81757114fde9aba /math
parent719b60dc29cf866645f7e608a0960d22a2234c65 (diff)
downloadports-ff82663b674567c432167b1d3c78c1a4da1d20ed.tar.gz
ports-ff82663b674567c432167b1d3c78c1a4da1d20ed.zip
math/octave-forge-interval: fix build on powerpc*
Fixed in LLVM 16: Assertion failed: ((CGF.CurFuncDecl == nullptr || CGF.Builder.getIsFPConstrained() || isa<CXXConstructorDecl>(CGF.CurFuncDecl) || isa<CXXDestructorDecl>(CGF.CurFuncDecl) || (NewExceptionBehavior == llvm::fp::ebIgnore && NewRoundingBehavior == llvm::RoundingMode::NearestTiesToEven)) && "FPConstrained should be enabled on entire function"), function ConstructorHelper, file /usr/local/poudriere/jails/main-powerpc64/usr/src/contrib/llvm-project/clang/lib/CodeGen/CodeGenFunction.cpp, line 163. PLEASE submit a bug report to https://bugs.freebsd.org/submit/ and include the crash backtrace, preprocessed source, and associated run script. Stack dump: 0. Program arguments: c++ -c -I/usr/local/include/octave-8.2.0 -fPIC -I/usr/local/include/octave-8.2.0/octave/.. -I/usr/local/include/octave-8.2.0/octave -I/usr/local/include -pthread -O2 -pipe -I/usr/local/include/octave-8.2.0 -fstack-protector-strong -fno-strict-aliasing -I/usr/local/include/octave-8.2.0 -Wno-unknown-pragmas __setround__.cc -o /tmp/oct-J3uyET.o 1. <eof> parser at end of file 2. Per-file LLVM IR generation 3. /usr/include/c++/v1/string:1650:10: Generating code for declaration 'std::basic_string<char>::__init' c++: error: clang frontend command failed with exit code 134 (use -v to see invocation) FreeBSD clang version 15.0.7 (https://github.com/llvm/llvm-project.git llvmorg-15.0.7-0-g8dfdcc7b7bf6) Target: powerpc64-unknown-freebsd14.0 Thread model: posix InstalledDir: /usr/bin
Diffstat (limited to 'math')
-rw-r--r--math/octave-forge-interval/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/math/octave-forge-interval/Makefile b/math/octave-forge-interval/Makefile
index 8a6bc0b70d26..b9be5da73ac8 100644
--- a/math/octave-forge-interval/Makefile
+++ b/math/octave-forge-interval/Makefile
@@ -16,4 +16,11 @@ LIB_DEPENDS= libmpfr.so:math/mpfr
USES= octave
+.include <bsd.port.options.mk>
+
+.if ${ARCH:Mpowerpc*}
+CXX= clang++${LLVM_VERSION}
+USES+= llvm:min=16
+.endif
+
.include <bsd.port.mk>