aboutsummaryrefslogtreecommitdiff
path: root/misc/amanda25-server/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2004-11-15 11:20:22 +0000
committerJames E. Housley <jeh@FreeBSD.org>2004-11-15 11:20:22 +0000
commitfe3d6ef70f129afb81a1cada3b83e575cb8b1f0f (patch)
treeca862af9929d35f2984da58b37295b0ee45bdb77 /misc/amanda25-server/Makefile
parent43c6be92f60b3fa0255d8ddcfc0ec7a7b3d8e58a (diff)
downloadports-fe3d6ef70f129afb81a1cada3b83e575cb8b1f0f.tar.gz
ports-fe3d6ef70f129afb81a1cada3b83e575cb8b1f0f.zip
As pointed out in PR ports/73956, even if a user and/or group was specified
there were two chown statements they were ignored. PR: 73956 Submitted By: Phil Homewood <pdh@bne.snapgear.com>
Notes
Notes: svn path=/head/; revision=121655
Diffstat (limited to 'misc/amanda25-server/Makefile')
-rw-r--r--misc/amanda25-server/Makefile40
1 files changed, 11 insertions, 29 deletions
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index ef10443fe5ec..effa72195e98 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= ${MASTERPORTNAME}
PORTVERSION= 2.4.4p4
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -34,6 +34,9 @@ PATCH_STRIP=
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+AMANDA_USER?= operator
+AMANDA_GROUP?= operator
+
# amanda-server part
.if !defined(CLIENT_ONLY)
@@ -72,7 +75,8 @@ BUILD_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --without-client --disable-libtool --prefix=${PREFIX}
+ --without-client --disable-libtool --prefix=${PREFIX} \
+ --with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP}
MAN8= amadmin.8 amcheck.8 amcheckdb.8 amcleanup.8 amdd.8 \
amdump.8 amflush.8 amgetconf.8 amlabel.8 ammt.8 \
@@ -112,18 +116,6 @@ CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
.endif
-.if defined (AMANDA_USER)
-CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
-.else
-CONFIGURE_ARGS+= --with-user=operator
-.endif
-
-.if defined (AMANDA_GROUP)
-CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
-.else
-CONFIGURE_ARGS+= --with-group=operator
-.endif
-
.if defined (AMANDA_UDPPORTRANGE)
CONFIGURE_ARGS+= --with-udpportrange=${AMANDA_UDPPORTRANGE}
.endif
@@ -179,7 +171,9 @@ pre-fetch:
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --without-server --disable-libtool --prefix=${PREFIX}
+ --without-server --disable-libtool --prefix=${PREFIX} \
+ --with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP}
+
MAN8= amanda.8 amrecover.8 amrestore.8
@@ -191,9 +185,9 @@ post-install:
${WRKSRC}/example/disklist \
${PREFIX}/share/examples/amanda
${MKDIR} ${PREFIX}/var/amanda/gnutar-lists
- ${CHOWN} operator:operator ${PREFIX}/var/amanda/gnutar-lists
+ ${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} ${PREFIX}/var/amanda/gnutar-lists
${TOUCH} /etc/amandates
- ${CHOWN} operator:operator /etc/amandates
+ ${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} /etc/amandates
.if defined (AMANDA_SERVER)
CONFIGURE_ARGS+= --with-index-server=${AMANDA_SERVER}
@@ -208,18 +202,6 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR}
.endif
-.if defined (AMANDA_USER)
-CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
-.else
-CONFIGURE_ARGS+= --with-user=operator
-.endif
-
-.if defined (AMANDA_GROUP)
-CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
-.else
-CONFIGURE_ARGS+= --with-group=operator
-.endif
-
.if defined (AMANDA_UDPPORTRANGE)
CONFIGURE_ARGS+= --with-udpportrange=${AMANDA_UDPPORTRANGE}
.endif