aboutsummaryrefslogtreecommitdiff
path: root/misc/amanda32-server
diff options
context:
space:
mode:
authorChris Timmons <cwt@FreeBSD.org>2001-01-27 17:18:38 +0000
committerChris Timmons <cwt@FreeBSD.org>2001-01-27 17:18:38 +0000
commit33eba68847e762d89d0eee58efc466cccf4b113b (patch)
tree224462daf05875f0a1d9f24e10eba16ed38ce9d8 /misc/amanda32-server
parentdb744767d7cabf999d75370339951b06c692d3a2 (diff)
downloadports-33eba68847e762d89d0eee58efc466cccf4b113b.tar.gz
ports-33eba68847e762d89d0eee58efc466cccf4b113b.zip
Amanda 2.4.2. Uses gmake to work around bin/23328. Changer support enabled but untested.
Notes
Notes: svn path=/head/; revision=37650
Diffstat (limited to 'misc/amanda32-server')
-rw-r--r--misc/amanda32-server/Makefile12
-rw-r--r--misc/amanda32-server/distinfo2
-rw-r--r--misc/amanda32-server/files/patch-ae18
-rw-r--r--misc/amanda32-server/files/patch-af68
-rw-r--r--misc/amanda32-server/pkg-plist35
5 files changed, 33 insertions, 102 deletions
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index d94fc5f5ab17..98d8de8e8520 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -6,18 +6,18 @@
#
PORTNAME= amanda
-PORTVERSION= 2.4.1
+PORTVERSION= 2.4.2
CATEGORIES= misc
MASTER_SITES= ftp://ftp.amanda.org/pub/amanda/
-DISTNAME= amanda-2.4.1p1
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-WRKSRC= ${WRKDIR}/amanda-2.4.1p1
+WRKSRC= ${WRKDIR}/amanda-2.4.2
NO_LATEST_LINK= yes
+USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
@@ -28,9 +28,9 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
PATCH_STRIP=
MAN8= amadmin.8 amanda.8 amcheck.8 amcheckdb.8 amcleanup.8 \
- amdump.8 amflush.8 amlabel.8 amoverview.8 amplot.8 \
- amrecover.8 amreport.8 amrestore.8 amrmtape.8 amstatus.8 \
- amtape.8 amtoc.8 amverify.8
+ amdump.8 amflush.8 amgetconf.8 amlabel.8 amoverview.8 \
+ amplot.8 amrecover.8 amreport.8 amrestore.8 amrmtape.8 \
+ amstatus.8 amtape.8 amtoc.8 amverify.8
post-install:
${MKDIR} ${PREFIX}/share/examples/amanda
diff --git a/misc/amanda32-server/distinfo b/misc/amanda32-server/distinfo
index 7a6ad03da941..11c39fd7d06c 100644
--- a/misc/amanda32-server/distinfo
+++ b/misc/amanda32-server/distinfo
@@ -1 +1 @@
-MD5 (amanda-2.4.1p1.tar.gz) = 13f34dc97c35f85f88e54ca25b2009ed
+MD5 (amanda-2.4.2.tar.gz) = b10c0ada724694d0bbc46a0d3ebee3c9
diff --git a/misc/amanda32-server/files/patch-ae b/misc/amanda32-server/files/patch-ae
deleted file mode 100644
index 62ea9e28e154..000000000000
--- a/misc/amanda32-server/files/patch-ae
+++ /dev/null
@@ -1,18 +0,0 @@
---- config/config.h.in Thu Aug 27 11:43:52 1998
-+++ config/config.h.in Sun Sep 6 11:38:27 1998
-@@ -1,4 +1,4 @@
--/* config/config.h.in. Generated automatically from configure.in by autoheader. */
-+/* config/config.h.in. Generated automatically from ../configure.in by autoheader. */
- #ifndef _CONFIG_H
- #define _CONFIG_H
-
-@@ -360,6 +360,9 @@
-
- /* Define if you have the <arpa/inet.h> header file. */
- #undef HAVE_ARPA_INET_H
-+
-+/* Define if you have the <camlib.h> header file. */
-+#undef HAVE_CAMLIB_H
-
- /* Define if you have the <chio.h> header file. */
- #undef HAVE_CHIO_H
diff --git a/misc/amanda32-server/files/patch-af b/misc/amanda32-server/files/patch-af
deleted file mode 100644
index 272d5133ca48..000000000000
--- a/misc/amanda32-server/files/patch-af
+++ /dev/null
@@ -1,68 +0,0 @@
---- changer-src/scsi-chio.c Tue Jul 7 21:04:04 1998
-+++ changer-src/scsi-chio.c Sat Sep 12 16:11:21 1998
-@@ -114,6 +114,38 @@
- }
-
-
-+#if defined(__FreeBSD__) && defined(HAVE_CAMLIB_H)
-+#warning "CHIO TAPE CHANGER FUNCTIONS UNIMPLEMENTED FOR FREEBSD CAM"
-+#warning "Code will work fine if you aren't running a changer."
-+int isempty(int fd, int slot)
-+{
-+struct changer_element_status ces;
-+int i,rc;
-+int type=CHET_ST;
-+
-+return 0;
-+}
-+
-+int find_empty(int fd)
-+{
-+struct changer_element_status ces;
-+int i,rc;
-+int type=CHET_ST;
-+
-+return 0;
-+}
-+
-+int drive_loaded(int fd, int drivenum)
-+{
-+struct changer_element_status ces;
-+int i,rc;
-+int type=CHET_DT;
-+
-+return 0;
-+}
-+
-+#else
-+
- /*
- * this routine checks a specified slot to see if it is empty
- */
-@@ -141,6 +173,8 @@
- return !i;
- }
-
-+
-+
- /*
- * find the first empty slot
- */
-@@ -169,6 +203,8 @@
- return i;
- }
-
-+
-+
- /*
- * returns one if there is a tape loaded in the drive
- */
-@@ -195,7 +231,7 @@
- free(ces.ces_data);
- return i;
- }
--
-+#endif
-
- /*
- * unloads the drive, putting the tape in the specified slot
diff --git a/misc/amanda32-server/pkg-plist b/misc/amanda32-server/pkg-plist
index d04ad4ebbebe..9a351c91e341 100644
--- a/misc/amanda32-server/pkg-plist
+++ b/misc/amanda32-server/pkg-plist
@@ -1,23 +1,18 @@
lib/libamanda.a
-lib/libamanda.so
-lib/libamanda.so.0
lib/libamclient.a
-lib/libamclient.so
-lib/libamclient.so.0
lib/libamserver.a
-lib/libamserver.so
-lib/libamserver.so.0
lib/libamtape.a
-lib/libamtape.so
-lib/libamtape.so.0
libexec/amanda/amandad
libexec/amanda/amcat.awk
+libexec/amanda/amcleanupdisk
libexec/amanda/amidxtaped
libexec/amanda/amindexd
+libexec/amanda/amlogroll
libexec/amanda/amplot.awk
libexec/amanda/amplot.g
libexec/amanda/amplot.gp
libexec/amanda/amtrmidx
+libexec/amanda/amtrmlog
libexec/amanda/calcsize
libexec/amanda/chg-chio
libexec/amanda/chg-chs
@@ -28,7 +23,6 @@ libexec/amanda/chg-rth
libexec/amanda/chg-zd-mtx
libexec/amanda/driver
libexec/amanda/dumper
-libexec/amanda/getconf
libexec/amanda/killpgrp
libexec/amanda/patch-system
libexec/amanda/planner
@@ -45,6 +39,7 @@ sbin/amcheckdb
sbin/amcleanup
sbin/amdump
sbin/amflush
+sbin/amgetconf
sbin/amlabel
sbin/amoverview
sbin/amplot
@@ -56,6 +51,28 @@ sbin/amstatus
sbin/amtape
sbin/amtoc
sbin/amverify
+share/amanda/COPYRIGHT
+share/amanda/COPYRIGHT-APACHE
+share/amanda/COPYRIGHT-REGEX
+share/amanda/DUMPER-API
+share/amanda/FAQ
+share/amanda/INDEXING
+share/amanda/INSTALL
+share/amanda/INTERNALS
+share/amanda/KERBEROS
+share/amanda/LABEL.PRINTING
+share/amanda/MULTITAPE
+share/amanda/RESTORE
+share/amanda/SAMBA
+share/amanda/SECURITY
+share/amanda/SYSTEM.NOTES
+share/amanda/TAPE.CHANGERS
+share/amanda/TAPETYPES
+share/amanda/UPGRADE
+share/amanda/WHATS.NEW
+share/amanda/WISHLIST
+share/amanda/YEAR2000
+share/amanda/ZFTAPE
share/examples/amanda/amanda.conf
share/examples/amanda/chg-multi.conf
share/examples/amanda/chg-scsi.conf