aboutsummaryrefslogtreecommitdiff
path: root/misc/chord2html
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-11 10:51:16 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-11 10:51:16 +0000
commit3685f97d366bd46af8353599c474e89c9b9eaa7d (patch)
treeb14bd06c1111a17677eb4cca7dca2a3c542612cd /misc/chord2html
parentf5caf714c5e74fd26993acf2b58b1ba1272e2d00 (diff)
downloadports-3685f97d366bd46af8353599c474e89c9b9eaa7d.tar.gz
ports-3685f97d366bd46af8353599c474e89c9b9eaa7d.zip
add chord2html 1.3
Convert CHORD input files to HTML
Notes
Notes: svn path=/head/; revision=66117
Diffstat (limited to 'misc/chord2html')
-rw-r--r--misc/chord2html/Makefile33
-rw-r--r--misc/chord2html/distinfo1
-rw-r--r--misc/chord2html/files/patch-chord2html11
-rw-r--r--misc/chord2html/pkg-comment1
-rw-r--r--misc/chord2html/pkg-descr7
-rw-r--r--misc/chord2html/pkg-plist3
6 files changed, 56 insertions, 0 deletions
diff --git a/misc/chord2html/Makefile b/misc/chord2html/Makefile
new file mode 100644
index 000000000000..7cee940eaa37
--- /dev/null
+++ b/misc/chord2html/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: chord2html
+# Date created: Sep 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= chord2html
+PORTVERSION= 1.3
+CATEGORIES= misc
+MASTER_SITES= http://helllabs.org/~claudio/chord/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+MAN1= chord2html.1
+
+post-patch:
+ @${PERL} -pi -e "s,/usr/bin/perl,${PERL},g ; \
+ s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/chord2html
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/chord2html ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/chord2html.css ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/misc/chord2html/distinfo b/misc/chord2html/distinfo
new file mode 100644
index 000000000000..030f3f6350f5
--- /dev/null
+++ b/misc/chord2html/distinfo
@@ -0,0 +1 @@
+MD5 (chord2html-1.3.tar.gz) = fcbca77921bb1ad03b82416b0b4c3e63
diff --git a/misc/chord2html/files/patch-chord2html b/misc/chord2html/files/patch-chord2html
new file mode 100644
index 000000000000..f8af5d97e9b5
--- /dev/null
+++ b/misc/chord2html/files/patch-chord2html
@@ -0,0 +1,11 @@
+--- chord2html.orig Wed Sep 11 18:45:11 2002
++++ chord2html Wed Sep 11 18:45:30 2002
+@@ -32,7 +32,7 @@
+ $bg_color = "white";
+ $format = $opt_T || "png";
+ $color = "color=\"blue\"";
+-$style = $opt_s || "chord2html.css";
++$style = $opt_s || "%%PREFIX%%/share/chord2html/chord2html.css";
+ $me = $0;
+
+ $opt_q && ($opt_v = 0);
diff --git a/misc/chord2html/pkg-comment b/misc/chord2html/pkg-comment
new file mode 100644
index 000000000000..cd1a19528f90
--- /dev/null
+++ b/misc/chord2html/pkg-comment
@@ -0,0 +1 @@
+Convert CHORD input files to HTML
diff --git a/misc/chord2html/pkg-descr b/misc/chord2html/pkg-descr
new file mode 100644
index 000000000000..dc0cf1481f8c
--- /dev/null
+++ b/misc/chord2html/pkg-descr
@@ -0,0 +1,7 @@
+chord2html is a small Perl script to convert CHORD input files (the .chopro
+files in OLGA) to HTML. The HTML files are similar to the PostScript documents
+produced by CHORD; chord2html reads a text file containing the lyrics and
+chords of a song to produce a page with chord names above the words and a
+graphical representation of the chords at the end of the songs.
+
+WWW: http://helllabs.org/~claudio/chord/
diff --git a/misc/chord2html/pkg-plist b/misc/chord2html/pkg-plist
new file mode 100644
index 000000000000..f3eb9b294064
--- /dev/null
+++ b/misc/chord2html/pkg-plist
@@ -0,0 +1,3 @@
+bin/chord2html
+share/chord2html/chord2html.css
+@dirrm share/chord2html