aboutsummaryrefslogtreecommitdiff
path: root/misc/clex/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-02-02 14:13:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-02-02 14:13:30 +0000
commit43140d23fccf8aec878742d99c8a00e9d5bf8673 (patch)
tree0e92e56c1fc8ae69a6152b136dc76b42723e712c /misc/clex/Makefile
parent5830e1295352038e9d1222c385a2729475ca0d39 (diff)
downloadports-43140d23fccf8aec878742d99c8a00e9d5bf8673.tar.gz
ports-43140d23fccf8aec878742d99c8a00e9d5bf8673.zip
- Update to version 4.6.4
- Define LICENSE (GPLv2) and remove it (and some other useless files) from PORTDOCS - Remove pkg-plist; use PLIST_FILES/PORTDOCS instead - Adjust COMMENT and canonicalize Makefile header - Always include large file support as it seems there is no reason not to enable it these days - Remove useless MASTER_SITE_SUBDIR and add missing USE_NCURSES knobs - Deorbit custom do-install target; instead use post-install for PORTDOCS - Unmute installation commands Submitted by: zeus@ibs.dn.ua (version update; cleanups and bugs are mine) Approved by: maintainer timeout (over 6 months)
Notes
Notes: svn path=/head/; revision=290307
Diffstat (limited to 'misc/clex/Makefile')
-rw-r--r--misc/clex/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/misc/clex/Makefile b/misc/clex/Makefile
index a4ba9cb95441..56eb1013e533 100644
--- a/misc/clex/Makefile
+++ b/misc/clex/Makefile
@@ -1,4 +1,4 @@
-# Ports collection makefile for: clex-tty
+# New ports collection makefile for: CLEX File Manager
# Date created: Tue Oct 30, 2002
# Whom: Michael L. Hostbaek <mich@freebsdcluster.org>
#
@@ -6,34 +6,34 @@
#
PORTNAME= clex
-PORTVERSION= 3.18
+PORTVERSION= 4.6.4
CATEGORIES= misc
MASTER_SITES= http://www.clex.sk/download/
-MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mich@FreeBSD.org
-COMMENT= A commandline file manager
+COMMENT= A command line file manager
+
+LICENSE= GPLv2
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_NCURSES= yes
-DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
-MAN1= clex.1
-
-OPTIONS= LARGE_FILES "Enable support for large files" on
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/clex bin/cfg-clex bin/kbd-test
+PORTDOCS= AUTHORS ChangeLog README
+MAN1= clex.1 cfg-clex.1 kbd-test.1
-.if !defined(WITH_LARGE_FILES)
-CONFIGURE_ARGS+= --disable-largefile
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e '18s,^,#include <stdio.h>,' \
+ ${WRKSRC}/src/preview.c
-do-install:
.if !defined(NOPORTDOCS)
+post-install:
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
- @${INSTALL_MAN} ${WRKSRC}/src/${MAN1} ${MAN1PREFIX}/man/man1
- @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>