aboutsummaryrefslogtreecommitdiff
path: root/misc/clpbar/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-31 00:12:48 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-31 00:12:48 +0000
commit0f280153dffc272c7a27379af32617e29b665266 (patch)
treed1c6935645e6a55b3fdaa56aad07025fe44c8073 /misc/clpbar/Makefile
parentcb93a3cf920fa146e3a22e2d2a42cda28857e1a4 (diff)
downloadports-0f280153dffc272c7a27379af32617e29b665266.tar.gz
ports-0f280153dffc272c7a27379af32617e29b665266.zip
Actually, this is only necessary on 32-bit systems. This is probably also
not the most graceful way to accomplish this.
Notes
Notes: svn path=/head/; revision=363528
Diffstat (limited to 'misc/clpbar/Makefile')
-rw-r--r--misc/clpbar/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/misc/clpbar/Makefile b/misc/clpbar/Makefile
index 89d1287c6929..2ddcc55a16d0 100644
--- a/misc/clpbar/Makefile
+++ b/misc/clpbar/Makefile
@@ -13,9 +13,14 @@ COMMENT= Command Line Progress Bar
WRKSRC= ${WRKDIR}/bar-${PORTVERSION}
GNU_CONFIGURE= yes
MAKE_ARGS+= CFLAGS+="${CFLAGS}"
-CONFIGURE_ARGS= --disable-use-m64
PLIST_FILES= bin/bar \
man/man1/bar.1.gz
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if empty(ARCH:M*64)
+CONFIGURE_ARGS= --disable-use-m64
+.endif
+
+.include <bsd.port.post.mk>