aboutsummaryrefslogtreecommitdiff
path: root/misc/countrycodes
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-03-15 20:30:42 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-03-15 20:30:42 +0000
commit5353ed9277c9a764c19c97d5c063f37c64e50c00 (patch)
treeb27fe332a6000bc931bb814a122f891174d61a8c /misc/countrycodes
parent94693094dfb76ad636887dead9730b9f824db2e1 (diff)
downloadports-5353ed9277c9a764c19c97d5c063f37c64e50c00.tar.gz
ports-5353ed9277c9a764c19c97d5c063f37c64e50c00.zip
Update to 1.0.6
Notes
Notes: svn path=/head/; revision=436258
Diffstat (limited to 'misc/countrycodes')
-rw-r--r--misc/countrycodes/Makefile13
-rw-r--r--misc/countrycodes/distinfo5
-rw-r--r--misc/countrycodes/files/patch-Makefile43
-rw-r--r--misc/countrycodes/files/patch-src_Makefile32
-rw-r--r--misc/countrycodes/pkg-descr2
5 files changed, 51 insertions, 44 deletions
diff --git a/misc/countrycodes/Makefile b/misc/countrycodes/Makefile
index 58d306746532..599f1eadf715 100644
--- a/misc/countrycodes/Makefile
+++ b/misc/countrycodes/Makefile
@@ -2,28 +2,23 @@
# $FreeBSD$
PORTNAME= countrycodes
-PORTVERSION= 1.0.5
+PORTVERSION= 1.0.6
CATEGORIES= misc
-MASTER_SITES= http://www.grigna.com/diego/linux/countrycodes/ \
- LOCAL/ehaupt
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= ISO 3166 country code finder
LICENSE= GPLv2
-
-BUILD_WRKSRC= ${WRKSRC}/src
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
+LICENSE_FILE= ${WRKSRC}/COPYING
PLIST_FILES= bin/iso3166 man/man1/iso3166.1.gz
PORTDOCS= README
-MAKE_ARGS= prefix="${STAGEDIR}${PREFIX}" CC="${CC}" CCOPTS="${CFLAGS}" WARNINGS=""
-
OPTIONS_DEFINE= DOCS
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/misc/countrycodes/distinfo b/misc/countrycodes/distinfo
index a54a04afdc96..f4b17396f4aa 100644
--- a/misc/countrycodes/distinfo
+++ b/misc/countrycodes/distinfo
@@ -1,2 +1,3 @@
-SHA256 (countrycodes-1.0.5.tar.gz) = e56e10442c7353c39cd9e57fa747df279ae39a84a89336644a58c29de5b2b39b
-SIZE (countrycodes-1.0.5.tar.gz) = 18621
+TIMESTAMP = 1489608226
+SHA256 (countrycodes-1.0.6.tar.gz) = 4574d331b4e25f78b792fb0c10556312cca462973a9819b86c643d35ce69ed96
+SIZE (countrycodes-1.0.6.tar.gz) = 18834
diff --git a/misc/countrycodes/files/patch-Makefile b/misc/countrycodes/files/patch-Makefile
new file mode 100644
index 000000000000..8e6ea391ab0c
--- /dev/null
+++ b/misc/countrycodes/files/patch-Makefile
@@ -0,0 +1,43 @@
+--- Makefile.orig 2017-02-26 15:02:56 UTC
++++ Makefile
+@@ -9,7 +9,7 @@
+ prefix ?= /usr/local
+ bindir ?= ${prefix}/bin
+
+-mandir ?= ${prefix}/man/man1
++mandir ?= ${MANPREFIX}/man/man1
+
+ # For system that doesn't support mkdir -p.
+ # If you have Linux, don't bother.
+@@ -23,13 +23,13 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
++CC?=gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++#WARNINGS= -pedantic -Wall
+
+ # Compiler flags
+-CCOPTS = -O2 -fomit-frame-pointer
++CCOPTS = ${CFLAGS}
+
+ # The makefile standards document I read says that I have to put it here...
+ SHELL = /bin/sh
+@@ -66,11 +66,11 @@ clean:
+ strip:
+ strip $(PROGRAM)
+
+-install:
+- $(MKDIRECTORY) $(DESTDIR)/${bindir} $(DESTDIR)/${mandir}/man1
++install: strip
++ $(MKDIRECTORY) $(DESTDIR)/${bindir} $(DESTDIR)/${mandir}
+ $(INSTALL) -m $(BINMODE) $(PROGRAM) $(DESTDIR)/${bindir}
+ @echo "Installing man page..."
+- $(INSTALL) -m 644 iso3166.1 $(DESTDIR)/${mandir}/man1
++ $(INSTALL) -m 644 iso3166.1 $(DESTDIR)/${mandir}
+
+ update-man:
+ @$(SEDBIN) $(SEDCMDS) iso3166.1.in > iso3166.1
diff --git a/misc/countrycodes/files/patch-src_Makefile b/misc/countrycodes/files/patch-src_Makefile
deleted file mode 100644
index a380c7705775..000000000000
--- a/misc/countrycodes/files/patch-src_Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
---- src/Makefile.orig Sat Feb 1 16:56:08 2003
-+++ src/Makefile Sun Jul 24 21:39:05 2005
-@@ -58,11 +58,14 @@
-
- PROGRAM = iso3166
-
--all: $(PROGRAM)
-+all: $(PROGRAM) iso3166.1
-
- $(PROGRAM): $(ISO3166OBJ)
- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
-
-+iso3166.1: ${docdir}/iso3166.1.in
-+ @$(SEDBIN) $(SEDCMDS) $> > $@
-+
- clean:
- rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
-
-@@ -70,11 +73,8 @@
- strip $(PROGRAM)
-
- install:
-- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
-- @echo "Installing man page..."
-- @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
-- @chown 0.0 ${mandir}/iso3166.1
-- @echo
-+ $(BSD_INSTALL_PROGRAM) ${srcdir}/$(PROGRAM) ${bindir}
-+ $(BSD_INSTALL_MAN) iso3166.1 ${mandir}
-
- uninstall:
- rm -f ${bindir}/$(PROGRAM)
diff --git a/misc/countrycodes/pkg-descr b/misc/countrycodes/pkg-descr
index bd4ad0685c93..adac82e2fe5d 100644
--- a/misc/countrycodes/pkg-descr
+++ b/misc/countrycodes/pkg-descr
@@ -2,4 +2,4 @@ Countrycodes is an ISO 3166 country code finder. It is mainly used to know
the country a domain name belongs to. It also allows searching by 2 or 3
letters codes, country number and country name.
-WWW: http://www.grigna.com/diego/linux/countrycodes/
+WWW: https://sourceforge.net/projects/countrycodes/