aboutsummaryrefslogtreecommitdiff
path: root/misc/dahdi
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2010-08-31 03:37:06 +0000
committerMax Khon <fjoe@FreeBSD.org>2010-08-31 03:37:06 +0000
commit0babd6d2de64500e6e162a38fccb589d33a494b4 (patch)
tree485e0b80f6ef1bc1f321dbdf7b85ef2f11e562a6 /misc/dahdi
parentd2e84b418d3dcf7df02eb196cba4a91b8a909e4c (diff)
downloadports-0babd6d2de64500e6e162a38fccb589d33a494b4.tar.gz
ports-0babd6d2de64500e6e162a38fccb589d33a494b4.zip
- Update to 2.4.0rc3
- Run "fxotune -s" during startup if fxotune.conf is present in the default location ($PREFIX/etc/fxotune.conf).
Notes
Notes: svn path=/head/; revision=260251
Diffstat (limited to 'misc/dahdi')
-rw-r--r--misc/dahdi/Makefile2
-rw-r--r--misc/dahdi/distinfo6
-rw-r--r--misc/dahdi/files/dahdi.in6
3 files changed, 9 insertions, 5 deletions
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index 3dbadffd4d2e..992e22e94519 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -19,7 +19,7 @@ COMMENT= Digium/Asterisk Hardware Device Interface
BUILD_DEPENDS= gmake:${PORTSDIR}/devel/gmake
LIB_DEPENDS= newt.52:${PORTSDIR}/devel/newt
-DAHDI_VERSION= 2.4.0-rc2
+DAHDI_VERSION= 2.4.0-rc3
DAHDI_TOOLS_VERSION= 2.4.0-rc1
NO_PACKAGE= Should be in sync with the kernel to work correctly
diff --git a/misc/dahdi/distinfo b/misc/dahdi/distinfo
index bebc7c368400..4fd504636928 100644
--- a/misc/dahdi/distinfo
+++ b/misc/dahdi/distinfo
@@ -1,3 +1,3 @@
-MD5 (dahdi-freebsd-complete-2.4.0-rc2+2.4.0-rc1.tar.gz) = 3393be3504d041283a02a088a295c78f
-SHA256 (dahdi-freebsd-complete-2.4.0-rc2+2.4.0-rc1.tar.gz) = 0da28c257f8e21b2ab81a21144773dfdfcdd6c90981cc0eafd576fed63708a03
-SIZE (dahdi-freebsd-complete-2.4.0-rc2+2.4.0-rc1.tar.gz) = 2048391
+MD5 (dahdi-freebsd-complete-2.4.0-rc3+2.4.0-rc1.tar.gz) = 72f236f905c6f8ac66e3bb4d781cffaa
+SHA256 (dahdi-freebsd-complete-2.4.0-rc3+2.4.0-rc1.tar.gz) = fb31f1ca76fa89568ba9590a4d65f7e26ab69e45e09587bd0e3b2a97b93ade60
+SIZE (dahdi-freebsd-complete-2.4.0-rc3+2.4.0-rc1.tar.gz) = 2048903
diff --git a/misc/dahdi/files/dahdi.in b/misc/dahdi/files/dahdi.in
index adf915391837..e4eea6b1ffad 100644
--- a/misc/dahdi/files/dahdi.in
+++ b/misc/dahdi/files/dahdi.in
@@ -51,13 +51,17 @@ done
dahdi_start()
{
- echo -n " ${name}"
+ echo "Starting ${name}."
kldconfig -mf ${kmod_dir}
for m in ${dahdi_modules}; do
kldload $m || exit 1
done
%%PREFIX%%/sbin/dahdi_cfg
+ if [ -r %%PREFIX%%/etc/fxotune.conf ]; then
+ echo "Starting fxotune."
+ %%PREFIX%%/sbin/fxotune -s
+ fi
}
dahdi_stop()