aboutsummaryrefslogtreecommitdiff
path: root/misc/dnetc/Makefile
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2006-10-07 16:52:34 +0000
committerTim Bishop <tdb@FreeBSD.org>2006-10-07 16:52:34 +0000
commit515f588c86ce0429390b5ae7e0c81bd5c9bc0c4c (patch)
treeac8ffe2eb3a1dd1a7cddc368e37c90ffd07cb6ec /misc/dnetc/Makefile
parent511f0f0ca578e78fa2a324bce960a9d64da13a8e (diff)
downloadports-515f588c86ce0429390b5ae7e0c81bd5c9bc0c4c.tar.gz
ports-515f588c86ce0429390b5ae7e0c81bd5c9bc0c4c.zip
- Pre-release clients are now properly released.
- Add client for FreeBSD6/amd64. - Try and tidy the tests for which binary to fetch.
Notes
Notes: svn path=/head/; revision=174807
Diffstat (limited to 'misc/dnetc/Makefile')
-rw-r--r--misc/dnetc/Makefile27
1 files changed, 18 insertions, 9 deletions
diff --git a/misc/dnetc/Makefile b/misc/dnetc/Makefile
index 5f46aecfb879..0b47814c4560 100644
--- a/misc/dnetc/Makefile
+++ b/misc/dnetc/Makefile
@@ -48,24 +48,33 @@ SUB_LIST= BINDIR="${BINDIR}" \
.include <bsd.port.pre.mk>
-.if ${ARCH} == sparc64 || ${ARCH} == alpha
-VERSION= 2.9003.481
-.elif ${ARCH} == amd64
-VERSION= 2.9011.496
-.else
+.if ${ARCH} == i386
VERSION= 2.9012.497
+.if ${OSVERSION} >= 503000
+DISTNAME= dnetc${PORTVERSION:E}-freebsd5-${ARCH:S/i386/x86/}-elf
+.endif
+.if ${OSVERSION} >= 600034
+DISTNAME= dnetc${PORTVERSION:E}-freebsd6-${ARCH:S/i386/x86/}-elf
+WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd6-${ARCH:S/i386/x86/}-elf
+.endif
.endif
-.if ${ARCH} == i386 && ${OSVERSION} >= 503000
-MASTER_SITE_SUBDIR= prerelease/rc
+.if ${ARCH} == amd64
+.if ${OSVERSION} >= 503000
+VERSION= 2.9011.496
+#DISTNAME= dnetc${PORTVERSION:E}-freebsd5-${ARCH:S/i386/x86/}-elf
+.endif
.if ${OSVERSION} >= 600034
+VERSION= 2.9012.497
DISTNAME= dnetc${PORTVERSION:E}-freebsd6-${ARCH:S/i386/x86/}-elf
WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd6-${ARCH:S/i386/x86/}-elf
-.else
-DISTNAME= dnetc${PORTVERSION:E}-freebsd5-${ARCH:S/i386/x86/}-elf
.endif
.endif
+.if ${ARCH} == sparc64 || ${ARCH} == alpha
+VERSION= 2.9003.481
+.endif
+
do-configure:
@if [ ! -f ${PREFIX}/dnetc.ini ]; then \
${INSTALL} -c -m 644 ${FILESDIR}/dnetc.ini ${WRKSRC}; \