aboutsummaryrefslogtreecommitdiff
path: root/misc/estic
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2019-06-27 09:59:54 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2019-06-27 09:59:54 +0000
commit78e5f728adc841603fd46708a4e3852849527acf (patch)
tree1c07c529c9e69bdaca186952901377f25ff312d9 /misc/estic
parenta07b57c87a6c415a176114c2828259b36eb839ea (diff)
downloadports-78e5f728adc841603fd46708a4e3852849527acf.tar.gz
ports-78e5f728adc841603fd46708a4e3852849527acf.zip
- fix build with gcc9
- fix build with clang from base on FreeBSD-11 and FreeBSD-12 PR: 238647
Notes
Notes: svn path=/head/; revision=505205
Diffstat (limited to 'misc/estic')
-rw-r--r--misc/estic/Makefile6
-rw-r--r--misc/estic/files/patch-str.h9
2 files changed, 10 insertions, 5 deletions
diff --git a/misc/estic/Makefile b/misc/estic/Makefile
index 2cef339c0ee6..e632c39de5f5 100644
--- a/misc/estic/Makefile
+++ b/misc/estic/Makefile
@@ -3,7 +3,7 @@
PORTNAME= estic
PORTVERSION= 1.61
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= misc comms
MASTER_SITES= LOCAL/dinoex
PKGNAMESUFFIX?= ${NOX11_SUFFIX}${PKGNAMESUFFIX2}
@@ -14,13 +14,9 @@ COMMENT= Controller for ISDN TK-Anlage (PBX) made by Istec
LICENSE= BSD2CLAUSE
-BROKEN_armv6= fails to compile: str.h: friend declaration specifying a default argument must be the only declaration
-BROKEN_armv7= fails to compile: str.h: friend declaration specifying a default argument must be the only declaration
-
USES= ncurses zip
USE_CSTD= gnu89
USE_CXXSTD= gnu++98
-USE_GCC= any
NO_WRKSUBDIR= yes
# Personal Preferences, Where to install.
diff --git a/misc/estic/files/patch-str.h b/misc/estic/files/patch-str.h
index 23a3f8dd69b1..65e9ce719519 100644
--- a/misc/estic/files/patch-str.h
+++ b/misc/estic/files/patch-str.h
@@ -47,3 +47,12 @@
class String : public Streamable {
+@@ -303,7 +343,7 @@ public:
+ // representation by the character itself, e.g. replace "\n" by the
+ // character with code 13.
+
+- friend String ShowControls (const String& S, unsigned Style = ccDefault);
++ friend String ShowControls (const String& S, unsigned Style);
+ // Recode the given string and replace every control character by it's
+ // visible representation, e.g. "\n" instead of the character with code
+ // code 13.