aboutsummaryrefslogtreecommitdiff
path: root/misc/figlet-fonts/Makefile
diff options
context:
space:
mode:
authorDima Dorfman <dd@FreeBSD.org>2001-08-11 18:20:24 +0000
committerDima Dorfman <dd@FreeBSD.org>2001-08-11 18:20:24 +0000
commit56bf5a36261ff74ced7e092c99f0dd41602ce93a (patch)
treebaab1dd970530be82d8ecc87fd2aca468cc9c3bb /misc/figlet-fonts/Makefile
parent73f81b8c4233337f905c12df8a09e2f4abbde298 (diff)
downloadports-56bf5a36261ff74ced7e092c99f0dd41602ce93a.tar.gz
ports-56bf5a36261ff74ced7e092c99f0dd41602ce93a.zip
Add figlet-fonts, a port that installs about 150 contributed fonts for
misc/figlet. I didn't try to integrate this into the main figlet port since most of these are rather useless, although some are nice.
Notes
Notes: svn path=/head/; revision=46083
Diffstat (limited to 'misc/figlet-fonts/Makefile')
-rw-r--r--misc/figlet-fonts/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/misc/figlet-fonts/Makefile b/misc/figlet-fonts/Makefile
new file mode 100644
index 000000000000..db52086f7e6c
--- /dev/null
+++ b/misc/figlet-fonts/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: figlet-fonts
+# Date created: 11 August 2001
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= figlet-fonts
+PORTVERSION= 20010811
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= dd
+
+MAINTAINER= dd@FreeBSD.org
+
+RUN_DEPENDS= figlet:${PORTSDIR}/misc/figlet
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+FONTFILES!= ${CAT} ${FILESDIR}/fontfiles
+
+do-install:
+ @${INSTALL_DATA} ${FONTFILES:S/^/${WRKSRC}\//} ${PREFIX}/share/figlet
+
+# Because of the large amount of files, I've decided not to have the
+# port automatically download all of them, but instead have the
+# maintainer generate the distfile. The `tarball' target should take
+# care of that.
+
+REAL_MASTER_SITES= \
+ ftp://wuarchive.wustl.edu/graphics/graphics/misc/figlet/fonts/ \
+ ftp://ftp.funet.fi/pub/unix/tools/figlet/fonts/
+
+tarball:
+ @${MKDIR} ${.CURDIR}/${DISTNAME}
+.for __fx in ${FONTFILES}
+ @${MKDIR} ${.CURDIR}/${DISTNAME}/${__fx:H}
+ @for MASTER_SITE in ${REAL_MASTER_SITES}; do \
+ if ${SETENV} ${FETCH_ENV} ${FETCH_CMD} \
+ -o ${.CURDIR}/${DISTNAME}/${__fx} \
+ ${FETCH_BEFORE_ARGS} $${MASTER_SITE}${__fx} \
+ ${FETCH_AFTER_ARGS}; then \
+ break; \
+ fi; \
+ done;
+.endfor
+ @cd ${.CURDIR} && ${TAR} -zcf ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}
+
+# Generate pkg-plist from files/fontfiles.
+
+makelist:
+ ${CAT} ${FILESDIR}/fontfiles | ${SED} 's;^[^/]*/;share/figlet/;' \
+ > ${PLIST}
+
+.include <bsd.port.post.mk>