aboutsummaryrefslogtreecommitdiff
path: root/misc/fortuneit
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-02-15 13:33:25 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-02-15 13:33:25 +0000
commitaea62ac573548ea40795902c0b0d00891f16d950 (patch)
tree564efd14d553a1a2b020275d456e35f8605bd0de /misc/fortuneit
parent62b0e06bbad2d51be5f4205c55c6e932f3e5bad2 (diff)
downloadports-aea62ac573548ea40795902c0b0d00891f16d950.tar.gz
ports-aea62ac573548ea40795902c0b0d00891f16d950.zip
Unbreak on head
Notes
Notes: svn path=/head/; revision=379034
Diffstat (limited to 'misc/fortuneit')
-rw-r--r--misc/fortuneit/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/misc/fortuneit/Makefile b/misc/fortuneit/Makefile
index 355906fe41b1..4e6ee5c3dff8 100644
--- a/misc/fortuneit/Makefile
+++ b/misc/fortuneit/Makefile
@@ -10,38 +10,29 @@ DISTNAME= fortune-it-${PORTVERSION}
MAINTAINER= gmarco@gufi.org
COMMENT= Funny fortune file in Italian
+.if exists(/usr/games/strfile)
STRCMD= /usr/games/strfile
+.elif exists(/usr/bin/strfile)
+STRCMD= /usr/bin/strfile
+.else
+IGNORE= needs strfile command. Please install games distribution of base system
+.endif
FORTUNEFILES= adams banner computer definizioni formiche italia itatrek \
jackfr leggi luke luttazzi norm paolotedeschi zuse \
computer-o definizioni-o film-o italia-o jackfr-o leggi-o \
luttazzi-o obsc-o zuse-o
-pre-build:
-.if !exists(${STRCMD})
- @${ECHO_MSG} "Please install the games distribution"
- @exit 1
-.endif
-
do-build:
.for f in ${FORTUNEFILES}
${STRCMD} ${WRKSRC}/testi/${f}
.endfor
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/games
@${MKDIR} ${STAGEDIR}${PREFIX}/share/games/fortune
.for f in ${FORTUNEFILES}
- @${INSTALL_DATA} ${WRKSRC}/testi/${f}* \
+ ${INSTALL_DATA} ${WRKSRC}/testi/${f}* \
${STAGEDIR}${PREFIX}/share/games/fortune
.endfor
-post-install:
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Usage:"
- @${ECHO_MSG} "/usr/games/fortune [-aDefilosw] ${PREFIX}/share/games/fortune/"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Please check fortune manual pages for more informations"
- @${ECHO_MSG} ""
-
.include <bsd.port.mk>