aboutsummaryrefslogtreecommitdiff
path: root/misc/gkrellshoot
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>2002-03-08 17:04:47 +0000
committerJim Mock <jim@FreeBSD.org>2002-03-08 17:04:47 +0000
commit76a31d626b6a198461166aa751f873468471d735 (patch)
tree34bfe344bcb4f7b76f29c10d481b3f7f1c900c72 /misc/gkrellshoot
parente52b8b908a2f8798c37a49a651720b9c9ce97382 (diff)
downloadports-76a31d626b6a198461166aa751f873468471d735.tar.gz
ports-76a31d626b6a198461166aa751f873468471d735.zip
New port of gkrellshoot, a screen locking and screen capture plugin for
GKrellM. Submitted by: Andrew Stuart <elitetek@tekrealm.net>
Notes
Notes: svn path=/head/; revision=55733
Diffstat (limited to 'misc/gkrellshoot')
-rw-r--r--misc/gkrellshoot/Makefile23
-rw-r--r--misc/gkrellshoot/distinfo1
-rw-r--r--misc/gkrellshoot/files/patch-Makefile55
-rw-r--r--misc/gkrellshoot/pkg-comment1
-rw-r--r--misc/gkrellshoot/pkg-descr5
-rw-r--r--misc/gkrellshoot/pkg-plist1
6 files changed, 86 insertions, 0 deletions
diff --git a/misc/gkrellshoot/Makefile b/misc/gkrellshoot/Makefile
new file mode 100644
index 000000000000..3e6ecab3c5cd
--- /dev/null
+++ b/misc/gkrellshoot/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: gkrellshoot
+# Date Created: 7 Mar 2002
+# Whom: Andrew Stuart <elitetek@tekrealm.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gkrellshoot
+PORTVERSION= 0.2
+CATEGORIES= misc
+MASTER_SITES= http://www.geocities.com/m_muthukumar/
+
+MAINTAINER= elitetek@tekrealm.net
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm \
+ import:${PORTSDIR}/graphics/ImageMagick
+
+WRKSRC= ${WRKDIR}/gkrellShoot-${PORTVERSION}
+USE_X_PREFIX= yes
+USE_IMLIB= yes
+
+.include <bsd.port.mk>
diff --git a/misc/gkrellshoot/distinfo b/misc/gkrellshoot/distinfo
new file mode 100644
index 000000000000..d41bb721ae25
--- /dev/null
+++ b/misc/gkrellshoot/distinfo
@@ -0,0 +1 @@
+MD5 (gkrellshoot-0.2.tar.gz) = 17b132289647044e413255788c13642d
diff --git a/misc/gkrellshoot/files/patch-Makefile b/misc/gkrellshoot/files/patch-Makefile
new file mode 100644
index 000000000000..b9455f7d44bf
--- /dev/null
+++ b/misc/gkrellshoot/files/patch-Makefile
@@ -0,0 +1,55 @@
+--- Makefile.orig Thu Mar 7 00:44:28 2002
++++ Makefile Thu Mar 7 00:52:39 2002
+@@ -1,20 +1,20 @@
+-GTK_INCLUDE = `gtk-config --cflags`
+-GTK_LIB = `gtk-config --libs`
++GTK_INCLUDE = `$(GTK_CONFIG) --cflags`
++GTK_LIB = `$(GTK_CONFIG) --libs`
+
+-IMLIB_INCLUDE = `imlib-config --cflags-gdk`
+-IMLIB_LIB = `imlib-config --libs-gdk`
++IMLIB_INCLUDE = `${IMLIB_CONFIG} --cflags-gdk`
++IMLIB_LIB = `${IMLIB_CONFIG} --libs-gdk`
+
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE)
++CFLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE)
+ LIBS = $(GTK_LIB) $(IMLIB_LIB)
+ LFLAGS = -shared
+
+-CC = gcc $(CFLAGS) $(FLAGS)
++CC ?= gcc $(CFLAGS) $(FLAGS)
+
+ OBJS = gkrellshoot.o
+
+ gkrellshoot.so: $(OBJS)
+- $(CC) $(OBJS) -o gkrellshoot.so $(LFLAGS) $(LIBS) -lpthread
++ $(CC) $(OBJS) -o gkrellshoot.so $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
+@@ -22,21 +22,9 @@
+ gkrellshoot.o: gkrellshoot.c
+
+ install:
+- if [ -d /usr/lib/gkrellm/plugins/ ] ; then \
+- install -c -s -m 644 gkrellshoot.so /usr/lib/gkrellm/plugins/ ; \
+- elif [ -d /usr/share/gkrellm/plugins/ ] ; then \
+- install -c -s -m 644 gkrellshoot.so /usr/share/gkrellm/plugins/ ; \
+- elif [ -d /usr/local/lib/gkrellm/plugins/ ] ; then \
+- install -c -s -m 644 gkrellshoot.so /usr/local/lib/gkrellm/plugins/ ; \
+- elif [ -d /usr/lib/gkrellm/plugins/ ] ; then \
+- install -c -s -m 644 gkrellshoot.so /usr/lib/gkrellm/plugins/ ; \
+- else \
+- install -D -c -s -m 644 gkrellshoot.so /usr/lib/gkrellm/plugins/gkrellshoot.so ; \
+- fi
++ install -c -s gkrellshoot.so ${PREFIX}/libexec/gkrellm/plugins
+
+ uninstall:
+- rm -f /usr/lib/gkrellm/plugins/gkrellshoot.so
+- rm -f /usr/share/gkrellm/plugins/gkrellshoot.so
+- rm -f /usr/local/lib/gkrellm/plugins/gkrellshoot.so
+- rm -f /usr/lib/gkrellm/plugins/gkrellshoot.so
++ rm -f $(PLUGIN_DIR)/gkrellshoot.so
+
++all: gkrellshoot.so
diff --git a/misc/gkrellshoot/pkg-comment b/misc/gkrellshoot/pkg-comment
new file mode 100644
index 000000000000..412b9293ea31
--- /dev/null
+++ b/misc/gkrellshoot/pkg-comment
@@ -0,0 +1 @@
+A screen locking and screen capture plugin for GKrellM
diff --git a/misc/gkrellshoot/pkg-descr b/misc/gkrellshoot/pkg-descr
new file mode 100644
index 000000000000..de7ab0280a02
--- /dev/null
+++ b/misc/gkrellshoot/pkg-descr
@@ -0,0 +1,5 @@
+This plugin puts a lock and shoot button on your GKrellM, It uses
+ImageMagick for screen capture and can be configured for your screen
+saver program. Known to work with either Xlock or xscreensaver.
+
+WWW: http://www.geocities.com/m_muthukumar/gkrellshoot.html
diff --git a/misc/gkrellshoot/pkg-plist b/misc/gkrellshoot/pkg-plist
new file mode 100644
index 000000000000..99b0db80569b
--- /dev/null
+++ b/misc/gkrellshoot/pkg-plist
@@ -0,0 +1 @@
+libexec/gkrellm/plugins/gkrellshoot.so