aboutsummaryrefslogtreecommitdiff
path: root/misc/hxtools/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-08-03 06:13:13 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-08-03 06:13:13 +0000
commitf423ead6e5b2e51b0ff08ab3e0f8e846d41223ad (patch)
treee4fd373e96a1da6d9d1a4e56dd2c86b414f49752 /misc/hxtools/Makefile
parent3b1ae2859eb5f049be888649faf57ae50ea1f9b5 (diff)
downloadports-f423ead6e5b2e51b0ff08ab3e0f8e846d41223ad.tar.gz
ports-f423ead6e5b2e51b0ff08ab3e0f8e846d41223ad.zip
This is the collection of tools and scripts for different tasks written
by Jan Engelhardt, each of which seems to be too small to warrant their own project. WWW: http://inai.de/projects/hxtools/
Notes
Notes: svn path=/head/; revision=544024
Diffstat (limited to 'misc/hxtools/Makefile')
-rw-r--r--misc/hxtools/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/misc/hxtools/Makefile b/misc/hxtools/Makefile
new file mode 100644
index 000000000000..2064375b1f73
--- /dev/null
+++ b/misc/hxtools/Makefile
@@ -0,0 +1,52 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= hxtools
+DISTVERSION= 20200712
+CATEGORIES= misc
+MASTER_SITES= http://inai.de/files/hxtools/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Collection of miscellaneous tools and scripts
+
+LIB_DEPENDS= libHX.so:lang/libhx libpci.so:devel/libpci
+RUN_DEPENDS= bash:shells/bash
+
+USES= compiler:c++11-lang iconv perl5 pkgconfig shebangfix \
+ tar:xz xorg
+GNU_CONFIGURE= yes
+SHEBANG_FILES= data/hxtools_bashrc.bash data/hxtools_profile.bash \
+ examples/colortable examples/git-deconstruct examples/neon \
+ examples/rc4 examples/unitable sadmin/hxnetload \
+ sadmin/ldif-duplicate-attrs sadmin/ldif-leading-spaces \
+ sadmin/logontime sadmin/pmap_dirty sadmin/recursive_lower \
+ sadmin/vcsaview sdevel/checkbrack sdevel/cwdiff \
+ sdevel/diff2php sdevel/doxygen-kerneldoc-filter \
+ sdevel/git-author-stat sdevel/git-blame-stats \
+ sdevel/git-forest sdevel/git-revert-stats \
+ sdevel/git-track sdevel/man2html sdevel/paddrspacesize \
+ sdevel/proc_stat_signal_decode sdevel/sourcefuncsize \
+ sdevel/spec-beautifier smm/aumeta smm/extract_d3pkg \
+ smm/extract_dfqshared.pm smm/extract_dxhog \
+ smm/extract_f3pod smm/extract_qupak smm/gpsh smm/mkvappend \
+ smm/mod2opus smm/ssa2srt suser/fxterm suser/mailsplit \
+ suser/pegrep suser/pesubst suser/qpdecode suser/qtar \
+ suser/rezip suser/wktimer
+USE_PERL5= run
+USE_XORG= xcb
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-patch:
+ @${REINPLACE_CMD} -E 's,(/usr)?/bin,${LOCALBASE}/bin,g' \
+ ${WRKSRC}/sadmin/su1
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/NEWS.txt ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>