aboutsummaryrefslogtreecommitdiff
path: root/misc/jargon/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>1999-04-15 20:44:57 +0000
committerMichael Haro <mharo@FreeBSD.org>1999-04-15 20:44:57 +0000
commitea40f6c11572b20a8f790abc29628a1a805dae76 (patch)
tree6ccdadfaab89d183eff863f0ff40874102d6e265 /misc/jargon/Makefile
parentba0f8cda026d4d20562d7ec30542259e531f0bc7 (diff)
downloadports-ea40f6c11572b20a8f790abc29628a1a805dae76.tar.gz
ports-ea40f6c11572b20a8f790abc29628a1a805dae76.zip
Update from 4.0.0 to 4.1.0
Notes
Notes: svn path=/head/; revision=17896
Diffstat (limited to 'misc/jargon/Makefile')
-rw-r--r--misc/jargon/Makefile37
1 files changed, 18 insertions, 19 deletions
diff --git a/misc/jargon/Makefile b/misc/jargon/Makefile
index 691a7f2e6b34..8c21f6e9afb0 100644
--- a/misc/jargon/Makefile
+++ b/misc/jargon/Makefile
@@ -3,33 +3,32 @@
# Date created: 11 July 1998
# Whom: moeding
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/07/13 03:58:11 mph Exp $
#
-DISTNAME= jarg400.info
-PKGNAME= jargon-4.0.0
+DISTNAME= jargon-4.1.0
CATEGORIES= misc
-MASTER_SITES= http://sagan.earthspace.net/jargon/
-EXTRACT_SUFX= .gz
+MASTER_SITES= http://www.tuxedo.org/~esr/jargon/
MAINTAINER= s.moeding@ndh.net
-NO_WRKSUBDIR= YES
-EXTRACT_CMD= ${GZCAT}
-EXTRACT_BEFORE_ARGS= # None
-EXTRACT_AFTER_ARGS= > ${WRKSRC}/jargon.info
NO_BUILD= YES
-do-install:
- @${INSTALL_DATA} ${WRKSRC}/jargon.info ${PREFIX}/info
+FILES= jarghist.html mirroring.html alternates.html jarginfo.html mirrorlist.html awards.html quoting.html search.html jargon-upd.lst submissions.html index.html jargtxt.html
-post-install:
- @if [ ! -f ${PREFIX}/info/dir ]; then \
- ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
- fi
- @install-info \
- --section="Miscellaneous" \
- --entry="* Jargon: (jargon). The hacker's dictionary." \
- ${PREFIX}/info/jargon.info ${PREFIX}/info/dir
+post-patch:
+ /usr/bin/perl -pi -e 's,/home/httpd/html,${PREFIX}/www/data,' ${WRKSRC}/jargon-search
+do-install:
+ @${MKDIR} ${PREFIX}/www/cgi-bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/jargon-search ${PREFIX}/www/cgi-bin
+ @${MKDIR} ${PREFIX}/www/data/jargon
+.for file in ${FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/www/data/jargon
+.endfor
+ @${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${PREFIX}/www/data/jargon
+ @${CP} -R ${WRKSRC}/graphics ${PREFIX}/www/data/jargon/
+ @${CP} -R ${WRKSRC}/html ${PREFIX}/www/data/jargon/
+ @${MKDIR} ${PREFIX}/share/doc/jargon
+ @${INSTALL_DATA} ${WRKSRC}/jargon-README ${PREFIX}/share/doc/jargon
.include <bsd.port.mk>