aboutsummaryrefslogtreecommitdiff
path: root/misc/kdeutils4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
commitcb8b1428c6bb9ed135f61a9cecbe8397defbf329 (patch)
tree0a68a09c88303888985b47f7045bed36788aefc2 /misc/kdeutils4
parent563bcaab10c891e4bee07c4ec1fbf46515c5a0b4 (diff)
downloadports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.tar.gz
ports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.zip
KDE/FreeBSD team presents KDE SC 4.9.5 ports!
- kdebindings ports have been renamed to match upstream. - kdemultimedia and kdenetwork have been split. - New port games/pairs added. - Trim Makefile header - Convert to new option framework - New USE_KDE4 components: libkcddb, libkcompactdisc - Update: databases/akonadi to 1.9.0 devel/grantlee to 0.3.0 textproc/rasqal to 0.9.30 textproc/redland-bindings to 1.0.16.1 textproc/soprano to 2.9.0 x11-toolkits/attica to 0.4.1 The area51 repository features commits by Schaich Alonso, avilla, dbn, jhale, makc and rakuco. Contributors: - Oleg Sidorkin - Tobias Berner - Kurt Jaeger
Notes
Notes: svn path=/head/; revision=311483
Diffstat (limited to 'misc/kdeutils4')
-rw-r--r--misc/kdeutils4/Makefile62
1 files changed, 32 insertions, 30 deletions
diff --git a/misc/kdeutils4/Makefile b/misc/kdeutils4/Makefile
index e704a98daec0..6f80fce07f72 100644
--- a/misc/kdeutils4/Makefile
+++ b/misc/kdeutils4/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: kdeutils
-# Date created: 2008-01-31
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
PORTNAME= kdeutils
@@ -18,71 +15,76 @@ LATEST_LINK= ${PORTNAME}4
USE_KDE4= kdeprefix
NO_BUILD= yes
-OPTIONS= ARK "Install archiving tool Ark" on \
- FILELIGHT "Install file system viewer Filelight" on \
- KCALC "Install scientific calculator KCalc" on \
- KCHARSELECT "Install character selector KCharSelect" on \
- KDF "Install disk usage tool KDiskFree" on \
- KFLOPPY "Install floppy formatter KFloppy" on \
- KGPG "Install encryption tool KGpg" on \
- KREMOTECONTROL "Install KRemoteControl" on \
- KTIMER "Install countdown launcher KTimer" on \
- KWALLET "Install password manager KWallet" on \
- PRINTER_APPLET "Install printer system tray utility" on \
- SUPERKARAMBA "Install widget framework SuperKaramba" on \
- SWEEPER "Install system cleaner Sweeper" on
+OPTIONS_DEFINE= ARK FILELIGHT KCALC KCHARSELECT KDF KFLOPPY KGPG \
+ KREMOTECONTROL KTIMER KWALLET PRINTER_APPLET \
+ SUPERKARAMBA SWEEPER
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+
+ARK_DESC= Install archiving tool Ark
+FILELIGHT_DESC= Install file system viewer Filelight
+KCALC_DESC= Install scientific calculator KCalc
+KCHARSELECT_DESC= Install character selector KCharSelect
+KDF_DESC= Install disk usage tool KDiskFree
+KFLOPPY_DESC= Install floppy formatter KFloppy
+KGPG_DESC= Install encryption tool KGpg
+KREMOTECONTROL_DESC= Install KRemoteControl
+KTIMER_DESC= Install countdown launcher KTimer
+KWALLET_DESC= Install password manager KWallet
+PRINTER_APPLET_DESC= Install printer system tray utility
+SUPERKARAMBA_DESC= Install widget framework SuperKaramba
+SWEEPER_DESC= Install system cleaner Sweeper
.include <bsd.port.options.mk>
-.ifdef(WITH_ARK)
+.if ${PORT_OPTIONS:MARK}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/ark:${PORTSDIR}/archivers/ark
.endif
-.ifdef(WITH_FILELIGHT)
+.if ${PORT_OPTIONS:MFILELIGHT}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/filelight:${PORTSDIR}/sysutils/filelight-kde4
.endif
-.ifdef(WITH_KCALC)
+.if ${PORT_OPTIONS:MKCALC}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kcalc:${PORTSDIR}/math/kcalc
.endif
-.ifdef(WITH_KCHARSELECT)
+.if ${PORT_OPTIONS:MKCHARSELECT}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kcharselect:${PORTSDIR}/deskutils/kcharselect
.endif
-.ifdef(WITH_KDF)
+.if ${PORT_OPTIONS:MKDF}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kdf:${PORTSDIR}/sysutils/kdf
.endif
-.ifdef(WITH_KFLOPPY)
+.if ${PORT_OPTIONS:MKFLOPPY}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kfloppy:${PORTSDIR}/sysutils/kfloppy
.endif
-.ifdef(WITH_KGPG)
+.if ${PORT_OPTIONS:MKGPG}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kgpg:${PORTSDIR}/security/kgpg-kde4
.endif
-.ifdef(WITH_KREMOTECONTROL)
+.if ${PORT_OPTIONS:MKREMOTECONTROL}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/krcdnotifieritem:${PORTSDIR}/comms/kremotecontrol
.endif
-.ifdef(WITH_KTIMER)
+.if ${PORT_OPTIONS:MKTIMER}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/ktimer:${PORTSDIR}/x11-clocks/ktimer
.endif
-.ifdef(WITH_KWALLET)
+.if ${PORT_OPTIONS:MKWALLET}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kwalletmanager:${PORTSDIR}/security/kwallet
.endif
-.ifdef(WITH_PRINTER_APPLET)
+.if ${PORT_OPTIONS:MPRINTER_APPLET}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
.endif
-.ifdef(WITH_SUPERKARAMBA)
+.if ${PORT_OPTIONS:MSUPERKARAMBA}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/superkaramba:${PORTSDIR}/deskutils/superkaramba
.endif
-.ifdef(WITH_SWEEPER)
+.if ${PORT_OPTIONS:MSWEEPER}
RUN_DEPENDS+= ${KDE4_PREFIX}/bin/sweeper:${PORTSDIR}/sysutils/sweeper
.endif