aboutsummaryrefslogtreecommitdiff
path: root/misc/kf5-purpose/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-02-15 17:05:45 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-02-15 17:05:45 +0000
commitc8a04c8cdc48270a69cb1f935e62ab84a42463ec (patch)
tree285c74765e63d1d9602d357c11b291eabf0cd535 /misc/kf5-purpose/Makefile
parent20abeb677475a7af9404d9f99fe59df400984823 (diff)
downloadports-c8a04c8cdc48270a69cb1f935e62ab84a42463ec.tar.gz
ports-c8a04c8cdc48270a69cb1f935e62ab84a42463ec.zip
Update KDE Frameworks to 5.43.0
PR: 225869 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D14287
Notes
Notes: svn path=/head/; revision=461936
Diffstat (limited to 'misc/kf5-purpose/Makefile')
-rw-r--r--misc/kf5-purpose/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/misc/kf5-purpose/Makefile b/misc/kf5-purpose/Makefile
new file mode 100644
index 000000000000..af9a42747570
--- /dev/null
+++ b/misc/kf5-purpose/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= purpose
+DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= misc kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Offers available actions for a specific purpose
+
+USES= cmake:outsource compiler:c++11-lang gettext \
+ kde:5 pkgconfig tar:xz
+USE_GNOME= intltool
+USE_KDE= config coreaddons ecm i18n kdeclarative kio service widgetsaddons
+USE_QT5= core dbus gui network qml widgets xml \
+ buildtools_build qmake_build
+
+.include <bsd.port.mk>