aboutsummaryrefslogtreecommitdiff
path: root/misc/libisocodes/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-02-24 22:15:01 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-02-24 22:15:01 +0000
commit44a098df42f711a7cf387acc33139964d8ce7c05 (patch)
tree5c30864841ba608ac935240881d9eb54754fcd66 /misc/libisocodes/Makefile
parent18d0289d459968ea28afd012df38849e476aa223 (diff)
downloadports-44a098df42f711a7cf387acc33139964d8ce7c05.tar.gz
ports-44a098df42f711a7cf387acc33139964d8ce7c05.zip
Add libisocodes.
A interaction library for iso-codes 3.x and 4.x (when released).
Notes
Notes: svn path=/head/; revision=345902
Diffstat (limited to 'misc/libisocodes/Makefile')
-rw-r--r--misc/libisocodes/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/misc/libisocodes/Makefile b/misc/libisocodes/Makefile
new file mode 100644
index 000000000000..bff010139680
--- /dev/null
+++ b/misc/libisocodes/Makefile
@@ -0,0 +1,32 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libisocodes
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= http://pkg-isocodes.alioth.debian.org/downloads/
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Interaction library for iso-codes
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
+LIB_DEPENDS= libgee.so:${PORTSDIR}/devel/libgee06
+RUN_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes
+
+USE_XZ= yes
+USES= gettext gmake libtool pathfix pkgconfig
+USE_GNOME= glib20 gnomehier introspection:build libxml2
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/xml/|${LOCALBASE}/share/xml/|g' \
+ ${WRKSRC}/src/iso_15924.* ${WRKSRC}/src/iso_3166* \
+ ${WRKSRC}/src/iso_4217.* ${WRKSRC}/src/iso_639* \
+ ${WRKSRC}/src/isocodes.* ${WRKSRC}/tests/test_iso_*.vala
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libisocodes.so.0.0.0
+
+.include <bsd.port.mk>