aboutsummaryrefslogtreecommitdiff
path: root/misc/magicpoint/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-09-02 13:26:34 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-09-02 13:26:34 +0000
commitf86cad0ce3a80127b2912301315fa7dac042002d (patch)
tree724d013a376d218986fefc586ed681b8c219eeb7 /misc/magicpoint/Makefile
parent4e55a9215df0dcffaf32acdc58dfda0cb691838c (diff)
downloadports-f86cad0ce3a80127b2912301315fa7dac042002d.tar.gz
ports-f86cad0ce3a80127b2912301315fa7dac042002d.zip
Two imake related changes:
1) Move -a from XMKMF command variable to a new XMKMF_ARGS variable. For ports that don't need -a introduce USES=imake:notall. This way ports no longer have to redefine XMKMF. 2) xmkmf -a runs imake with the flags in IMAKECPPFLAGS as extra arguments to set CPP, CC and CXX. This creates the top Makefile, and then xmkmf runs make Makefiles. This Makefiles target runs imake for each subdirectory but these imake invocations did not have the flags from IMAKECPPFLAGS so the resulting makefiles used the wrong C preprocessor when clang is used (/usr/bin/cpp instead of /usr/local/bin/tradcpp). Instead of letting xmkmf pass IMAKECPPFLAGS from the environment to imake let imake handle IMAKECPPFLAGS itself just like it handles IMAKEINCLUDE. This exposed configure errors in x11-clocks/mouseclock and x11-wm/fvwm. Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=325992
Diffstat (limited to 'misc/magicpoint/Makefile')
-rw-r--r--misc/magicpoint/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index 7c786cc9703b..2f72854ccfbf 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -83,7 +83,7 @@ post-patch:
${WRKSRC}/configure
post-configure:
- (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${MAKE_ENV} ${XMKMF})
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${MAKE_ENV} ${XMKMF} ${XMKMF_ARGS})
cd ${WRKSRC}/contrib/xmindpath && \
${SH} ${CONFIGURE_SCRIPT} --prefix=${PREFIX}