aboutsummaryrefslogtreecommitdiff
path: root/misc/magicpoint
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-26 12:29:17 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-26 12:29:17 +0000
commitdc09c9fc7bb76e95151d800345b086d854acbf0f (patch)
tree7d36f74f12fc412326c2eab3aef16a2b6f363254 /misc/magicpoint
parent7335a2e374b1702cda4494b16c34d46e9f7edd19 (diff)
downloadports-dc09c9fc7bb76e95151d800345b086d854acbf0f.tar.gz
ports-dc09c9fc7bb76e95151d800345b086d854acbf0f.zip
- Add missing run dependency on perl
- Fix shebangs - Allow building with either giflib 4.2 or 5.0
Notes
Notes: svn path=/head/; revision=375619
Diffstat (limited to 'misc/magicpoint')
-rw-r--r--misc/magicpoint/Makefile6
-rw-r--r--misc/magicpoint/files/patch-gif.c86
2 files changed, 80 insertions, 12 deletions
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index 72bec5230278..787fbeeb7e6d 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= magicpoint
PORTVERSION= 1.13a
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES?= misc
MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/
@@ -18,11 +18,13 @@ RUN_DEPENDS+= pnmscale:${PORTSDIR}/graphics/netpbm
MAKE_JOBS_UNSAFE= yes
-USES= imake:env pkgconfig
+USES= imake:env perl5 pkgconfig
+USE_PERL5= run
USE_XORG= x11 xext xmu xt sm ice xi xtst
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-vflib --enable-locale
+CONFIGURE_ENV= mgp_cv_path_perl=${PERL}
CPPFLAGS+= -I..
LATE_INSTALL_ARGS= install.man
diff --git a/misc/magicpoint/files/patch-gif.c b/misc/magicpoint/files/patch-gif.c
index 3c19c5cddca6..743dc56f62d3 100644
--- a/misc/magicpoint/files/patch-gif.c
+++ b/misc/magicpoint/files/patch-gif.c
@@ -1,81 +1,147 @@
---- image/gif.c.orig 2000-03-07 07:59:56.000000000 +0100
-+++ image/gif.c 2012-06-02 09:10:25.000000000 +0200
-@@ -19,6 +19,17 @@
+--- image/gif.c.orig 2000-03-07 06:59:56 UTC
++++ image/gif.c
+@@ -15,10 +15,31 @@
+
+ #ifdef USE_GIF
+
++#include <stdlib.h>
+ #include "image.h"
#include <gif_lib.h>
static void
++#if GIFLIB_MAJOR >= 5
++localPrintGifError(int ErrorCode)
++#else
+localPrintGifError(void)
++#endif
+{
++#if GIFLIB_MAJOR >= 5
++ char *Err = GifErrorString(ErrorCode);
++#else
+ char *Err = GifErrorString();
++ int ErrorCode = GifError();
++#endif
+
+ if (Err != NULL)
+ fprintf(stderr, "\nGIF-LIB error: %s.\n", Err);
+ else
-+ fprintf(stderr, "\nGIF-LIB undefined error %d.\n", GifError());
++ fprintf(stderr, "\nGIF-LIB undefined error %d.\n", ErrorCode);
+}
+
+static void
tellAboutImage(name, gifp)
char *name;
GifFileType *gifp;
-@@ -87,13 +98,13 @@
+@@ -50,7 +71,11 @@ gifLoad(fullname, name, verbose)
+ ColorMapObject *ColorMap;
+ GifColorType *ColorMapEntry;
+
++#if GIFLIB_MAJOR >= 5
++ GifFile = DGifOpenFileName(fullname, NULL);
++#else
+ GifFile = DGifOpenFileName(fullname);
++#endif
+ if (GifFile == NULL)
+ return NULL;
+
+@@ -87,13 +112,21 @@ gifLoad(fullname, name, verbose)
/* Scan the content of the GIF file and load the image(s) in: */
do {
if (DGifGetRecordType(GifFile, &RecordType) == GIF_ERROR) {
- PrintGifError();
++#if GIFLIB_MAJOR >= 5
++ localPrintGifError(GifFile->Error);
++#else
+ localPrintGifError();
++#endif
exit(-1);
}
switch (RecordType) {
case IMAGE_DESC_RECORD_TYPE:
if (DGifGetImageDesc(GifFile) == GIF_ERROR) {
- PrintGifError();
++#if GIFLIB_MAJOR >= 5
++ localPrintGifError(GifFile->Error);
++#else
+ localPrintGifError();
++#endif
exit(-1);
}
Row = GifFile->Image.Top; /* Image Position relative to Screen. */
-@@ -113,7 +124,7 @@
+@@ -113,7 +146,11 @@ gifLoad(fullname, name, verbose)
j += InterlacedJumps[i]) {
if (DGifGetLine(GifFile, &ScreenBuffer[j][Col],
Width) == GIF_ERROR) {
- PrintGifError();
++#if GIFLIB_MAJOR >= 5
++ localPrintGifError(GifFile->Error);
++#else
+ localPrintGifError();
++#endif
exit(-1);
}
}
-@@ -122,7 +133,7 @@
+@@ -122,7 +159,11 @@ gifLoad(fullname, name, verbose)
for (i = 0; i < Height; i++) {
if (DGifGetLine(GifFile, &ScreenBuffer[Row++][Col],
Width) == GIF_ERROR) {
- PrintGifError();
++#if GIFLIB_MAJOR >= 5
++ localPrintGifError(GifFile->Error);
++#else
+ localPrintGifError();
++#endif
exit(-1);
}
}
-@@ -131,7 +142,7 @@
+@@ -131,7 +172,11 @@ gifLoad(fullname, name, verbose)
case EXTENSION_RECORD_TYPE:
/* Skip any extension blocks in file: */
if (DGifGetExtension(GifFile, &ExtCode, &Extension) == GIF_ERROR) {
- PrintGifError();
++#if GIFLIB_MAJOR >= 5
++ localPrintGifError(GifFile->Error);
++#else
+ localPrintGifError();
++#endif
exit(-1);
}
/* very adhoc transparency support */
-@@ -141,7 +152,7 @@
+@@ -141,7 +186,11 @@ gifLoad(fullname, name, verbose)
}
while (Extension != NULL) {
if (DGifGetExtensionNext(GifFile, &Extension) == GIF_ERROR) {
- PrintGifError();
++#if GIFLIB_MAJOR >= 5
++ localPrintGifError(GifFile->Error);
++#else
+ localPrintGifError();
++#endif
exit(-1);
}
}
-@@ -180,7 +191,7 @@
+@@ -180,7 +229,11 @@ gifLoad(fullname, name, verbose)
}
if (DGifCloseFile(GifFile) == GIF_ERROR) {
- PrintGifError();
++#if GIFLIB_MAJOR >= 5
++ localPrintGifError(GifFile->Error);
++#else
+ localPrintGifError();
++#endif
exit(-1);
}
+@@ -196,7 +249,11 @@ gifIdent(fullname, name)
+ GifFileType *gifp;
+ int ret;
+
++#if GIFLIB_MAJOR >= 5
++ gifp = DGifOpenFileName(fullname, NULL);
++#else
+ gifp = DGifOpenFileName(fullname);
++#endif
+ if (gifp == NULL)
+ ret = 0;
+ else {